انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۰٫۱۰ منتشر شد.
انتظار می‌ره همهٔ اعضا هرچه زودتر به این نگارش ارتقا پیدا کنند. همهٔ پاسخ‌ها از این به بعد، بر پایهٔ اوبونتو ۲۰٫۱۰ خواهد بود.

نویسنده موضوع: لود نشدن اکستنشن‌های گنوم شل [حل شد]  (دفعات بازدید: 1625 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین Midgårdsormen

  • Hero Member
  • *
  • ارسال: 900
  • جنسیت : پسر
من از اوبونتو 13.10 به همراه گنوم شل 3.10.0.1 که از ppa نصبش کردم استفاده میکنم
هر بار که گنوم اجرا میشه، مجبورم اکستنشنا رو دستی از طریق Gnome Tweak Tool فعالشون کنم
وقتی فعالشون میکنم، میبینم که محتویات enabled-extensions در org.gnome.shell بدون مشکل افزونه‌های فعال شده رو نشون میده
راهی هست که هر بار موقع اجرای گنوم شل، این افزونه‌ها به شکل خودکار لود بشن؟

اگه این باگه و باید منتظر رفعش بمونم، شنیدم که از طریق dbus میشه اکستنشای گنوم شلو فعّال/غیرفعّال کرد
سینتکسش چه جوریه؟
میخوام دستورشو بذارم تو یه اسکریپت و به Starup Applications اضافه کنم
« آخرین ویرایش: 08 مهر 1392، 07:50 ق‌ظ توسط Midgårdsormen »

آفلاین Midgårdsormen

  • Hero Member
  • *
  • ارسال: 900
  • جنسیت : پسر
پاسخ : لود نشدن اکستنشن‌های گنوم شل
« پاسخ #1 : 08 مهر 1392، 07:48 ق‌ظ »
با احمقانه‌ترین workaround ممکن حل شد
محتویات اسکریپتی که به Startup Applications اضافه‌ش کردم:
#!/bin/sh -e
sleep 2
gsettings set org.gnome.shell enabled-extensions "['alternative-status-menu@gnome-shell-extensions.gcampax.github.com', 'alternate-tab@gnome-shell-extensions.gcampax.github.com', 'drop-down-terminal@gs-extensions.zzrough.org', 'GPaste@gnome-shell-extensions.gnome.org', 'places-menu@gnome-shell-extensions.gcampax.github.com', 'user-theme@gnome-shell-extensions.gcampax.github.com']"

اون دستور sleep رو برای این گذاشتم که خیالم راحت باشه که حتما بعد از لود شدن کامل گنوم اکستنشنا اجرا میشن
شاید نیازی به گذاشتنش نباشه