انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۰.۰۴ منتشر شد.
انتظار می‌ره همهٔ اعضا هرچه زودتر به این نگارش ارتقا پیدا کنند. همهٔ پاسخ‌ها از این به بعد، بر پایهٔ اوبونتو ۲۰.۰۴ خواهد بود.

نویسنده موضوع: مشکل در کلیدهای ترکیبی لایه های کیبرد (اسلکور+فلاکس باکس)  (دفعات بازدید: 1513 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین The Dude

  • Sr. Member
  • *
  • ارسال: 285
  • جنسیت : پسر
با سلام
من توی ویکی فلاکس باکس اینو پیدا کردم. غیر از کلیدهای ترکیبیش، بقیه ش درست کار میکنه. این کد توی آدرس /etc/default/keyboard ذخیره شده.
XKBMODEL="pc105"
XKBLAOUT="us,ir"
XKBVARIANT=" ,pes_keypad"
XKBOPTIONS="lv3:ralt_switch,compose:lwin,grp:alt_shift_toggle"
مشکل اصلی اینه که اون آلت+شیفت که خط آخر نوشته کار نمیکنه. لطفا راهنمایی کنید. باید از توی منو، لایه ی کیبرد رو عوض کنم.
و اگه کسی هم لطف کنه خط اول و آخر رو توضیح بده ممنون میشم. pc105 و خط آخر کلا یعنی چی؟ دقیقا چیکار میکنن.

آفلاین אוּרִיאֵל

  • High Sr. Member
  • *
  • ارسال: 641
  • جنسیت : پسر
  • bin/Matin/ !#
    • bin/Matin/ !#
اين چيز خاصى نيست قاعدتا هم بايد كار بده شما اول امتحان كنيد ببينيد با setxkbmap ir كيبوردتون فارسى ميشه يا نه اگه شد من يه راه ديگه واستون ميگم كه همينو انجام بده .

آفلاین The Dude

  • Sr. Member
  • *
  • ارسال: 285
  • جنسیت : پسر
با اون کار میکنه. من مشکلم کلیدهای ترکیبیه. باید توی دسکتاپ راست کلیک کنم، از زیرمنوی کیبرد (که باید خودم اضافه میکردم - پیکربندی منوی فلاکس کار راحتیه) انتخاب کنم که فارسی یا انگلیسی باشه. اگه یه کلمه ی انگلیسی بخوام بین متن فارسی تایپ کنم، باید برم منوی دسکتاپ.
« آخرین ویرایش: 19 شهریور 1392، 07:01 ب‌ظ توسط پسر کوچولو »

آفلاین אוּרִיאֵל

  • High Sr. Member
  • *
  • ارسال: 641
  • جنسیت : پسر
  • bin/Matin/ !#
    • bin/Matin/ !#
 توى اين فايل
/etc/X11/xinit/xintrcاين رو بزار :
setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,ir

آفلاین The Dude

  • Sr. Member
  • *
  • ارسال: 285
  • جنسیت : پسر
اون فایل دو قسمت مدیر پنجره و یکی دیگه داره که مربوط به کیمپ و غیره ست. و هردوتاشون هم if ,fi دارن. دقیقا کجاش باید اونو بذارم؟

آفلاین אוּרִיאֵל

  • High Sr. Member
  • *
  • ارسال: 641
  • جنسیت : پسر
  • bin/Matin/ !#
    • bin/Matin/ !#
آخرش بزار ريبوت كن اگه نشد بعد بگو تا ببينم مشكل از كجا بوده .

آفلاین The Dude

  • Sr. Member
  • *
  • ارسال: 285
  • جنسیت : پسر
هنوزم کلیدهای ترکیبی کار نمیکنه. البته فکر کنم این نکته هم قابل توجه باشه که اون خطی که اضافه کردم به صورت متن ساده ست ( فقط مشکی)

آفلاین אוּרִיאֵל

  • High Sr. Member
  • *
  • ارسال: 641
  • جنسیت : پسر
  • bin/Matin/ !#
    • bin/Matin/ !#
هنوزم کلیدهای ترکیبی کار نمیکنه. البته فکر کنم این نکته هم قابل توجه باشه که اون خطی که اضافه کردم به صورت متن ساده ست ( فقط مشکی)

بايد به چه صورت ميبود مگه ؟

+ به اين صورت ويرايشش كن :
exec setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,ir
« آخرین ویرایش: 20 شهریور 1392، 08:07 ق‌ظ توسط אוּרִיאֵל »

آفلاین The Dude

  • Sr. Member
  • *
  • ارسال: 285
  • جنسیت : پسر
از اون جهت میگم متن ساده که فایلهای پیکربندی معمولا بسته به سینتکسش رنگی میشه.

هنوزم کار نمیکنه. نباید توی اون if, fiها بذارمش؟ یا یه دستوری که یه کار خاصی قبلش بکنه؟ (این کارا رو بلد نیستم. گفتم شاید احتمال داشته باشه.)
توی ویکی فلاکس فقط همون قدر نوشته بود. اون فایل پیکربندی جدید که کد چهار خطی پست اول بود، به اضافه ی ویرایش فایل پیکربندی منوی دسکتاپ که گزینه های لایه ی کیبرد بهش اضافه میشد. ( که من از همون منو برای عوض کردن زبان کیبرد استفاده میکنم.)
« آخرین ویرایش: 20 شهریور 1392، 11:26 ق‌ظ توسط پسر کوچولو »

آفلاین אוּרִיאֵל

  • High Sr. Member
  • *
  • ارسال: 641
  • جنسیت : پسر
  • bin/Matin/ !#
    • bin/Matin/ !#
با startx ميارى بالا fluxbox رو يا با dm ها ؟

آفلاین The Dude

  • Sr. Member
  • *
  • ارسال: 285
  • جنسیت : پسر
با startx میارم. اصلا کی دی ای یا گنوم نصب ندارم. راستی dm با de فرق میکنه؟ همون desktop environment منظورمه.