انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

نویسنده موضوع: یک روش بسیار ساده برای به اشتراک گذازی فایل (اوبونتو - سامبا - ویندوز)  (دفعات بازدید: 28341 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین مهدی پیشگوی

  • High Hero Member
  • *
  • ارسال: 3100
  • جنسیت : پسر
  • لينوكس يعني آزادي ، امنيت
کاری از پیش نبردم . مشکل این جا هم هستش که همدیکه رو به راحتی پینگ می کنن ولی نه smb4k و نه کانکرر قادر به نمایش شاخه های به اشتراک گذاری شده نیست

آفلاین کرگدن

  • High Hero Member
  • *
  • ارسال: 1769
  • جنسیت : پسر
کاری از پیش نبردم . مشکل این جا هم هستش که همدیکه رو به راحتی پینگ می کنن ولی نه smb4k و نه کانکرر قادر به نمایش شاخه های به اشتراک گذاری شده نیست

رو هر ماشین با namp localhost  ببینید اینارو داریر یا نه

139/tcp  open  netbios-ssn
445/tcp  open  microsoft-ds
فایروالتون هم برای امتحان یک بار ببنید

در addressbar اینو بزنید

smb://192.168.1.1

ip ماشینی که می خواید فایلها رو ببینید ( برای ماشین خودتون localhost)

 Vaio-VPCCW - core i7 -Nvidia GT320M -4GB -OS Fedora 20/ kde 4.12
Vbox: Centos 6.4 (server) / Archlinux

آفلاین مهدی پیشگوی

  • High Hero Member
  • *
  • ارسال: 3100
  • جنسیت : پسر
  • لينوكس يعني آزادي ، امنيت
وقتی smb://192.168.0.1 رو میزنم بلی نشون میده ولی وقت می زنم /:smb که خودش نشون بده . نه اصلا . فایروالی هم نصب نکردم .
اون دو تا خط بلی وقتی پورت رو اسکن می کنم نشون میده

آفلاین کرگدن

  • High Hero Member
  • *
  • ارسال: 1769
  • جنسیت : پسر
وقتی smb://192.168.0.1 رو میزنم بلی نشون میده ولی وقت می زنم /:smb که خودش نشون بده . نه اصلا . فایروالی هم نصب نکردم .
اون دو تا خط بلی وقتی پورت رو اسکن می کنم نشون میده

خب پس samba تون مشکلی نداره و داره کار می کنه ؟:)

و فقط workgroup رو اون اول نشون نمیده؟
یعنی با آدرس مستقیم می تونید بهش وصل بشید دیگه؟

 Vaio-VPCCW - core i7 -Nvidia GT320M -4GB -OS Fedora 20/ kde 4.12
Vbox: Centos 6.4 (server) / Archlinux

آفلاین مهدی پیشگوی

  • High Hero Member
  • *
  • ارسال: 3100
  • جنسیت : پسر
  • لينوكس يعني آزادي ، امنيت
با آدرس مستقیم به کیس دیگه نه . فقط میتونم پینگش کنم .
بلی ورک گروپ رو نشون نمی ده .
کیس بعدی که آدرسش 192.168.0.1 هستش پینگ میشه ولی با آدرس smb:/192.168.0.1 نمی تونم وصل بشم

آفلاین کرگدن

  • High Hero Member
  • *
  • ارسال: 1769
  • جنسیت : پسر
با آدرس مستقیم به کیس دیگه نه . فقط میتونم پینگش کنم .
بلی ورک گروپ رو نشون نمی ده .
کیس بعدی که آدرسش 192.168.0.1 هستش پینگ میشه ولی با آدرس smb:/192.168.0.1 نمی تونم وصل بشم

البته این درسته
smb://192.168.0.1

اگه اینم مشکل داشت :)

فایروال هم همراه کرنلتون هست :)




sudo iptables -A INPUT -p udp -d $SAMBA_SERVER -m multiport --dports 137,138 -j DROP
sudo iptables -A INPUT -p tcp -d $SAMBA_SERVER -m multiport --dports 139,445 -j DROP

به جای $SAMBA_SERVER
ip ماشین مقابل رو بدید ( در هر دو)

می تونید یک رابط گرافیکی هم براش نصب کنید
firestarter یکیشه ( خیلی رابط های زیادی داره و این ساده ترینشونه  kmyfirewall هم هست )




 Vaio-VPCCW - core i7 -Nvidia GT320M -4GB -OS Fedora 20/ kde 4.12
Vbox: Centos 6.4 (server) / Archlinux

آفلاین مهدی پیشگوی

  • High Hero Member
  • *
  • ارسال: 3100
  • جنسیت : پسر
  • لينوكس يعني آزادي ، امنيت
سلام . باز هم تاثیری نداشت متاسفانه .

آفلاین مهدی پیشگوی

  • High Hero Member
  • *
  • ارسال: 3100
  • جنسیت : پسر
  • لينوكس يعني آزادي ، امنيت
الان وقتی /:smb رو میزنم خطای فایروال و workgroup رو میده

آفلاین کرگدن

  • High Hero Member
  • *
  • ارسال: 1769
  • جنسیت : پسر
الان وقتی /:smb رو میزنم خطای فایروال و workgroup رو میده

اگه می شه خروجی
iptables -L
رو بگو

می تونی firstarter نصب کنی و ببینی وقتی stop اش می کنی فرق می کنه یا نه؟

 Vaio-VPCCW - core i7 -Nvidia GT320M -4GB -OS Fedora 20/ kde 4.12
Vbox: Centos 6.4 (server) / Archlinux

آفلاین مهدی پیشگوی

  • High Hero Member
  • *
  • ارسال: 3100
  • جنسیت : پسر
  • لينوكس يعني آزادي ، امنيت
پاسخ به: یک روش بسیار ساده برای به اشتراک گذا
« پاسخ #39 : 09 اردیبهشت 1387، 11:02 ق‌ظ »
debian:/home/mahdi# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
تا جایی که فهمیدم فرقی نکرده
kmyfirewall رو نصب کردم و تنظیمش هم کردم ولی باز هم تاثیری نداشت
اکثر این خطا رو میبینم : Unable to find any workgroups in your local network. This might be caused by an enabled firewall.
« آخرین ویرایش: 09 اردیبهشت 1387، 11:12 ق‌ظ توسط مهدی پیشگوی »

آفلاین کرگدن

  • High Hero Member
  • *
  • ارسال: 1769
  • جنسیت : پسر
وقتی اینارو می زدی چیزی نگفت؟

sudo iptables -A INPUT -p udp -d $SAMBA_SERVER -m multiport --dports 137,138 -j DROP
sudo iptables -A INPUT -p tcp -d $SAMBA_SERVER -m multiport --dports 139,445 -j DROP

چون باید تو iptables -nL نشونشون بده ( دوباره بزن چک کن)

ip ماشین مقابل یادت نره :)

 Vaio-VPCCW - core i7 -Nvidia GT320M -4GB -OS Fedora 20/ kde 4.12
Vbox: Centos 6.4 (server) / Archlinux

آفلاین مهدی پیشگوی

  • High Hero Member
  • *
  • ارسال: 3100
  • جنسیت : پسر
  • لينوكس يعني آزادي ، امنيت
راستش هیچ چیزی نگفت و نشون نداد . آی پی رو هم دادم
برای ماشین اول :
sudo iptables -A INPUT -p udp -d $192.168.0.1 -m multiport --dports 137,138 -j DROP
sudo iptables -A INPUT -p tcp -d $192.168.0.1 -m multiport --dports 139,445 -j DROP
برای ماشین دوم هم :
sudo iptables -A INPUT -p udp -d $192.168.0.2 -m multiport --dports 137,138 -j DROP
sudo iptables -A INPUT -p tcp -d $192.168.0.2 -m multiport --dports 139,445 -j DROP

آفلاین کرگدن

  • High Hero Member
  • *
  • ارسال: 1769
  • جنسیت : پسر
راستش هیچ چیزی نگفت و نشون نداد . آی پی رو هم دادم
برای ماشین اول :
sudo iptables -A INPUT -p udp -d $192.168.0.1 -m multiport --dports 137,138 -j DROP
sudo iptables -A INPUT -p tcp -d $192.168.0.1 -m multiport --dports 139,445 -j DROP
برای ماشین دوم هم :
sudo iptables -A INPUT -p udp -d $192.168.0.2 -m multiport --dports 137,138 -j DROP
sudo iptables -A INPUT -p tcp -d $192.168.0.2 -m multiport --dports 139,445 -j DROP

علامت $ برای نمایش متغیر هست :)
نباید قبلش اینو بذارید

یکبار

iptables -f
و بعد دوباره این کار رو بکنید

باید بعد از این کار  این دوتا  رو در iptables -nL ببینید :)


 Vaio-VPCCW - core i7 -Nvidia GT320M -4GB -OS Fedora 20/ kde 4.12
Vbox: Centos 6.4 (server) / Archlinux

آفلاین کرگدن

  • High Hero Member
  • *
  • ارسال: 1769
  • جنسیت : پسر
فکر کنم یه اشتباهی کردم
اینو امتحان کنید

فکر کنم بر عکس فیلتر کرده بودم :(

از رول های خودم دادم که اون زمان بسته بودمش و الان یادم افتاد
sudo iptables -F
sudo sudo iptables -A INPUT -p udp -d 192.168.0.1 -m multiport --dports 137,138 -j ACCEPT
sudo iptables -A INPUT -p tcp -d 192.168.0.1 -m multiport --dports 139,445 -j ACCEPT

sudo iptables -A INPUT -p udp -d 192.168.0.2 -m multiport --dports 137,138 -j ACCEPT
sudo iptables -A INPUT -p tcp -d 192.168.0.2 -m multiport --dports 139,445 -j ACCEPT
« آخرین ویرایش: 12 اردیبهشت 1387، 09:52 ق‌ظ توسط کرگدن »

 Vaio-VPCCW - core i7 -Nvidia GT320M -4GB -OS Fedora 20/ kde 4.12
Vbox: Centos 6.4 (server) / Archlinux

آفلاین مهدی پیشگوی

  • High Hero Member
  • *
  • ارسال: 3100
  • جنسیت : پسر
  • لينوكس يعني آزادي ، امنيت
ولی تا اونجایی که مشخصه کدها فرقی نکردن درسته ؟
باز هم امتحان کردم ولی تاثیری باز نداشت . یعنی شاخه های share شده و هیچ جیز نشون داده نمیشه