انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۰.۰۴ منتشر شد.
انتظار می‌ره همهٔ اعضا هرچه زودتر به این نگارش ارتقا پیدا کنند. همهٔ پاسخ‌ها از این به بعد، بر پایهٔ اوبونتو ۲۰.۰۴ خواهد بود.

نویسنده موضوع: پرل و آپاچی  (دفعات بازدید: 5814 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین میلاد

  • Sr. Member
  • *
  • ارسال: 443
  • جنسیت : پسر
    • وبلاگ شخصی
پرل و آپاچی
« : 06 اسفند 1385، 11:08 ب‌ظ »
سلام
من cgi را بر روی آپاچی فعال کردم اما موقعی که میخوام به صفحه مورد نظرم که پسوند cgi داره مشاهده کنم با پیغام زیر روبرو میشم:
Forbidden

You don't have permission to access /mt/mt.cgi on this server.
میلاد نکوفر، توسعه‌دهنده وب و موبایل

آفلاین وحيد غفارپور

  • Newbie
  • *
  • ارسال: 22
  • جنسیت : پسر
  • what is essential is invisible to the eyes
    • Vahid's Personal Homepage
پاسخ به: پرل و آپاچی
« پاسخ #1 : 07 اسفند 1385، 08:44 ق‌ظ »
سلام
ممكنه www-data اجازه اجرا برروي شاخه مورد نظر را نداشته باشد يا اينكه در تنظيمات apache تنظيمات cgi بودن mt را فراموش كرده ايد!
--Vahid Ghafarpour
http://vahid.ghafarpour.ir
vahid at ghafarpour dot ir

آفلاین Mehdi

  • ناظر ویژه انجمن
  • *
  • ارسال: 3281
  • جنسیت : پسر
    • هزاردستان
پاسخ به: پرل و آپاچی
« پاسخ #2 : 07 اسفند 1385، 01:09 ب‌ظ »
یک بار دستور
sudo chown www-data:www-data destination_folder
رو برای پوشه cgi تون بزنید. (به جای destination_folder مسیر پوشه مورد نظر) اگر مشکل حل نشد تنظیمات vhost رو بگذارید اینجا...
Of one Essence is the human race,
Thusly has Creation put the Base;
One Limb impacted is sufficient,
For all Others to feel the Mace.
~Saadi (persian poet) -1258
Hezardastan | Free As in Freedom

آفلاین میلاد

  • Sr. Member
  • *
  • ارسال: 443
  • جنسیت : پسر
    • وبلاگ شخصی
پاسخ به: پرل و آپاچی
« پاسخ #3 : 07 اسفند 1385، 01:52 ب‌ظ »
سلام
من فایل ها را تو پوشه cgi نزاشتم، در واقع میخوام خارج پوشه cgi استفاده کنم.
میلاد نکوفر، توسعه‌دهنده وب و موبایل

آفلاین میلاد

  • Sr. Member
  • *
  • ارسال: 443
  • جنسیت : پسر
    • وبلاگ شخصی
پاسخ به: پرل و آپاچی
« پاسخ #4 : 07 اسفند 1385، 01:55 ب‌ظ »
تنظیمات virtual host هم به صورت زیره:
<VirtualHost *>
ServerName milad
DocumentRoot /home/milad/public_html
</VirtualHost>
میلاد نکوفر، توسعه‌دهنده وب و موبایل

آفلاین Mehdi

  • ناظر ویژه انجمن
  • *
  • ارسال: 3281
  • جنسیت : پسر
    • هزاردستان
پاسخ به: پرل و آپاچی
« پاسخ #5 : 07 اسفند 1385، 03:22 ب‌ظ »
همین  :o
پس تنظیمات مربوط به cgi چی ؟
Of one Essence is the human race,
Thusly has Creation put the Base;
One Limb impacted is sufficient,
For all Others to feel the Mace.
~Saadi (persian poet) -1258
Hezardastan | Free As in Freedom

آفلاین Mehdi

  • ناظر ویژه انجمن
  • *
  • ارسال: 3281
  • جنسیت : پسر
    • هزاردستان
پاسخ به: پرل و آپاچی
« پاسخ #6 : 07 اسفند 1385، 09:53 ب‌ظ »
شما باید یه خط مثل خط زیر برای cgi داشته باشید
ScriptAlias /cgi-bin/ /PATH_TO/cgi-bin/
Of one Essence is the human race,
Thusly has Creation put the Base;
One Limb impacted is sufficient,
For all Others to feel the Mace.
~Saadi (persian poet) -1258
Hezardastan | Free As in Freedom

آفلاین میلاد

  • Sr. Member
  • *
  • ارسال: 443
  • جنسیت : پسر
    • وبلاگ شخصی
پاسخ به: پرل و آپاچی
« پاسخ #7 : 07 اسفند 1385، 09:57 ب‌ظ »
همین  :o
پس تنظیمات مربوط به cgi چی ؟
اونا را مگه نباید از توی فایل کانفیگ انجام داد!؟
میلاد نکوفر، توسعه‌دهنده وب و موبایل

آفلاین Mehdi

  • ناظر ویژه انجمن
  • *
  • ارسال: 3281
  • جنسیت : پسر
    • هزاردستان
پاسخ به: پرل و آپاچی
« پاسخ #8 : 07 اسفند 1385، 10:13 ب‌ظ »
اول www-data بشید:
sudo -s -u www-data
بعد برید تو مسیر زیر:
cd /etc/apache2/sites-available
یه کپی از default به اسم سایتتون بگیرید: مثلا test.com
cp default test.com
اون جوری که دوست دارید ویرایش کنید: مثال
NameVirtualHost 192.168.0.1
<VirtualHost 192.168.0.1>
        ServerAdmin webmaster@test.com

        DocumentRoot /home/test.com/public_html/
        ServerName www.test.com
        <Directory /home/test.com/public_html/>
                Options FollowSymLinks
                AllowOverride All
        </Directory>

        ScriptAlias /cgi-bin/ /home/test.com/cgi-bin/

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

</VirtualHost>

سایت رو فعال کنید:
a2ensite test.com
enjoy it  ;)

Of one Essence is the human race,
Thusly has Creation put the Base;
One Limb impacted is sufficient,
For all Others to feel the Mace.
~Saadi (persian poet) -1258
Hezardastan | Free As in Freedom

آفلاین میلاد

  • Sr. Member
  • *
  • ارسال: 443
  • جنسیت : پسر
    • وبلاگ شخصی
پاسخ به: پرل و آپاچی
« پاسخ #9 : 07 اسفند 1385، 11:08 ب‌ظ »
سلام
اینجوری که شما گفتی تنظیم کردم الان دیگه کلا بالا نمیاد هیچی!
Forbidden

You don't have permission to access / on this server.
Apache/2.0.55 (Ubuntu) PHP/5.1.6 Server at milad Port 80
میلاد نکوفر، توسعه‌دهنده وب و موبایل

آفلاین وحيد غفارپور

  • Newbie
  • *
  • ارسال: 22
  • جنسیت : پسر
  • what is essential is invisible to the eyes
    • Vahid's Personal Homepage
پاسخ به: پرل و آپاچی
« پاسخ #10 : 08 اسفند 1385، 09:12 ق‌ظ »
حواست به دسترسي‌ها برروي شاخه اصلي باشه حداقل read بده
--Vahid Ghafarpour
http://vahid.ghafarpour.ir
vahid at ghafarpour dot ir

آفلاین میلاد

  • Sr. Member
  • *
  • ارسال: 443
  • جنسیت : پسر
    • وبلاگ شخصی
پاسخ به: پرل و آپاچی
« پاسخ #11 : 11 اسفند 1385، 09:28 ق‌ظ »
حواست به دسترسي‌ها برروي شاخه اصلي باشه حداقل read بده
سلام
دستریش مشکلی نداره وقتی از این استفاده میکردم مشکلی نداشت:
<VirtualHost *>
ServerName milad
DocumentRoot /home/milad/public_html
</VirtualHost>
میلاد نکوفر، توسعه‌دهنده وب و موبایل