انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۰.۰۴ منتشر شد.
انتظار می‌ره همهٔ اعضا هرچه زودتر به این نگارش ارتقا پیدا کنند. همهٔ پاسخ‌ها از این به بعد، بر پایهٔ اوبونتو ۲۰.۰۴ خواهد بود.

نویسنده موضوع: راهنمای جامع نصب مودم و برقراری اتصال به اینترنت  (دفعات بازدید: 133831 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین Dallas1387

  • Newbie
  • *
  • ارسال: 8
  • جنسیت : پسر
نقل‌قول
چه اروری داد؟
سلام سامان جان خسته نباشید
آقا من اون فایل رو دانلود کردم وسط ارور می داد رفتم از سایت لینوکس فایل alsa-driver-linuxant_1.0.20.1_k2.6.28_11_generic_ubuntu_i386.deb.zip v رو دانلود کردم نصبش کردم مشکل حل شد بعد اون پکیجی که شما بهم دادید نصب شد بعد رفتم توی ترمینال دستور sudu pppconfig رو اجرا کردم تنضیمات رو هم انجام دادم اما وقتی دستور pon رو برای اتصال می زنم ارور زیر رو می ده من کلش رو قرار می دم لطفا راهنمایی کنید مشکل کجاست
masood@masood-desktop:~$ pon Irangate
Error: only members of the 'dip' group can use this command.
یه مورد دیگه برای پیکر بندی wvdial هم ارور می ده من کلشو می زارم لطفا کمک کنید
masood@masood-desktop:~$ sudo wvdialconf /etc/wvdial.conf
sudo: wvdialconf: command not found
ممنون

آفلاین ahmed

  • High Hero Member
  • *
  • ارسال: 1069
  • جنسیت : پسر
    • یادداشت‌های یک دوست‌دار نرم‌افزارهای آزاد
نقل‌قول
چه اروری داد؟
سلام سامان جان خسته نباشید
آقا من اون فایل رو دانلود کردم وسط ارور می داد رفتم از سایت لینوکس فایل alsa-driver-linuxant_1.0.20.1_k2.6.28_11_generic_ubuntu_i386.deb.zip v رو دانلود کردم نصبش کردم مشکل حل شد بعد اون پکیجی که شما بهم دادید نصب شد بعد رفتم توی ترمینال دستور sudu pppconfig رو اجرا کردم تنضیمات رو هم انجام دادم اما وقتی دستور pon رو برای اتصال می زنم ارور زیر رو می ده من کلش رو قرار می دم لطفا راهنمایی کنید مشکل کجاست
masood@masood-desktop:~$ pon Irangate
Error: only members of the 'dip' group can use this command.
یه مورد دیگه برای پیکر بندی wvdial هم ارور می ده من کلشو می زارم لطفا کمک کنید
masood@masood-desktop:~$ sudo wvdialconf /etc/wvdial.conf
sudo: wvdialconf: command not found
ممنون

در مورد اولی(pon Irangate) یه sudo بهش اضافه کنید، یعنی:
sudo pon Irangateیا
http://yeenghelabi.wordpress.com/2009/02/05/%d9%86%da%a9%d8%a7%d8%aa%db%8c-%d8%af%d8%b1%d8%a8%d8%a7%d8%b1%d9%87%e2%80%8c%db%8c-%da%af%d8%b1%d9%88%d9%87%e2%80%8c%d9%87%d8%a7/

در مورد دومی هم فکر کنم شما از Jaunty استفاده می کنید و به طور پیش فرض wvdial نصب نیست و باید خودتون نصبش کنید:
http://mirrors.kernel.org/ubuntu/pool/main/w/wvdial/wvdial_1.60.1+nmu2_i386.deb

موفق باشید.

آفلاین Dallas1387

  • Newbie
  • *
  • ارسال: 8
  • جنسیت : پسر
سلام
آقا طبق فرمایشات شما
اول رفتم درایور مودم hsf رو دانلود کردم نصب نشد بعد اون لایلری های مورد نیازشو گرفتم و نصبش کردم همینطور wvdial رو اما هنوز مشکل دارم
اینو جوابیه که بعد از ران کردن دستور sudo wvdialconf /etc/wvdial.conf برای پیکر بندی wvdial اجرا کردم

masood@masood-desktop:~$ sudo wvdialconf /etc/wvdial.conf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: Scanning ttySHSF0 first, /dev/modem is a link to it.
ttySHSF0<*1>: ATQ0 V1 E1 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 Z -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttySHSF0<*1>: Modem Identifier: ATI -- 56000
ttySHSF0<*1>: Speed 4800: AT -- OK
ttySHSF0<*1>: Speed 9600: AT -- OK
ttySHSF0<*1>: Speed 19200: AT -- OK
ttySHSF0<*1>: Speed 38400: AT -- OK
ttySHSF0<*1>: Speed 57600: AT -- OK
ttySHSF0<*1>: Speed 115200: AT -- OK
ttySHSF0<*1>: Speed 230400: AT -- OK
ttySHSF0<*1>: Speed 460800: AT -- OK
ttySHSF0<*1>: Max speed is 460800; that should be safe.
ttySHSF0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1   S2   S3   SHSF1 SHSF2 SHSF3 SHSF4 SHSF5
Modem Port Scan<*1>: SHSF6 SHSF7

Found a modem on /dev/ttySHSF0, using link /dev/modem in config.
Modem configuration written to /etc/wvdial.conf.
ttySHSF0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
بعد از این
در جواب ران کردن wvdial هست باید بگم من از خطوط in استفاده می کنم که بدون کد و پسورد هست شماره رو هم وارد کردم اما باز کانکت نمی شه
masood@masood-desktop:~$ wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Configuration does not specify a valid phone number.
--> Configuration does not specify a valid login name.
--> Configuration does not specify a valid password.
بعد از اینکه از این راه به نتیجه نرسیدم دستور sudo pppconfig رو اجاره کردم کانکشن هم ساختم پورت مودم رو هم روی /dev/ttySHSF0 یکبار هم روی  /dev/ttyS0تنظیم کردم اما با اجاره دستور pon m ( ام نام کانکشنمه ) و البته sudo pon m رو هم اجرا کردم ارور زیر رو می ده
masood@masood-desktop:~$ sudo pon m
The file /etc/ppp/peers/m does not exist. Please create it or use
a command line argument to use another file in the /etc/ppp/peers/ directory
خواهشا کمک کنید
یه سوال دیگه اوبونتو 9.04 سیستم گرافیکی نداره برای ساخت کانکشن و وصل شدن به اینترنت توی ادمینستراتور فقط گزینه network tools هست که من چیزی در مورد کانکشن داخلش پیدا نکردم
ممنون

آفلاین ahmed

  • High Hero Member
  • *
  • ارسال: 1069
  • جنسیت : پسر
    • یادداشت‌های یک دوست‌دار نرم‌افزارهای آزاد
در مورد دومی باید بگم که شما چنین کانکشنی نساخته اید! مطمئن شوید که پس از طی مراحل Finish رو اینتر کنید. وگرنه ساخته نمی شه.

آفلاین AliRezaiMi

  • High Hero Member
  • *
  • ارسال: 1073
  • جنسیت : پسر
سلام آقا من درايور مودمم رو نصب كردم (زولتريكس hcf)اما نميتونم on بشم
با kppp هر كاري ميكنم نميشه و بعضي وقتها ارورر زير ميده

لطفا يه راهي براي on شدن با اوبونتو به dialup به من بديد
ممنون

دوستان كسي نبو د من رو كمك كنه
در ضمن مودم رو با دانلود فايل Deb از سايت conxtant و نصبش و كرك كردنش با كيژن مورد نظر .
حالا با kpppكه ميخوام كانكت بشم صداي مودم مياد اما آخرش گير ميكنه و وصل نميشه نميدونم چرا
تازه گاهي اوقات هم اروري كه تصويرش توي پست قبلي هست رو ميده
ممنون ميشم كمكم كنيد

آفلاین ahmed

  • High Hero Member
  • *
  • ارسال: 1069
  • جنسیت : پسر
    • یادداشت‌های یک دوست‌دار نرم‌افزارهای آزاد
سلام آقا من درايور مودمم رو نصب كردم (زولتريكس hcf)اما نميتونم on بشم
با kppp هر كاري ميكنم نميشه و بعضي وقتها ارورر زير ميده

لطفا يه راهي براي on شدن با اوبونتو به dialup به من بديد
ممنون

دوستان كسي نبو د من رو كمك كنه
در ضمن مودم رو با دانلود فايل Deb از سايت conxtant و نصبش و كرك كردنش با كيژن مورد نظر .
حالا با kpppكه ميخوام كانكت بشم صداي مودم مياد اما آخرش گير ميكنه و وصل نميشه نميدونم چرا
تازه گاهي اوقات هم اروري كه تصويرش توي پست قبلي هست رو ميده
ممنون ميشم كمكم كنيد

چرا اینقدر روی kppp مصمم هستید؟ بعضی اوقات kppp برای من هم کار نمی کنه! البته این بیشتر تو گنوم اتفاق می افته. به نظر من بهتره از pppconfig یا wvdial استفاده کنید:
http://wiki.ubuntu.ir/DialupModemHowto/SetUpDialer

آفلاین amirHP

  • Jr. Member
  • *
  • ارسال: 75
  • جنسیت : پسر
    • binazir
خروجی فایل scanmodem بنده به این شرحه : Only plain text email is forwarded by the  Discuss@Linmodems.org List Server,
 as HTML can contain viruses. Use as the email Subject Line:
           YourName, YourCountry Welcome to openSUSE 11.1 - Kernel  kernel 2.6.27.7-9-pae
 With this Subject Line cogent experts will be alerted, and useful case names left in the Archive.
 YourCountry will enable Country specific guidance. Linux experts in YourCountry
 can be found through: http://www.linux.org/groups/index.html.
They will know your Country's modem code, which may be essential for dialup service.
Responses from Discuss@Linmodems.org are sometimes blocked by an Internet Provider mail filters.
 So in a day, also check the Archived responses at http://www.linmodems.org
--------------------------  System information ----------------------------
CPU=i686,  Welcome to openSUSE 11.1 - Kernel
Linux version 2.6.27.7-9-pae (geeko@buildhost) (gcc version 4.3.2 [gcc-4_3-branch revision 141291] (SUSE Linux) ) #1 SMP 2008-12-04 18:10:04 +0100
 scanModem update of:  2009_05_31

 There are no blacklisted modem drivers in /etc/modprobe*  files
 Potentially useful modem drivers now loaded are:
         snd_hda_intel       

If a USB modem or cellphone is attached and was not detected, please
provide available information in your request to discuss@linmodems.org

If a USB modem or cellphone is attached and was not detected, please
provide available information in your request to discuss@linmodems.org

For candidate card in slot 00:1b.0, firmware information and bootup diagnostics are:
 PCI slot PCI ID SubsystemID Name
 ---------- --------- --------- --------------
For candidate card in slot 00:1b.0, firmware information and bootup diagnostics are:
 PCI slot PCI ID SubsystemID Name
 ---------- --------- --------- --------------
 00:1b.0 8086:284b 1025:011c Audio device: Intel Corporation 82801H

 Modem interrupt assignment and sharing:
 22:        955   IO-APIC-fasteoi   yenta, ohci1394, tifm_7xx1, mmc0, HDA Intel
 00:1b.0 8086:284b 1025:011c Audio device: Intel Corporation 82801H

 Modem interrupt assignment and sharing:
 22:        955   IO-APIC-fasteoi   yenta, ohci1394, tifm_7xx1, mmc0, HDA Intel
 --- Bootup diagnostics for card in PCI slot 00:1b.0 ----
PCI: 0000:00:1b.0 reg 10 64bit mmio: [fc300000, fc303fff]
pci 0000:00:1b.0: PME# supported from D0 D3hot D3cold
pci 0000:00:1b.0: PME# disabled
HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
HDA Intel 0000:00:1b.0: setting latency timer to 64

 The PCI slot 00:1b.0 of the modem card may be disabled early in
 a bootup process,  but then enabled later. If modem drivers load
 but the  modem is not responsive, read DOCs/Bootup.txt about possible fixes.
 Send dmesg.txt along with ModemData.txt to discuss@linmodems.org
 if help is needed.
 

 --- Bootup diagnostics for card in PCI slot 00:1b.0 ----
PCI: 0000:00:1b.0 reg 10 64bit mmio: [fc300000, fc303fff]
pci 0000:00:1b.0: PME# supported from D0 D3hot D3cold
pci 0000:00:1b.0: PME# disabled
HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
HDA Intel 0000:00:1b.0: setting latency timer to 64

 The PCI slot 00:1b.0 of the modem card may be disabled early in
 a bootup process,  but then enabled later. If modem drivers load
 but the  modem is not responsive, read DOCs/Bootup.txt about possible fixes.
 Send dmesg.txt along with ModemData.txt to discuss@linmodems.org
 if help is needed.
 



===== Advanced Linux Sound Architecture (ALSA) diagnostics =====
The ALSA packages provide audio support and also drivers for some modems.
ALSA diagnostics are written during bootup to /proc/asound/ folders.

The ALSA verion is 1.0.17
The modem cards detected by "aplay -l"  are: None


The /proc/asound/pcm file reports:
-----------------------
00-04: ALC268 Analog : ALC268 Analog : capture 1
00-00: ALC268 Analog : ALC268 Analog : playback 1 : capture 1

about /proc/asound/cards:
------------------------
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfc300000 irq 22
===== Advanced Linux Sound Architecture (ALSA) diagnostics =====
The ALSA packages provide audio support and also drivers for some modems.
ALSA diagnostics are written during bootup to /proc/asound/ folders.

The ALSA verion is 1.0.17
The modem cards detected by "aplay -l"  are: None


The /proc/asound/pcm file reports:
-----------------------
00-04: ALC268 Analog : ALC268 Analog : capture 1
00-00: ALC268 Analog : ALC268 Analog : playback 1 : capture 1

about /proc/asound/cards:
------------------------
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfc300000 irq 22

 PCI slot 00:1b.0 has a High Definition Audio Card
 The drivers are in the kernel modules tree at:
 /lib/modules/2.6.27.7-9-pae/kernel/sound/pci/hda/snd-hda-intel.ko

 PCI slot 00:1b.0 has a High Definition Audio Card
 The drivers are in the kernel modules tree at:
 /lib/modules/2.6.27.7-9-pae/kernel/sound/pci/hda/snd-hda-intel.ko
 The modem codec file for the HDA card is: /proc/asound/card0/codec#1
--------------------------------------------------------
Codec: LSI ID 1040
Address: 1
Vendor Id: 0x11c11040
Subsystem Id: 0x10250100
Revision Id: 0x100200
Modem Function Group: 0x1

 The modem codec file for the HDA card is: /proc/asound/card0/codec#1
--------------------------------------------------------
Codec: LSI ID 1040
Address: 1
Vendor Id: 0x11c11040
Subsystem Id: 0x10250100
Revision Id: 0x100200
Modem Function Group: 0x1

 The audio card hosts a softmodem chip:  0x11c11040
 The audio card hosts a softmodem chip:  0x11c11040
If not a Conexant modem, the driver agrsm with its dependent drivers:

----------
provide audio + modem support with the modem chip residing on the subsystem.
Any particular card can host any one of several soft modem chips.

If not a Conexant modem, the driver agrsm with its dependent drivers:

----------
provide audio + modem support with the modem chip residing on the subsystem.
Any particular card can host any one of several soft modem chips.

===== Advanced Linux Sound Architecture (ALSA) diagnostics =====
The ALSA packages provide audio support and also drivers for some modems.
ALSA diagnostics are written during bootup to /proc/asound/ folders.

The ALSA verion is 1.0.17
The modem cards detected by "aplay -l"  are: None


The /proc/asound/pcm file reports:
-----------------------
00-04: ALC268 Analog : ALC268 Analog : capture 1
00-00: ALC268 Analog : ALC268 Analog : playback 1 : capture 1

about /proc/asound/cards:
------------------------
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfc300000 irq 22
===== Advanced Linux Sound Architecture (ALSA) diagnostics =====
The ALSA packages provide audio support and also drivers for some modems.
ALSA diagnostics are written during bootup to /proc/asound/ folders.

The ALSA verion is 1.0.17
The modem cards detected by "aplay -l"  are: None


The /proc/asound/pcm file reports:
-----------------------
00-04: ALC268 Analog : ALC268 Analog : capture 1
00-00: ALC268 Analog : ALC268 Analog : playback 1 : capture 1

about /proc/asound/cards:
------------------------
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfc300000 irq 22

 PCI slot 00:1b.0 has a High Definition Audio Card
 The drivers are in the kernel modules tree at:
 /lib/modules/2.6.27.7-9-pae/kernel/sound/pci/hda/snd-hda-intel.ko

 PCI slot 00:1b.0 has a High Definition Audio Card
 The drivers are in the kernel modules tree at:
 /lib/modules/2.6.27.7-9-pae/kernel/sound/pci/hda/snd-hda-intel.ko
 The modem codec file for the HDA card is: /proc/asound/card0/codec#1
--------------------------------------------------------
Codec: LSI ID 1040
Address: 1
Vendor Id: 0x11c11040
Subsystem Id: 0x10250100
Revision Id: 0x100200
Modem Function Group: 0x1

 The modem codec file for the HDA card is: /proc/asound/card0/codec#1
--------------------------------------------------------
Codec: LSI ID 1040
Address: 1
Vendor Id: 0x11c11040
Subsystem Id: 0x10250100
Revision Id: 0x100200
Modem Function Group: 0x1

 The audio card hosts a softmodem chip:  0x11c11040
 The audio card hosts a softmodem chip:  0x11c11040
If not a Conexant modem, the driver agrsm with its dependent drivers:

----------
provide audio + modem support with the modem chip residing on the subsystem.
Any particular card can host any one of several soft modem chips.

If not a Conexant modem, the driver agrsm with its dependent drivers:

----------
provide audio + modem support with the modem chip residing on the subsystem.
Any particular card can host any one of several soft modem chips.

=== Finished firmware and bootup diagnostics, next deducing cogent software. ===
=== Finished firmware and bootup diagnostics, next deducing cogent software. ===

Predictive  diagnostics for card in bus 00:1b.0:
Modem chipset  detected on
NAME="Audio device: Intel Corporation 82801H "
NAME="Audio device: Intel Corporation 82801H "
CLASS=0403
PCIDEV=8086:284b
SUBSYS=1025:011c
IRQ=22
CLASS=0403
PCIDEV=8086:284b
SUBSYS=1025:011c
IRQ=22
HDA=8086:284b
HDA=8086:284b
SOFT=8086:284b.HDA
SOFT=8086:284b.HDA
HDAchipVendorID=11c1
CHIP=0x11c11040
IDENT=agrsm
Driver=agrsm
HDAchipVendorID=11c1
CHIP=0x11c11040
IDENT=agrsm
Driver=agrsm

 For candidate modem in:  00:1b.0
   0403 Audio device: Intel Corporation 82801H
      Primary device ID:  8086:284b

Predictive  diagnostics for card in bus 00:1b.0:
Modem chipset  detected on
NAME="Audio device: Intel Corporation 82801H "
NAME="Audio device: Intel Corporation 82801H "
CLASS=0403
PCIDEV=8086:284b
SUBSYS=1025:011c
IRQ=22
CLASS=0403
PCIDEV=8086:284b
SUBSYS=1025:011c
IRQ=22
HDA=8086:284b
HDA=8086:284b
SOFT=8086:284b.HDA
SOFT=8086:284b.HDA
HDAchipVendorID=11c1
CHIP=0x11c11040
IDENT=agrsm
Driver=agrsm
HDAchipVendorID=11c1
CHIP=0x11c11040
IDENT=agrsm
Driver=agrsm

 For candidate modem in:  00:1b.0
   0403 Audio device: Intel Corporation 82801H
      Primary device ID:  8086:284b
    Subsystem PCI_id  1025:011c
    Softmodem codec or chipset from diagnostics: 0x11c11040
                               from    Archives:
                        The HDA card softmodem chip is 0x11c11040
     

    Subsystem PCI_id  1025:011c
    Softmodem codec or chipset from diagnostics: 0x11c11040
                               from    Archives:
                        The HDA card softmodem chip is 0x11c11040
     

Support type needed or chipset: agrsm


Support type needed or chipset: agrsm


Writing DOCs/Intel.txt
Writing DOCs/Intel.txt

The AgereSystems/LSI agrsm code supports compiling of a agrmodem + agrsm driver pair.
One resource site is http://linmodems.technion.ac.il/packages/ltmodem/11c11040/
Thereat get the agrsm_howto.txt and one of the agrsm-tools packages.
The initial agrsm_howto.txt compiling steps are only cogent to modems with PCI IDs:
   11c1:0620, 11c1:048c and 11c1:048f chips.
   They use the agrsm-20090418.tar.gz package.
The agrsm-tools sets a useful symbolic link and a agrsm-test utlity

For AgereSystems/LSI with Vendor 11c1 chips hosted on High Definition Audio cards, there may be support
through the agrsm resources (providing an agrmodem + agrserial driver pair) as an alternative to usage
of the snd-hda-intel driver + slmodemd helper. For the 11c11040 modem chip, ONLY the agrsm code is competent.
Your Linux distro's dkms package should be first installed, as it directs the installation of modem
specific dkms-agrsm resources, and also directs auto-installation of new drivers upon kernel upgrades.

Currently, the dkms-agrsm code is NOT competent for 2.26.28 and later kernels.
A short term fix is to install linux-image + linux-headers packages for earlier kernels.
For example, for Ubuntu Jaunty with 2.6.28 kernels, linux-image + linux-headers packages
for earlier 2.26.27 series Intrepid kernels can be installed. Search for them at:
   http://packages.ubuntu.com


The primary dkms-agrsm resource site is http://linux.zsolttech.com/linmodem/agrsm/
whereat a few different packaging types are available. Debian type installers (supporting Ubuntu too)
are copied to http://linmodems.technion.ac.il/packages/ltmodem/11c11040/ . Thereat the current package
is the dkms-agrsm_2.1.80-6_i386.deb is for Agere/LSI chipsets hosted on High Definition Audio cards. 
Read the Modem/DOCs/Agrsm.txt for details.


The AgereSystems/LSI agrsm code supports compiling of a agrmodem + agrsm driver pair.
One resource site is http://linmodems.technion.ac.il/packages/ltmodem/11c11040/
Thereat get the agrsm_howto.txt and one of the agrsm-tools packages.
The initial agrsm_howto.txt compiling steps are only cogent to modems with PCI IDs:
   11c1:0620, 11c1:048c and 11c1:048f chips.
   They use the agrsm-20090418.tar.gz package.
The agrsm-tools sets a useful symbolic link and a agrsm-test utlity

For AgereSystems/LSI with Vendor 11c1 chips hosted on High Definition Audio cards, there may be support
through the agrsm resources (providing an agrmodem + agrserial driver pair) as an alternative to usage
of the snd-hda-intel driver + slmodemd helper. For the 11c11040 modem chip, ONLY the agrsm code is competent.
Your Linux distro's dkms package should be first installed, as it directs the installation of modem
specific dkms-agrsm resources, and also directs auto-installation of new drivers upon kernel upgrades.

Currently, the dkms-agrsm code is NOT competent for 2.26.28 and later kernels.
A short term fix is to install linux-image + linux-headers packages for earlier kernels.
For example, for Ubuntu Jaunty with 2.6.28 kernels, linux-image + linux-headers packages
for earlier 2.26.27 series Intrepid kernels can be installed. Search for them at:
   http://packages.ubuntu.com


The primary dkms-agrsm resource site is http://linux.zsolttech.com/linmodem/agrsm/
whereat a few different packaging types are available. Debian type installers (supporting Ubuntu too)
are copied to http://linmodems.technion.ac.il/packages/ltmodem/11c11040/ . Thereat the current package
is the dkms-agrsm_2.1.80-6_i386.deb is for Agere/LSI chipsets hosted on High Definition Audio cards. 
Read the Modem/DOCs/Agrsm.txt for details.

-------------- end Agere Systems section -------------------
-------------- end Agere Systems section -------------------

 Completed candidate modem analyses.

 Completed candidate modem analyses.


 The base of the UDEV device file system is: /dev/.udev

 Versions adequately match for the compiler installed: 4.3.2
             and the compiler used in kernel assembly: 4.3

 The base of the UDEV device file system is: /dev/.udev

 Versions adequately match for the compiler installed: 4.3.2
             and the compiler used in kernel assembly: 4.3

 linux-headers-2.6.27.7-9-pae resources needed for compiling are not manifestly ready!
 linux-headers-2.6.27.7-9-pae resources needed for compiling are not manifestly ready!

 If compiling is necessary packages must be installed, providing:
kernel-source-2.6.27.7-9-pae


If a driver compilation fails, with message including some lack of some FileName.h (stdio.h for example), then
Some additional kernel-header files need installation to /usr/include. The minimal additional packages are libc6-dev
and any of its dependents, under Ubuntu linux-libc-dev

If an alternate ethernet connection is available,
$  apt-get update
$  apt-get -s install linux-kernel-devel
will install needed packages.
For Debian/Ubuntu related distributions, run the following command to display the needed package list:

Otherwise packages have to be found through http://packages.ubuntu.com
Once downloaded and transferred into a Linux partition,
they can be installed alltogether with:
$ sudo dpkg -i *.deb


 If compiling is necessary packages must be installed, providing:
kernel-source-2.6.27.7-9-pae


If a driver compilation fails, with message including some lack of some FileName.h (stdio.h for example), then
Some additional kernel-header files need installation to /usr/include. The minimal additional packages are libc6-dev
and any of its dependents, under Ubuntu linux-libc-dev

If an alternate ethernet connection is available,
$  apt-get update
$  apt-get -s install linux-kernel-devel
will install needed packages.
For Debian/Ubuntu related distributions, run the following command to display the needed package list:

Otherwise packages have to be found through http://packages.ubuntu.com
Once downloaded and transferred into a Linux partition,
they can be installed alltogether with:
$ sudo dpkg -i *.deb


Checking pppd properties:
-rwxr-xr-x 1 root dialout 330764 2008-12-03 11:33 /usr/sbin/pppd

In case of an "error 17" "serial loopback" problem, see:
    http://linmodems.technion.ac.il/linmodems/archive-sixth/msg02637.html


Checking pppd properties:
-rwxr-xr-x 1 root dialout 330764 2008-12-03 11:33 /usr/sbin/pppd

In case of an "error 17" "serial loopback" problem, see:
    http://linmodems.technion.ac.il/linmodems/archive-sixth/msg02637.html

To enable dialout without Root permission do:
$ su - root  (not for Ubuntu)
         chmod a+x /usr/sbin/pppd
or under Ubuntu related Linuxes
chmod a+x /usr/sbin/pppd

To enable dialout without Root permission do:
$ su - root  (not for Ubuntu)
         chmod a+x /usr/sbin/pppd
or under Ubuntu related Linuxes
chmod a+x /usr/sbin/pppd

Checking settings of: /etc/ppp/options
noipdefault
noauth
crtscts
lock
modem
asyncmap 0
nodetach
lcp-echo-interval 30
lcp-echo-failure 4
lcp-max-configure 60
lcp-restart 2
idle 600
noipx
file /etc/ppp/filters

In case of a message like:
   Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
see http://linmodems.technion.ac.il/bigarch/archive-sixth/msg04656.html

Checking settings of: /etc/ppp/options
noipdefault
noauth
crtscts
lock
modem
asyncmap 0
nodetach
lcp-echo-interval 30
lcp-echo-failure 4
lcp-max-configure 60
lcp-restart 2
idle 600
noipx
file /etc/ppp/filters

In case of a message like:
   Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
see http://linmodems.technion.ac.il/bigarch/archive-sixth/msg04656.html


 Don't worry about the following, it is for experts should trouble shooting be necessary.
==========================================================


 Don't worry about the following, it is for experts should trouble shooting be necessary.
==========================================================

 Checking for modem support lines:
 --------------------------------------
     /device/modem symbolic link:   
slmodemd created symbolic link /dev/ttySL0: 
     Within /etc/udev/ files:
/etc/udev/rules.d/77-network.rules:SUBSYSTEM=="net", ENV{INTERFACE}=="ppp*|ippp*|isdn*|plip*|lo*|irda*|dummy*|ipsec*|tun*|tap*|bond*|br*|vlan*|modem*|dsl*", GOTO="skip_ifup"
     Within /etc/modprobe.conf files:
/etc/modprobe.conf:# Linux ACP modem (Mwave)
     Within any ancient /etc/devfs files:

     Within ancient kernel 2.4.n /etc/module.conf files:

--------- end modem support lines --------

 Checking for modem support lines:
 --------------------------------------
     /device/modem symbolic link:   
slmodemd created symbolic link /dev/ttySL0: 
     Within /etc/udev/ files:
/etc/udev/rules.d/77-network.rules:SUBSYSTEM=="net", ENV{INTERFACE}=="ppp*|ippp*|isdn*|plip*|lo*|irda*|dummy*|ipsec*|tun*|tap*|bond*|br*|vlan*|modem*|dsl*", GOTO="skip_ifup"
     Within /etc/modprobe.conf files:
/etc/modprobe.conf:# Linux ACP modem (Mwave)
     Within any ancient /etc/devfs files:

     Within ancient kernel 2.4.n /etc/module.conf files:

--------- end modem support lines --------
کسی میتونه لینک دانلود درایو ترجیحا مخصوص اپن سوزه بذاره ... با عرض پوزش از اینکه مشکلم رو اینجا مطرح کردم . تاپیک اپن سوزه خیلی کم فعاله و سر تیتر اینجا هم نوشته شده بود " راهنمای جامع " برای همین اومدم اینجا.

آفلاین yakoza

  • Jr. Member
  • *
  • ارسال: 83
سلام

من مودممو نصبیدم و فکر کنم همیچی اوکیه و wvdial هم درست کار میکنه ولی هیچ صفحه ای رو باز نمیکنه

قبلا address not found میزد ولی الان looking for site میزنه

چی کارش کنم
« آخرین ویرایش: 30 خرداد 1388، 05:52 ب‌ظ توسط yakoza »

آفلاین yakoza

  • Jr. Member
  • *
  • ارسال: 83
هوراااااااااااااااااااااااا

اینم اولین پستم از ابونتو  ;D
ولی خدایی چه سرعت مزخرفی داره
راهی نداره سرعتشو زیاد کنم  ???

آفلاین amirHP

  • Jr. Member
  • *
  • ارسال: 75
  • جنسیت : پسر
    • binazir
این مطلب رو بخون http://itline.ir/2009/01/install-full-conexant-modem-in-ubuntu/ فکر کنم چون کرکش نکردی اینجوریه .

آفلاین yakoza

  • Jr. Member
  • *
  • ارسال: 83
این مطلب رو بخون http://itline.ir/2009/01/install-full-conexant-modem-in-ubuntu/ فکر کنم چون کرکش نکردی اینجوریه .

ایول کرک شد

ممنون

آفلاین amirHP

  • Jr. Member
  • *
  • ارسال: 75
  • جنسیت : پسر
    • binazir
حالا که مشکل این دوست عزیز بر طرف شد یکی هم به این مشکل دوساله ی بنده برسه .

آفلاین ninja

  • Newbie
  • *
  • ارسال: 1
سلام
  می خواستم بدونم کسی میدونه چطور ubuntu رو میشه عضو domain کرد؟

آفلاین مهران رهباردار (mehionline)

  • Sr. Member
  • *
  • ارسال: 343
  • جنسیت : پسر
  • یه کاربر ساده نرم افزارهای آزاد
    • وبسایت شخصی من
وقتي دستور wvdial رو مي زنم مي گه مودم توسط يك نرم افزار ديگه در حال استفاده است و يا تنظيم نشده با setserial
لطفا ميشه درباره setserial راهنمايي كنيد.

آفلاین arkia

  • Newbie
  • *
  • ارسال: 2
یکی به من تازه وارد برا نصب مودمم کمک کنه
« پاسخ #59 : 10 شهریور 1388، 12:55 ق‌ظ »
سلام به دنیای لینوکس! (اولین بارمه که تو این انجمن پست میدم)
دوستان من 2 تا سوال خدمتتون داشتم فکر کردم اینجا به عرضتون برسونم
1) مودم من تو ویندوز به صورت Intel 2chips 536A شناخته میشه و از روشی که در ویکی همین سایت گفته شده بود این خروجیم بود :

Only plain text email is forwarded by the  Discuss@Linmodems.org List Server,
 as HTML can contain viruses. Use as the email Subject Line:
           YourName, YourCountry  kernel 2.6.24-19-generic
 With this Subject Line cogent experts will be alerted, and useful case names left in the Archive.
 YourCountry will enable Country specific guidance. Linux experts in YourCountry
 can be found through: http://www.linux.org/groups/index.html.
They will know your Country's modem code, which may be essential for dialup service.
Responses from Discuss@Linmodems.org are sometimes blocked by an Internet Provider mail filters.
 So in a day, also check the Archived responses at http://www.linmodems.org
--------------------------  System information ----------------------------
CPU=i686,  
Linux version 2.6.24-19-generic (buildd@palmer) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Wed Jun 18 14:43:41 UTC 2008
 scanModem update of:  2009_08_15

 There are no blacklisted modem drivers in /etc/modprobe*  files
 Potentially useful modem drivers now loaded are:
         snd_hda_intel      

Attached USB devices are:
 ID 058f:6362 Alcor Micro Corp. Hi-Speed 21-in-1 Flash Card Reader/Writer (Internal/External)
If a cellphone is not detected, see http://ubuntuforums.org/archive/index.php/t-878554.html
A sample report is:  http://linmodems.technion.ac.il/bigarch/archive-nineth/msg00578.html

If a USB modem or cellphone is attached and was not detected, please
provide available information in your request to discuss@linmodems.org

For candidate card in slot 03:02.0, firmware information and bootup diagnostics are:
 PCI slot PCI ID SubsystemID Name
 ---------- --------- --------- --------------
 03:02.0 14f1:2f50 14f1:205f Communication controller: Conexant Unknown device 2f50

 Modem interrupt assignment and sharing:
 15:          0   IO-APIC-edge      libata
 --- Bootup diagnostics for card in PCI slot 03:02.0 ----

For candidate card in slot 00:1b.0, firmware information and bootup diagnostics are:
 PCI slot PCI ID SubsystemID Name
 ---------- --------- --------- --------------
 00:1b.0 8086:27d8 1849:0888 Audio device: Intel Corporation 82801G

 Modem interrupt assignment and sharing:
 16:      76331   IO-APIC-fasteoi   uhci_hcd:usb4, HDA Intel, i915@pci:0000:00:02.0
 --- Bootup diagnostics for card in PCI slot 00:1b.0 ----
[   39.249761] ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 16 (level, low) -> IRQ 16
[   39.249787] PCI: Setting latency timer of device 0000:00:1b.0 to 64


===== Advanced Linux Sound Architecture (ALSA) diagnostics =====
The ALSA packages provide audio support and also drivers for some modems.
ALSA diagnostics are written during bootup to /proc/asound/ folders.

The ALSA verion is 1.0.16
The modem cards detected by "aplay -l"  are: None


The /proc/asound/pcm file reports:
-----------------------
00-04: ALC883 Analog : ALC883 Analog : capture 1
00-00: ALC883 Analog : ALC883 Analog : playback 1 : capture 1

about /proc/asound/cards:
------------------------
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfea38000 irq 16

 PCI slot 00:1b.0 has a High Definition Audio Card
 The drivers are in the kernel modules tree at:
 /lib/modules/2.6.24-19-generic/ubuntu/sound/alsa-driver/pci/hda/snd-hda-intel.ko
UNEXPECTED HDA diagnostic outcome.
=== Finished firmware and bootup diagnostics, next deducing cogent software. ===

Predictive  diagnostics for card in bus 03:02.0:
Modem chipset  detected on
NAME="Communication controller: Conexant Unknown device 2f50 "
CLASS=0780
PCIDEV=14f1:2f50
SUBSYS=14f1:205f
IRQ=15
IDENT=hsfmodem
Driver=hsfmodem-drivers

 For candidate modem in:  03:02.0
   0780 Communication controller: Conexant Unknown device 2f50
      Primary device ID:  14f1:2f50
 Support type needed or chipset: hsfmodem
 


Writing DOCs/Intel.txt

For owners of a Dell PCs with Conexant HSF modems, a driver source package with full speed enabled is available, but requires driver compiling. Read DOCs/Conexant.txt

 Support for the 14f1:2f50  and 14f1:2215 HSF modems is projected early in 2007 from Linuxant.
 From  http://www.linuxant.com/drivers/hsf/full/downloads-ubuntu-x86.php
 download hsfmodem-7.80.02.02full_k2.6.24_19_generic_ubuntu_i386.deb.zip
 Under Linux unpack with:
 $ unzip hsfmodem*.zip
 Then install with:
 $ sudo dpkg -i hsfmodem*.deb
 Subsequently, the modem should be found with
 $ sudo wvdialconf /etc/wvdial.conf
 Edit in your personal information with:
 $ sudo gedit /etc/wvdial.conf
 and try dialing out with:
 $ sudo wvdial.
 See DOCs/Testing.txt  for details.
 
 The directions following below need only be pursued, if the above procedures are not adequate.

Start at http://www.linuxant.com/drivers/hsf/downloads-license.php to find the
hsfmodem package matching your System. For several Linux distros, there are
precompiled drivers matched to specific kernels. These have within the FileName,
your KernelVersion: 2.6.24_19_generic
They can be found through http://www.linuxant.com/drivers/hsf/full/downloads.php
A more precise location may be given a few paragraphs below.
If an EXACT Match with your your KernelVersion is not found, one of the
"Generic packages with source" near the bottom of the page must be used.
Downloaded packages must be moved into the Linux partition (home folder is OK)
and unzipped with:
unzip hsf*.zip
The installation command for a .deb suffic packages is, with root/adm permission:
  sudo dpkg -i hsf*.deb
while for .rpm suffix it is, with:
  rpm -i hsf*.rpm
 Read DOCs/Conexant.txt

Writing DOCs/Conexant.txt



Predictive  diagnostics for card in bus 00:1b.0:
Modem chipset not detected on
NAME="Audio device: Intel Corporation 82801G "
CLASS=0403
PCIDEV=8086:27d8
SUBSYS=1849:0888
IRQ=16
HDA=8086:27d8
SOFT=8086:27d8.HDA


 High Definition Audio (HDA) cards MAY host a modem chip in their Subsystem,
 and many are supported by the ALSA audio+modem driver snd-hda-intel
 A modem was not detected on HDA card 8086:27d8.
 If another modem card is present, then most likely 8086:27d8 does not host a modem.
 If another modem card has not been detected, then possibilities are:
1) A Conexant modem chip is present on 8086:27d8, as Conexant chips
 are frequently not detectable by ALSA diagnostics
2) The modem may be of the older non-PCI Controller Chipset (hardware) type.
Try detection with Root permission:
sudo wvdialconf  /etc/wvdial.conf

 For candidate modem in:  00:1b.0
   0403 Audio device: Intel Corporation 82801G
      Primary device ID:  8086:27d8
    Subsystem PCI_id  1849:0888
    Softmodem codec or chipset from diagnostics:
                               from    Archives:
                        
      

Support type needed or chipset:

Support can likely be achieved through two mutually exclusive alternatives:
1) The hsfmodem software for Conexant chipset modems: Read DOCs/Conexant.txt
The following ALSA alternative CANNOT work with Conexant modems.

2) An ALSA modem driver plus slmodemd.  Read DOCs/Smartlink.txt for details, and
to test get the package SLMODEMD.gcc4.2.tar.gz from:
http://linmodems.technion.ac.il/packages/smartlink/

Writing DOCs/Smartlink.txt
============ end Smartlink section =====================

 Completed candidate modem analyses.

 The base of the UDEV device file system is: /dev/.udev

 Versions adequately match for the compiler installed: 4.2.3
             and the compiler used in kernel assembly: 4.2.3

 The patch utility is needed and is needed for compiling ALSA drivers, and possibly others.

 
 Minimal compiling resources appear complete:
   make utility - /usr/bin/make
   Compiler version 4.2
   linuc_headers base folder /lib/modules/2.6.24-19-generic/build

 However some compilations and executable functions may need additional files,
 in the FileNames.h (so called kernel "h"eaders) collection installed in  /usr/include/ .
 For martian_modem, additional required packages are needed. The also required headers of package libc6 are commonly installed by default.
 Compiling hsfmodem drivers does require linux-libc-dev and libc6-dev packages, for kernels 2.6.24 and later versions.
 In not included on your install CD, search for them at http://packages.ubuntu.com
 or comparable Repository for other Linux distros.
 When compiling ALSA drivers, the utility "patch" will also be needed.




If a driver compilation fails, with message including some lack of some FileName.h (stdio.h for example), then
Some additional kernel-header files need installation to /usr/include. The minimal additional packages are libc6-dev
and any of its dependents, under Ubuntu linux-libc-dev

If an alternate ethernet connection is available,
$  apt-get update
$  apt-get -s install linux-kernel-devel
will install needed packages.
For Debian/Ubuntu related distributions, run the following command to display the needed package list:

Otherwise packages have to be found through http://packages.ubuntu.com
Once downloaded and transferred into a Linux partition,
they can be installed alltogether with:
$ sudo dpkg -i *.deb


Checking pppd properties:
-rwsr-xr-- 1 root dip 269256 2007-10-04 22:57 /usr/sbin/pppd

In case of an "error 17" "serial loopback" problem, see:
    http://linmodems.technion.ac.il/linmodems/archive-sixth/msg02637.html

To enable dialout without Root permission do:
$ su - root  (not for Ubuntu)
        sudo chmod a+x /usr/sbin/pppd
or under Ubuntu related Linuxes
sudo chmod a+x /usr/sbin/pppd

Checking settings of: /etc/ppp/options
asyncmap 0
noauth
crtscts
lock
hide-password
modem
proxyarp
lcp-echo-interval 30
lcp-echo-failure 4
noipx

In case of a message like:
   Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
see http://linmodems.technion.ac.il/bigarch/archive-sixth/msg04656.html


 Don't worry about the following, it is for experts should trouble shooting be necessary.
==========================================================

 Checking for modem support lines:
 --------------------------------------
     /device/modem symbolic link:  
slmodemd created symbolic link /dev/ttySL0:  
     Within /etc/udev/ files:

     Within /etc/modprobe.conf files:
/etc/modprobe.d/blacklist-modem:# Uncomment these entries in order to blacklist unwanted modem drivers
/etc/modprobe.d/blacklist-modem:# blacklist snd-atiixp-modem
/etc/modprobe.d/blacklist-modem:# blacklist snd-via82xx-modem
/etc/modprobe.d/alsa-base:options snd-atiixp-modem index=-2
/etc/modprobe.d/alsa-base:options snd-via82xx-modem index=-2
     Within any ancient /etc/devfs files:

     Within ancient kernel 2.4.n /etc/module.conf files:

--------- end modem support lines --------



فکر کنم conexant بشناسه ??? نمیدونم والا اگه دوستان لطف کنن و بگن چجوری و از کجا درایورشو بگیرم که سرعتم رو محدود نکنه راستی تو فایل ini درایور مودمم نوشته بود ModemName     = "Intel(R) 536EP V.92 Modem" اما با دستوری که تو سایت برای تست اینکه مودم  intel536EP هست یا نه نوشته شده بود هیچ پاسخی ندیدم.
ببخشید که طولانی شد  :oops: خیلی سر در گمم


سوال دوومم اینه که اگه بخوام مودم ADSL بخرم چی بخرم که همچین مشکللاتی برا نصبش تو لینوکس نداشته باشم؟؟؟

ممنون بروبچ
« آخرین ویرایش: 10 شهریور 1388، 05:10 ق‌ظ توسط arkia »