انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

لطفاً هر چه زودتر، اوبونتوی خود را به نگارش ۲۱٫۱۰ ارتقا دهید

نویسنده موضوع: نصب کرنل ۳.۴ یا ۳.۵  (دفعات بازدید: 2403 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین ح.م

  • High Hero Member
  • *
  • ارسال: 1274
  • جنسیت : پسر
  • دین بدون خرد مانند خرد بدون دین بی معناست
نصب کرنل ۳.۴ یا ۳.۵
« : 28 مهر 1391، 08:16 ق‌ظ »
دوستانی که می خوان کرنل خودشون رو آپدیت کنن می تونن برای نصب کرنل ۳.۵.۱ از دستورات زیر استفاده کنند
su

cd /tmp
 
 wget -O linux-kernel-3.5.1 http://dl.dropbox.com/u/47950494/upubuntu.com/linux-kernel-3.5.1
 
 chmod +x linux-kernel-3.5.1
 
 sudo sh linux-kernel-3.5.1
استفاده کنن ! واسه حذفش هم از دستور
sudo apt-get purge linux-image-3.5.1-030501استفاده کنن !
اونایی هم که می خوان کرنل ۳.۴.۸ نصب کنن! از دستورات زیر
su

 cd /tmp
 
 wget -O linux-kernel-3.4.8 http://dl.dropbox.com/u/47950494/upubuntu.com/linux-kernel-3.4.8
 
 chmod +x linux-kernel-3.4.8
 
 sudo sh linux-kernel-3.4.8
استفاده کنن واسه حذفش هم از دستور
sudo apt-get purge linux-image-3.4.8-030408
استفاده کنن
بعد از restart هم می تونید با این ورژن دستور کرنل خودتون رو ببینید
uname -r
موفق باشید  ;D

منبع :http://www.upubuntu.com/2012/08/install-linux-kernel-351348-on-ubuntu.html
« آخرین ویرایش: 28 مهر 1391، 08:20 ق‌ظ توسط h1229m »
عاقبت انحصار شکست و سرانجام کمونیسم گنویی دیکتاتوریست !
الگوی متن باز از هر جهت بر الگوی نرم افزار آزاد رجحان دارد
وَسَيَعْلَمُ الَّذِينَ ظَلَمُوا أَيَّ مُنْقَلَبٍ يَنْقَلِبُونَ

آفلاین جادی

  • ناظر انجمن
  • *
  • ارسال: 1460
    • در دفاع از آزادی بیان
پاسخ : نصب کرنل ۳.۴ یا ۳.۵
« پاسخ #1 : 28 مهر 1391، 10:01 ق‌ظ »
تذکر فنی بدم که دوستان اگر از چیزی سر در نمیارن فقط دستور کپی پیست نکنن (:
توی لینوکس خوبه یاد بگیریم داریم چیکار می کنیم، این تنها راه پیشرفته.

حداقلش اینه که اون فایل که گفته رو بگیرین و بخونین که توش چی نوشته. اگه می گیم و اصرار داریم که لینوکس بسیار امنه دلیلش اینه که توی کسی همینجوری از اینترنت (یا دراپ باکس یکی که نمی دونه کیه) اسکریپت دانلود نمی کنه با دسترسی روت اجرا کنه (((:

نمی گم این اسکریپت غیرامنه ولی فقط یک تذکر فنی بود برای کسانی که دوست دارن حرفه ای بشن.
آزادی کیبرد حق هر انسان است - کیبرد آزاد

آفلاین ح.م

  • High Hero Member
  • *
  • ارسال: 1274
  • جنسیت : پسر
  • دین بدون خرد مانند خرد بدون دین بی معناست
پاسخ : نصب کرنل ۳.۴ یا ۳.۵
« پاسخ #2 : 28 مهر 1391، 10:09 ق‌ظ »
آقا حرفت کاملا درسته ! من خودم !خواستم دستی کامپایل کنم ! حجم کامپایل شدش داشت از ۲ گیگ رد می کرد ! جایی هم ندیدم فایل deb رو داشته باشه ! این بود که این راه رو مناسب تر دیدم خودتون هم به فکر امنیتش باشید !
دوستان راه امن تر اینه که خودتون برید.http://www.kernel.org/
کرنلی که می خواهید دانلود کنید ، کامپایل کنید و نصب کنید ! من که بی خیالش کامپایلش شدم به نظر ابر رایانه می خواد واسه کامپایلش ! وسط کامپایل بی خیالش شدم ! خیلی طول کشید.
این اسکریپش ! همش داره از خود سرور اوبونتو می گیره ! اگه اوبونتو امن نیست ! باید گفت : هر چه بگندد نمکش می زنند ....
#!/bin/bash

                           ######### Script Created By UpUbuntu.com ########

#i386 links

link1="http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4.8-quantal/linux-headers-3.4.8-030408_3.4.8-030408.201208091255_all.deb"

link2="http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4.8-quantal/linux-headers-3.4.8-030408-generic_3.4.8-030408.201208091255_i386.deb"

link3="http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4.8-quantal/linux-image-3.4.8-030408-generic_3.4.8-030408.201208091255_i386.deb"

link4="http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4.8-quantal/linux-image-extra-3.4.8-030408-generic_3.4.8-030408.201208091255_i386.deb"

#amd64 links

url1="http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4.8-quantal/linux-headers-3.4.8-030408-generic_3.4.8-030408.201208091255_amd64.deb"

url2="http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4.8-quantal/linux-image-3.4.8-030408-generic_3.4.8-030408.201208091255_amd64.deb"

url3="http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4.8-quantal/linux-image-extra-3.4.8-030408-generic_3.4.8-030408.201208091255_amd64.deb"

#System architecture

arch=`uname -m`
if  [ $arch = i686 ] || [ $arch = i386 ]; then

mkdir $HOME/kernel3.4.8-i386

sudo rm -rf $HOME/kernel3.4.8-i386/*

cd $HOME/kernel3.4.8-i386

wget $link1
wget $link2
wget $link3
wget $link4

sudo dpkg -i *.deb 

sudo rm -rf $HOME/kernel3.4.8-i386

elif [ $arch = "x86_64" ]; then


mkdir $HOME/kernel3.4.8-amd64

sudo rm -rf $HOME/kernel3.4.8-amd64/*

cd $HOME/kernel3.4.8-amd64

wget $link1
wget $url1
wget $url2
wget $url3

sudo dpkg -i *.deb 

sudo rm -rf $HOME/kernel3.4.8-amd64

     else
        echo "Unsupported Architecture"
fi

« آخرین ویرایش: 28 مهر 1391، 10:22 ق‌ظ توسط h1229m »
عاقبت انحصار شکست و سرانجام کمونیسم گنویی دیکتاتوریست !
الگوی متن باز از هر جهت بر الگوی نرم افزار آزاد رجحان دارد
وَسَيَعْلَمُ الَّذِينَ ظَلَمُوا أَيَّ مُنْقَلَبٍ يَنْقَلِبُونَ

آفلاین doomhammer65ir

  • High Hero Member
  • *
  • ارسال: 1572
  • جنسیت : پسر
    • IRAN Backup
پاسخ : نصب کرنل ۳.۴ یا ۳.۵
« پاسخ #3 : 28 مهر 1391، 12:42 ب‌ظ »
خوب همون دبیان های kernel.ubuntu.com رو بنصبید آسون تره که
http://kernel.ubuntu.com/~kernel-ppa/mainline/

آفلاین ح.م

  • High Hero Member
  • *
  • ارسال: 1274
  • جنسیت : پسر
  • دین بدون خرد مانند خرد بدون دین بی معناست
پاسخ : نصب کرنل ۳.۴ یا ۳.۵
« پاسخ #4 : 01 آبان 1391، 09:15 ب‌ظ »
دوستان یه مشکلی من کرنل جدید رو نصب کردم ! ولی وقتی خواستم کرنل قبلی رو حذف کنم ! کلی از برنامه ها رو همراهش پاک می کرد به عنوان مثال یکی از مهمترینشون gcc  بود که فک نکنم کسی اهمیتش رو ندونه ! حالا به نظر شما چه کنم تا کرنل خودم رو به طوری اینها پاک نشن ! پاک کنم !  ::)
عاقبت انحصار شکست و سرانجام کمونیسم گنویی دیکتاتوریست !
الگوی متن باز از هر جهت بر الگوی نرم افزار آزاد رجحان دارد
وَسَيَعْلَمُ الَّذِينَ ظَلَمُوا أَيَّ مُنْقَلَبٍ يَنْقَلِبُونَ

آفلاین doomhammer65ir

  • High Hero Member
  • *
  • ارسال: 1572
  • جنسیت : پسر
    • IRAN Backup
پاسخ : نصب کرنل ۳.۴ یا ۳.۵
« پاسخ #5 : 01 آبان 1391، 09:48 ب‌ظ »
gcc وابسته به هسته نیست به گمانم
شما هسته کهنه رو ( initrd و vmlinuz )‌ از بخش  boot پاک کنید و سپس :
sudo update-grub

آفلاین ح.م

  • High Hero Member
  • *
  • ارسال: 1274
  • جنسیت : پسر
  • دین بدون خرد مانند خرد بدون دین بی معناست
پاسخ : نصب کرنل ۳.۴ یا ۳.۵
« پاسخ #6 : 01 آبان 1391، 10:14 ب‌ظ »
ملاحظه بفرمائید !
sudo aptitude remove linux-headers-3.2.0-23 linux-headers-3.2.0-23-generic linux-image-3.2.0-23-generic linux-libc-dev
The following packages will be REMOVED: 
  linux-headers-3.2.0-23 linux-headers-3.2.0-23-generic linux-image-3.2.0-23-generic linux-libc-dev
0 packages upgraded, 0 newly installed, 4 to remove and 477 not upgraded.
Need to get 0 B of archives. After unpacking 182 MB will be freed.
The following packages have unmet dependencies:
 linux-headers-generic : Depends: linux-headers-3.2.0-23-generic but it is not going to be installed.
 linux-image-generic : Depends: linux-image-3.2.0-23-generic but it is not going to be installed.
 libc6-dev : Depends: linux-libc-dev but it is not going to be installed.
The following actions will resolve these dependencies:

      Remove the following packages:                   
1)      build-essential                               
2)      comerr-dev                                     
3)      g++                                           
4)      g++-4.6                                       
5)      gnome-common                                   
6)      gtk-doc-tools                                 
7)      krb5-multidev                                 
8)      libatk1.0-dev                                 
9)      libc6-dev                                     
10)     libcairo2-dev                                 
11)     libcups2-dev                                   
12)     libexpat1-dev                                 
13)     libfontconfig1-dev                             
14)     libfreetype6-dev                               
15)     libgcrypt11-dev                               
16)     libgdk-pixbuf2.0-dev                           
17)     libglib2.0-dev                                 
18)     libgnutls-dev                                 
19)     libgpgme11-dev                                 
20)     libgtk2.0-dev                                 
21)     libjpeg-dev                                   
22)     libjpeg-turbo8-dev                             
23)     libjpeg8-dev                                   
24)     libkrb5-dev                                   
25)     libmng-dev                                     
26)     libncurses5-dbg                               
27)     libncurses5-dev                               
28)     libpango1.0-dev                               
29)     libpcre3-dev                                   
30)     libpng12-dev                                   
31)     libqt3-mt-dev                                 
32)     libstdc++6-4.6-dev                             
33)     libtool                                       
34)     libusb-dev                                     
35)     libwnck-dev                                   
36)     libxft-dev                                     
37)     linux-generic                                 
38)     linux-headers-generic                         
39)     linux-image-generic                           
40)     mate-common                                   
41)     zlib1g-dev                                     

      Leave the following dependencies unresolved:     
42)     dkms recommends linux-image                   
43)     dpkg-dev recommends build-essential           
44)     gcc recommends libc6-dev | libc-dev           
45)     gcc-4.6 recommends libc6-dev (>= 2.13-0ubuntu6)
46)     libltdl-dev recommends libtool                 
47)     libqt3-compat-headers recommends libqt3-mt-dev
48)     libqt3-headers recommends libqt3-mt-dev       
49)     qt3-dev-tools recommends libqt3-mt-dev         


Accept this solution? [Y/n/q/?]

همچنین !
sudo apt-get remove linux-headers-3.2.0-23 linux-headers-3.2.0-23-generic linux-image-3.2.0-23-generic linux-libc-dev
[sudo] password for admin:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  x11proto-resource-dev libxcb-shm0-dev libtinfo5-dbg libstartup-notification0-dev libpcrecpp0 x11proto-composite-dev libpth-dev
  libcairo-script-interpreter2 x11proto-damage-dev libxdamage-dev libxcomposite-dev libpixman-1-dev libxres-dev libxcb-render0-dev
  libtinfo-dev
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  fontconfig-config gir1.2-pango-1.0 libc-bin libc-dev-bin libc6 libcairo-gobject2 libcairo-script-interpreter2 libcairo2 libexpat1
  libfontconfig1 libglib2.0-0 libglib2.0-bin libpango1.0-0 linux-generic linux-headers-3.2.0-32 linux-headers-3.2.0-32-generic
  linux-headers-generic linux-image-3.2.0-32-generic linux-image-generic
Suggested packages:
  glibc-doc ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp fdutils linux-doc-3.2.0
  linux-source-3.2.0 linux-tools
The following packages will be REMOVED:
  build-essential comerr-dev g++ g++-4.6 gnome-common gtk-doc-tools krb5-multidev libatk1.0-dev libc6-dev libcairo2-dev libcups2-dev
  libexpat1-dev libfontconfig1-dev libfreetype6-dev libgcrypt11-dev libgdk-pixbuf2.0-dev libglib2.0-dev libgnutls-dev libgpgme11-dev
  libgtk2.0-dev libjpeg-dev libjpeg-turbo8-dev libjpeg8-dev libkrb5-dev libmng-dev libncurses5-dbg libncurses5-dev libpango1.0-dev
  libpcre3-dev libpng12-dev libqt3-mt-dev libstdc++6-4.6-dev libtool libusb-dev libwnck-dev libxft-dev linux-headers-3.2.0-23
  linux-headers-3.2.0-23-generic linux-image-3.2.0-23-generic linux-libc-dev mate-common zlib1g-dev
The following NEW packages will be installed:
  linux-headers-3.2.0-32 linux-headers-3.2.0-32-generic linux-image-3.2.0-32-generic
The following packages will be upgraded:
  fontconfig-config gir1.2-pango-1.0 libc-bin libc-dev-bin libc6 libcairo-gobject2 libcairo-script-interpreter2 libcairo2 libexpat1
  libfontconfig1 libglib2.0-0 libglib2.0-bin libpango1.0-0 linux-generic linux-headers-generic linux-image-generic
16 upgraded, 3 newly installed, 42 to remove and 455 not upgraded.
Need to get 58.3 MB of archives.
After this operation, 106 MB disk space will be freed.
Do you want to continue [Y/n]?
« آخرین ویرایش: 01 آبان 1391، 10:17 ب‌ظ توسط h1229m »
عاقبت انحصار شکست و سرانجام کمونیسم گنویی دیکتاتوریست !
الگوی متن باز از هر جهت بر الگوی نرم افزار آزاد رجحان دارد
وَسَيَعْلَمُ الَّذِينَ ظَلَمُوا أَيَّ مُنْقَلَبٍ يَنْقَلِبُونَ

آفلاین ح.م

  • High Hero Member
  • *
  • ارسال: 1274
  • جنسیت : پسر
  • دین بدون خرد مانند خرد بدون دین بی معناست
پاسخ : نصب کرنل ۳.۴ یا ۳.۵
« پاسخ #7 : 01 آبان 1391، 10:49 ب‌ظ »
مشکل حل شد ! مشکل با این بسته بود !
linux-libc-devبی خیال حذفش شدم درست شد !
این رو نگاه کنید !‌
sudo apt-get remove linux-libc-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  x11proto-resource-dev libxcb-shm0-dev libtinfo5-dbg libstartup-notification0-dev libpcrecpp0 x11proto-composite-dev libpth-dev
  libcairo-script-interpreter2 x11proto-damage-dev libxdamage-dev libxcomposite-dev libpixman-1-dev libxres-dev libxcb-render0-dev
  libtinfo-dev
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  fontconfig-config gir1.2-pango-1.0 libc-bin libc-dev-bin libc6 libcairo-gobject2 libcairo-script-interpreter2 libcairo2 libexpat1
  libfontconfig1 libglib2.0-0 libglib2.0-bin libpango1.0-0
Suggested packages:
  glibc-doc ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp
The following packages will be REMOVED:
  build-essential comerr-dev g++ g++-4.6 gnome-common gtk-doc-tools krb5-multidev libatk1.0-dev libc6-dev libcairo2-dev libcups2-dev
  libexpat1-dev libfontconfig1-dev libfreetype6-dev libgcrypt11-dev libgdk-pixbuf2.0-dev libglib2.0-dev libgnutls-dev libgpgme11-dev
  libgtk2.0-dev libjpeg-dev libjpeg-turbo8-dev libjpeg8-dev libkrb5-dev libmng-dev libncurses5-dbg libncurses5-dev libpango1.0-dev
  libpcre3-dev libpng12-dev libqt3-mt-dev libstdc++6-4.6-dev libtool libusb-dev libwnck-dev libxft-dev linux-libc-dev mate-common
  zlib1g-dev
The following packages will be upgraded:
  fontconfig-config gir1.2-pango-1.0 libc-bin libc-dev-bin libc6 libcairo-gobject2 libcairo-script-interpreter2 libcairo2 libexpat1
  libfontconfig1 libglib2.0-0 libglib2.0-bin libpango1.0-0
13 upgraded, 0 newly installed, 39 to remove and 455 not upgraded.
Need to get 7,630 kB of archives.
After this operation, 107 MB disk space will be freed.
Do you want to continue [Y/n]?
« آخرین ویرایش: 01 آبان 1391، 10:55 ب‌ظ توسط h1229m »
عاقبت انحصار شکست و سرانجام کمونیسم گنویی دیکتاتوریست !
الگوی متن باز از هر جهت بر الگوی نرم افزار آزاد رجحان دارد
وَسَيَعْلَمُ الَّذِينَ ظَلَمُوا أَيَّ مُنْقَلَبٍ يَنْقَلِبُونَ

آفلاین doomhammer65ir

  • High Hero Member
  • *
  • ارسال: 1572
  • جنسیت : پسر
    • IRAN Backup
پاسخ : نصب کرنل ۳.۴ یا ۳.۵
« پاسخ #8 : 01 آبان 1391، 11:01 ب‌ظ »
خوب برادر من خودت فرمان میدی کتابخانه ی سی رو پاک کن بعد میگی چرا داره کتابخانه سی رو پاک میکنه ؟ :o
بگمانم داری از روی یک راهنما این کارها رو میکنی . هر فرمانی که توی راهنما نوشته است رو نباید اجرا کنی

آفلاین ح.م

  • High Hero Member
  • *
  • ارسال: 1274
  • جنسیت : پسر
  • دین بدون خرد مانند خرد بدون دین بی معناست
پاسخ : نصب کرنل ۳.۴ یا ۳.۵
« پاسخ #9 : 01 آبان 1391، 11:09 ب‌ظ »
آره داشتم از یه سری دستور می زدم ! راهنما گفته بود ! این دستور رو می زنی !‌
dpkg -l | grep ^ii | grep 3.2.0-23 | awk -F' ' '{ print $2 }'
بعد هر چی package نشون داد رو با دستور
sudo apt-get remove .... حذف می کنی ! اون ! پکیح هم جزئی از اون بود ! چون مخصوص generic 3.2 بود !
 می خواستم اگه شد کتابخانه c مخصوص 3.6 generic رو پیدا کنم !
« آخرین ویرایش: 01 آبان 1391، 11:12 ب‌ظ توسط h1229m »
عاقبت انحصار شکست و سرانجام کمونیسم گنویی دیکتاتوریست !
الگوی متن باز از هر جهت بر الگوی نرم افزار آزاد رجحان دارد
وَسَيَعْلَمُ الَّذِينَ ظَلَمُوا أَيَّ مُنْقَلَبٍ يَنْقَلِبُونَ