انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

نویسنده موضوع: مشکل در بروز رسانی سیستم  (دفعات بازدید: 335 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین freen

  • Jr. Member
  • *
  • ارسال: 64
  • جنسیت : پسر
مشکل در بروز رسانی سیستم
« : 09 مهر 1401، 11:22 ق‌ظ »
با سلام.
اخیرا و با توجه به شرایط حاکم بر اینترنت من نمیتونم با استفاده از دستورات
sudo apt update && sudo apt upgradeسیستم رو بروز رسانی کنم و برای repository های google chrome و node با توجه به تحریم ها فک کنم update ها کنسل شده و دارای مشکل میباشد. قندشکنی هم که قبلا خریداری کرده بودم الان کار نمیکنه و با سیستم تور هم نتونستم متصل بشم. سایت شکن هم فک میکنم در این مورد کارایی نداره. دوستان راه حلتون برای این مشکل چی هستش؟
متشکرم

آفلاین سودو

  • High Hero Member
  • *
  • ارسال: 3022
  • جنسیت : پسر
  • :(){ :|:& };:
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #1 : 09 مهر 1401، 11:42 ق‌ظ »
دوستان راه حلتون برای این مشکل چی هستش؟
مخزن خارجی اضافه نکنید.
آرچ و گنوم!

آفلاین freen

  • Jr. Member
  • *
  • ارسال: 64
  • جنسیت : پسر
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #2 : 09 مهر 1401، 11:54 ق‌ظ »

مخزن خارجی اضافه نکنید.
[/quote]

الان این راه حل بود یا پاک کردن صورت مساله؟

آفلاین سودو

  • High Hero Member
  • *
  • ارسال: 3022
  • جنسیت : پسر
  • :(){ :|:& };:
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #3 : 09 مهر 1401، 12:09 ب‌ظ »
معادله اشتباهو که نمی‌شه حلش کرد!
آرچ و گنوم!

آفلاین aboldom

  • High Hero Member
  • *
  • ارسال: 1608
  • جنسیت : پسر
  • متن شخصی
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #4 : 09 مهر 1401، 12:39 ب‌ظ »
سلام، کروم که انحصاری هست و کلا انحصاری هم نباشه روش خوبی نیست دستکاری مخازن احتمال داره در آینده به مشکل بخورید که سودو هم درمورد اضافه نکردن مخازن خارجی گفتش، حالا مشکل اگه بروزرسانی مخازن توزیع هست چند راه شاید جواب بده، تور که در سیستم شما نصب هست پل نداره و مستقیم میخواد وصل بشه که احتمالش زیاده کار نکنه، یا بگردید دنبال پل های تور و اضافه اش کنید، یا یک راه ساده تر مرورگر تور نصب کنید داخل خودش پل های خوبی داره، وقتی مرورگر تور اجرا میشه در پورت 9150 پروکسی داخلی ایجاد میکنه(معادل دقیق اسم علمیش نمیدونم)  حالا با ابزار هایی مثل torsocks یا proxychains میتونید بهش مقدار 9150 بدید به راحتی، و حالا apt رو با استفاده از این ها اجرا کنید، برای مثال اینطوری
sudo proxychains apt install name
راه دیگه استفاده از شادوساکس  هست که آقا آرمان آموزش خوبی ایجاد کرده درموردش https://forum.ubuntu.ir/index.php?topic=154575.0
حداکثر: 300; کاراکتر باقیمانده: 300

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 17558
  • جنسیت : پسر
  • Urahara Kiesuke
    • وبلاگ
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #5 : 10 مهر 1401، 02:12 ب‌ظ »
به هیچ عنوان نباید مخزن خارجی اضافه کنید. نود که توی مخازن هست و کروم هم مالکیته و نباید استفاده بشه.
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن

آفلاین freen

  • Jr. Member
  • *
  • ارسال: 64
  • جنسیت : پسر
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #6 : 10 مهر 1401، 11:35 ب‌ظ »
معادله اشتباهو که نمی‌شه حلش کرد!
خوب واقعا نمیتونم همه چی رو فعلا از مخازن نصب کنم. من به کروم وابسته هستم و سالها با اون کار کردم. تا بیام به فایرفاکس زمان لازم داره. دستورات نصب node رو هم از گیت رسمی سایتشون دانلود کردم. بدترین قسمت ماجرا اینه که هیچ برنامه ای مشابه vscode هم برای ubuntu موجود نیست. همین tor رو که نصب کردم باید ppa مخصوص خودش رو به سیستم اضافه میکردم. دستورالعمل نصبش هم از همین ویکی شما گرفتم. اما الان نصب شده و کار نمیکنه.
واقعا گیج شدم. من نمیخوام دوباره به محیط ویندوز برگردم اما بعضی وقت ها کم میارم :(

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 17558
  • جنسیت : پسر
  • Urahara Kiesuke
    • وبلاگ
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #7 : 10 مهر 1401، 11:39 ب‌ظ »
هم node توی مخازن هست و هم tor. نصب ppa برای هرکدومشون، سیستم رو خراب می‌کنه. کجای ویکی چنین راهنمایی اشتباهی شده؟ بگید که درستش کنیم.
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن

آفلاین aboldom

  • High Hero Member
  • *
  • ارسال: 1608
  • جنسیت : پسر
  • متن شخصی
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #8 : 11 مهر 1401، 02:20 ق‌ظ »
همینطور که گفتند درسته و در مخازن هستند، و درمورد تور هم مشکل از نسخه تور نیست احتمالا، برای وصل شدنش نیاز به اضافه کردن پل به تور هست و به صورت مستقیم با بعضی اینترنت ها وصل نمیشه، برای راحت تر شدن کار میتونید از مرورگر تور با پل های آماده استفاده کنید
حداکثر: 300; کاراکتر باقیمانده: 300

آفلاین Mehr32

  • High Hero Member
  • *
  • ارسال: 4558
  • جنسیت : پسر
  • ایران تسلیت
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #9 : 11 مهر 1401، 05:39 ب‌ظ »
اگه نمیتونید فعلا کروم رو کنار بزارید حد اقل از کرومیوم استفاده کنید
ایران تسلیت!
پیامبر اکرم(ص) :«هرکس از ما کمکی بخواهد ما به او کمک می کنیم اما اگر کسی دست نیاز پیش دیگران دراز نکند خداوند او را بی‌نیاز خواهد ساخت ».

آفلاین freen

  • Jr. Member
  • *
  • ارسال: 64
  • جنسیت : پسر
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #10 : 11 مهر 1401، 09:09 ب‌ظ »
هم node توی مخازن هست و هم tor. نصب ppa برای هرکدومشون، سیستم رو خراب می‌کنه. کجای ویکی چنین راهنمایی اشتباهی شده؟ بگید که درستش کنیم.
در این صفحه از ویکی :
https://wiki.ubuntu.ir/wiki/%DA%A9%D8%A7%D8%B1%D8%A8%D8%B1%D8%A7%D8%AA%D9%88%D8%B1
شما برای نصب کاربراتور برای استفاده از تور گفنید که ppa اضافه کنیم و من هم برای استفاده از تور و کاربراتور مطابق همین دستور کار کردم و نتیجه نگرفتم.
اگه نمیتونید فعلا کروم رو کنار بزارید حد اقل از کرومیوم استفاده کنید
آیا کرومیوم در مخازن اصلی موجوده؟

و مهمترین قسمت برای من برنامه vscode و یا مشابهش هست. vscode که طبیعتا در مخازن رسمی نیست اما در snap موجوده و من snap رو مطابق دستورالعمل حذف کردم. برنامه codium هم برای نصبش باید ppa اضافه کنم.

هم node توی مخازن هست و هم tor. نصب ppa برای هرکدومشون، سیستم رو خراب می‌کنه. کجای ویکی چنین راهنمایی اشتباهی شده؟ بگید که درستش کنیم.
ورژن node موجود در مخازن با ورژن lts که من احتیاج دارم متفاوته. همین هم باعث شد که من ppa اضافه کنم.
کلا این تنظیمات سخت و پیچیده است و اغلب اوقات خیلی زمان بر. همین عدم ثبات یه خورده اذیتم میکنه

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 17558
  • جنسیت : پسر
  • Urahara Kiesuke
    • وبلاگ
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #11 : 12 مهر 1401، 01:35 ب‌ظ »
در این صفحه از ویکی :
https://wiki.ubuntu.ir/wiki/%DA%A9%D8%A7%D8%B1%D8%A8%D8%B1%D8%A7%D8%AA%D9%88%D8%B1
شما برای نصب کاربراتور برای استفاده از تور گفنید که ppa اضافه کنیم و من هم برای استفاده از تور و کاربراتور مطابق همین دستور کار کردم و نتیجه نگرفتم.
اون فقط برای کاربراتوره و نه تور. منظورت از نتیجه نگرفتم چیه؟ احتمالاً باید یه موضوع جدا براش ایجاد کنی.


آیا کرومیوم در مخازن اصلی موجوده؟
در دبیان بله؛ در اوبونتو نه.

و مهمترین قسمت برای من برنامه vscode و یا مشابهش هست. vscode که طبیعتا در مخازن رسمی نیست اما در snap موجوده و من snap رو مطابق دستورالعمل حذف کردم. برنامه codium هم برای نصبش باید ppa اضافه کنم.
البته vscode برنامهٔ بدیه. هم از نظر اخلاقی که آزاد نیست و هم از نظر فنی که با الکترون نوشته شده. برنامه‌نویس‌های حرفه‌ای، ویم و ای‌مکس رو توصیه می‌کنن، ولی می‌تونید از محیط‌های کمکی گرافیکی برای برنامه‌نویسی هم استفاده کنید. مثل لپس

ورژن node موجود در مخازن با ورژن lts که من احتیاج دارم متفاوته. همین هم باعث شد که من ppa اضافه کنم.
خب این نشون می‌ده که باید یه توزیع LTS هم نصب کنید برای داشتن نود LTS.

کلا این تنظیمات سخت و پیچیده است و اغلب اوقات خیلی زمان بر. همین عدم ثبات یه خورده اذیتم میکنه
اتفاقاً اگه منطق پشتش رو بدونی، خیلی راحت و بدیهیه.
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن

آفلاین freen

  • Jr. Member
  • *
  • ارسال: 64
  • جنسیت : پسر
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #12 : 12 مهر 1401، 04:42 ب‌ظ »
نقل‌قول
اون فقط برای کاربراتوره و نه تور. منظورت از نتیجه نگرفتم چیه؟ احتمالاً باید یه موضوع جدا براش ایجاد کنی.
یعنی من الان بعد از نصب کاربراتور نمیتونم تور رو اجرا کنم. از ۱۰ درصد بیشتر لود نمیشه. فک میکنم برای اون باید یه تاپیک جدا بزنم.

نقل‌قول
در دبیان بله؛ در اوبونتو نه.

پس کروم کلا تو اوبونتو منتفیه.


نقل‌قول
البته vscode برنامهٔ بدیه. هم از نظر اخلاقی که آزاد نیست و هم از نظر فنی که با الکترون نوشته شده. برنامه‌نویس‌های حرفه‌ای، ویم و ای‌مکس رو توصیه می‌کنن، ولی می‌تونید از محیط‌های کمکی گرافیکی برای برنامه‌نویسی هم استفاده کنید. مثل لپس

بله میدونم vscode کدهاش آزاد نیست ولی رایگانه. از اینجا دوستان codium رو پیشنهاد دادن که هم رایگانه و هم آزاد اما برای اوبونتو نیاز به ppa داره و اون هم با سیاست های نصب برنامه اوبونتو در تعارضه! ویم و ایمکس شاید محیط های خوبی باشند اما من باهاشون کار نکردم و محیط گرافیکی هم ندارن. در واقع فک میکنم کدنویسی با اونها با توجه به سیستم autocomplete و سایر امکاناتی که دارند خیلی سریعتر باشه.

نقل‌قول
اتفاقاً اگه منطق پشتش رو بدونی، خیلی راحت و بدیهیه.
نکته اصلی همینه. مطمئنم اگر بتونم یه سالی رو اینجا دوام بیارم دیگه کارم خیلی راحت تر میشه. ولی تا اون موقع با توجه به این که این موراد حلشون برای من مبتدی خیلی زمان بر هستش باعث میشه که از کارم عقب بیفتم.


آفلاین Mehr32

  • High Hero Member
  • *
  • ارسال: 4558
  • جنسیت : پسر
  • ایران تسلیت
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #13 : 12 مهر 1401، 04:53 ب‌ظ »
نقل‌قول
ز اینجا دوستان codium رو پیشنهاد دادن که هم رایگانه و هم آزاد اما برای اوبونتو نیاز به ppa داره و اون هم با سیاست های نصب برنامه اوبونتو در تعارضه! ویم و ایمکس شاید محیط های خوبی باشند اما من باهاشون کار نکردم و محیط گرافیکی هم ندارن. در واقع فک میکنم کدنویسی با اونها با توجه به سیستم autocomplete و سایر امکاناتی که دارند خیلی سریعتر باشه.
حد اقل از نصب نرم افزار انحصاری که بهتره ! بهد هم ppa در شرایط خاص منعی ندارد و البته نصب فایل deb یک نرم افزار انحصاری گوگل خیلی کار زشتیه من بودم حکم اعدام نمیدادم لطف کرده بودم !
در کل بهتره با چیز های استاندارد و درست خودتون رو عادت بدید میتونیب با درست کردن یک تم فایرفاکس برای خودتون یا حتی انتشار عمومیش شروع کنید !  ;) خیلی راحته !
ایران تسلیت!
پیامبر اکرم(ص) :«هرکس از ما کمکی بخواهد ما به او کمک می کنیم اما اگر کسی دست نیاز پیش دیگران دراز نکند خداوند او را بی‌نیاز خواهد ساخت ».

آفلاین behzad1

  • Full Member
  • *
  • ارسال: 194
  • جنسیت : پسر
پاسخ : مشکل در بروز رسانی سیستم
« پاسخ #14 : 12 مهر 1401، 06:12 ب‌ظ »
آیا کرومیوم در مخازن اصلی موجوده؟
در دبیان بله؛ در اوبونتو نه.
کرومیوم هم در اوبونتو موجوده هم در دبیان.
پس کروم کلا تو اوبونتو منتفیه.
کرومیوم با کروم فرق می‌کنه.