انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

نویسنده موضوع: مشکل با تغییر زبان در openbox دبیان ۱۱  (دفعات بازدید: 461 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین vegetarian

  • Sr. Member
  • *
  • ارسال: 391
  • جنسیت : پسر
  • سیستم عامل : ننه اوبونتو
مشکل با تغییر زبان در openbox دبیان ۱۱
« : 28 فروردین 1401، 12:53 ق‌ظ »
دبیان ۱۱ استاندارد رو به همراه openbox نصب کردم الان مشکلم اینجاست که وقتی دستور زیر رو در ترمینال می زنم زبان با Alt+shift چپ و راست تغییر می کنه :
setxkbmap -layout "us,ir" -option "grp:alt_shift_toggle"
ولی وقتی همین دستور رو به این صورت در فایل ~/.config/openbox/autostart قرار میدم و لاگ اوت لاگین می کنم عمل نمی کنه و زبان با کلیدهای مورد نظر تغییر نمی کنه.
setxkbmap -layout "us,ir" -option "grp:alt_shift_toggle" &
دوره lpic1 آقای پیمان هوشمندی راد برای علاقه مندان به لینوکس (مجانی):
https://forum.ubuntu.ir/index.php?topic=152339.0

آفلاین M!lad

  • عضو کاربران ایرانی اوبونتو
  • *
  • ارسال: 1754
پاسخ : مشکل با تغییر زبان در openbox دبیان ۱۱
« پاسخ #1 : 28 فروردین 1401، 01:55 ق‌ظ »
مطمئن بشید فایل مذکور executable هست.


همینطور به جای این روش می‌تونید این فایل رو ایجاد کنید:

$ vim sudo /etc/X11/xorg.conf.d/10-keyboard.conf
Section "InputClass"
    Identifier "keyboard-all"
    Driver "evdev"
    Option "XkbLayout" "us,ir"
    Option "XkbOptions" "grp:alt_shift_toggle,caps:escape"
    MatchIsKeyboard "on"
EndSection

ٓX رو مجدد راه‌اندازی کنید. تو روش دوم همه کاربرها به تنظیمات کیبورد دسترسی دارند.
..I feel no fault for the fault I feel..

آفلاین vegetarian

  • Sr. Member
  • *
  • ارسال: 391
  • جنسیت : پسر
  • سیستم عامل : ننه اوبونتو
پاسخ : مشکل با تغییر زبان در openbox دبیان ۱۱
« پاسخ #2 : 28 فروردین 1401، 05:02 ق‌ظ »
مطمئن بشید فایل مذکور executable هست.


همینطور به جای این روش می‌تونید این فایل رو ایجاد کنید:

$ vim sudo /etc/X11/xorg.conf.d/10-keyboard.conf
Section "InputClass"
    Identifier "keyboard-all"
    Driver "evdev"
    Option "XkbLayout" "us,ir"
    Option "XkbOptions" "grp:alt_shift_toggle,caps:escape"
    MatchIsKeyboard "on"
EndSection

ٓX رو مجدد راه‌اندازی کنید. تو روش دوم همه کاربرها به تنظیمات کیبورد دسترسی دارند.
ممنون که جواب دادین
فایل executable ,autostart هست
روشی که شما گفتین رو انجام دادم ولی متاسفانه کار نمی کنه
دوره lpic1 آقای پیمان هوشمندی راد برای علاقه مندان به لینوکس (مجانی):
https://forum.ubuntu.ir/index.php?topic=152339.0

آفلاین vegetarian

  • Sr. Member
  • *
  • ارسال: 391
  • جنسیت : پسر
  • سیستم عامل : ننه اوبونتو
پاسخ : مشکل با تغییر زبان در openbox دبیان ۱۱
« پاسخ #3 : 28 فروردین 1401، 09:44 ق‌ظ »
عجیبه حالا وقتی سیستم رو ریبوت می کنم درسته ولی وقتی لوگ اوت لاگین می کنم کار نمی کنه :)
دوره lpic1 آقای پیمان هوشمندی راد برای علاقه مندان به لینوکس (مجانی):
https://forum.ubuntu.ir/index.php?topic=152339.0

آفلاین M!lad

  • عضو کاربران ایرانی اوبونتو
  • *
  • ارسال: 1754
پاسخ : مشکل با تغییر زبان در openbox دبیان ۱۱
« پاسخ #4 : 28 فروردین 1401، 11:59 ق‌ظ »
الان حل شده مشکل؟ یا همچنان پا بر جاست؟
..I feel no fault for the fault I feel..

آفلاین vegetarian

  • Sr. Member
  • *
  • ارسال: 391
  • جنسیت : پسر
  • سیستم عامل : ننه اوبونتو
پاسخ : مشکل با تغییر زبان در openbox دبیان ۱۱
« پاسخ #5 : 28 فروردین 1401، 12:20 ب‌ظ »
الان حل شده مشکل؟ یا همچنان پا بر جاست؟
وقتی سیستم رو روشن می کنم درسته ولی وقتی لاگ اوت و لاگین می کنم بازم کار نمی کنه
دوره lpic1 آقای پیمان هوشمندی راد برای علاقه مندان به لینوکس (مجانی):
https://forum.ubuntu.ir/index.php?topic=152339.0

آفلاین M!lad

  • عضو کاربران ایرانی اوبونتو
  • *
  • ارسال: 1754
پاسخ : مشکل با تغییر زبان در openbox دبیان ۱۱
« پاسخ #6 : 28 فروردین 1401، 03:42 ب‌ظ »
تنها حالت ممکن این هست که تنظیمات بعد از لاگین در یک مرحله‌ای بازنویسی می‌شند. به همین دلیل هست وقتی توی ترمینال دستور رو وارد می‌کنید کار می‌کنه (مجدد بازنویسی میشه به مقدار دلخواه). Display Manager چی هست؟ اگر دستور رو توی profile./~ بزارید مشکل حل نمی‌شه؟
..I feel no fault for the fault I feel..

آفلاین vegetarian

  • Sr. Member
  • *
  • ارسال: 391
  • جنسیت : پسر
  • سیستم عامل : ننه اوبونتو
پاسخ : مشکل با تغییر زبان در openbox دبیان ۱۱
« پاسخ #7 : 28 فروردین 1401، 05:56 ب‌ظ »
display manager :lightdm

اون دستوری که خودم گفته بودم رو گذاشتم انتهای فایل ~/.profile و نتیجه ای نداشت .سیستم رو ریبوت کردم که بعد از ریبوت همه چی درسته ولی به محض لاگ اوت و لاگین مجدد دیگه نمی شه زبان رو تغییر داد
دوره lpic1 آقای پیمان هوشمندی راد برای علاقه مندان به لینوکس (مجانی):
https://forum.ubuntu.ir/index.php?topic=152339.0

آفلاین M!lad

  • عضو کاربران ایرانی اوبونتو
  • *
  • ارسال: 1754
پاسخ : مشکل با تغییر زبان در openbox دبیان ۱۱
« پاسخ #8 : 31 فروردین 1401، 11:03 ق‌ظ »
یک خروجی از محتوای این دایرکتوری قرار میدید؟

ls /etc/X11/xorg.conf.d/
..I feel no fault for the fault I feel..