انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

لطفاً هر چه زودتر، اوبونتوی خود را به نگارش ۲۱٫۱۰ ارتقا دهید

نویسنده موضوع: تغییر نسخه پایتون به 3.10 در توزیع اوبونتو  (دفعات بازدید: 587 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین behDev

  • Sr. Member
  • *
  • ارسال: 313
  • جنسیت : پسر
  • آرچ + گنوم
وقتی تو آرچ کرنل نصب میشه، بسته  python-sphinx_rtd_theme هم نصب خواهد شد که این بسته به پایتون ۲ نیاز داره. پس پایتون ۲ نصب میشه. البته این مورد با make صدق میکنه.
فکر می‌کنم اشتباه می‌کنی. چون پایتون ۲ دیگه وجود نداره.
بله درست میگید. خود به خود نصب نمیشه با make نیاز هست.

آفلاین آرمان اسماعیلی

  • High Hero Member
  • *
  • ارسال: 1704
  • جنسیت : پسر
نقل‌قول
تغییر دادم هیچی باز نمیشه حتی ترمینال 
این همه «نکنید» که گفتن، مصداق آب در هاون کوبیدن بود؟

خوب اگه امتحان نکنیم به مشکل نخوریم یاد نمیگیریم .
خیلی هم عالی. سؤالی که پیش میاد اینه که الان شما چه چیز جدیدی یاد گرفتید که داخل همین تاپیک و از صحبت‌های دوستان یاد نگرفته بودید؟
صفحه‌ی من در اینستاگرام: ‎‎@armanes92

آفلاین saeedjeddi

  • Jr. Member
  • *
  • ارسال: 49
  • جنسیت : پسر
  • سعید
سلام چطور میشه نسخه پایتون 3.8 در توزیع اوبونتو 20.4 رو به پایتون 3.10 تغییر داد ؟
سلام. نمی‌شه و نباید هم بکنید!

نکنید، سیستم می‌ترکه. پایتون 3.10 هنوز توی اوبونتو 21.10 هم نیست.
حتا توی ۲۲٫۰۴ هم هنوز پیش‌گزیده نیست.

می ترکه؟   :o
چرا؟ مگه ارتقا یک پکیج چه مشکلی داره
بسته‌های مخازن به هم وابسته هستن. نمی‌تونید یکی از بخش‌هاش رو ارتقا بدید، بدون این که بقیه به مشکل بخورن.

1- پس چرا تو ویندوز اینطور نیست ؟ نسخه قبلی رو پاک و نسخه بروز رو نصب میکنی .
چون ویندوز آشغاله! توی ویندوز، تمام وابستگی‌ها رو دستی کنار هم می‌ذارن و اگه یکی از وابستگی‌های یکی از برنامه‌ها مشکلی داشته باشه، مثلاً به‌روز رسانمی امنیتی بده و تمام برنامه‌هایی که اون وابستگی رو تو خودشون دارن، همون لحظه براش به‌روز رسانی ندن و تو هم همون لحظه، همه‌شون رو به‌روز نکنی، تمام سیستمت ناامن می‌شه.


2- مثلا فرض کنیم  اگه یه باگی در نسخه قدیمی پیدا بشه مثلا 3.7 ، هکر ها با اون باگ نرم افزار یا سیستم رو  مختل کنن که با ورژن 3.7 توسعه داده شده  چی باید سیستم عامل رو بروز کنیم ؟ 
وقتی مشکلی در ۳٫۷٫۰ پیدا شه، توی ۳٫۷٫۱ حل می‌شه که یه ارتقای ساده‌است، نه ۳٫۸٫۰!


3- مگه وقتی ورژن جدید یه زبان برنامه نویسی میاد فرق میگه با نسخه جدیدش ؟
بله

مگه اینطور نیست که یه امکاناتی بهش اضافه میشه با حفظ ویژگی های قبلی  ؟
نه لزوماً!





پس دلیل ورژن بندی پایتون چیه ؟ که نسخه قبلی لزوما مثل نسخه جدیدش نیست اونوقت سیستم های که با نسخه قبلی طراحی شده به مشکل نمی خورن ؟
« آخرین ویرایش: 06 آذر 1400، 03:13 ب‌ظ توسط saeedjeddi »

آفلاین Dragon-

  • High Hero Member
  • *
  • ارسال: 2611
  • جنسیت : پسر
توی هر نسخه چیز‌های جدید اضافه میشه یا بعضی چیز‌ها منسوخ میشه یا اینکه بعضی چیز‌ها تغییر می‌کنند.
برنامه‌هایی که با نسخه قبلی نوشته شدند، باید برای نسخه جدید بازنویسی بشن.
تغییرات بین دو نسخه متوالی انقدر نیست که این بازنویسی، مشکل یا خیلی سخت باشه، اما معمولا انقدری هست که باعث بشه برنامه نوشته شده با نسخه قبلی، توی نسخه جدید درست کار نکنه.
میدونید که زکات علم نشر آن است

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 15563
  • جنسیت : پسر
  • Urahara Kiesuke
    • وبلاگ
پس دلیل ورژن بندی پایتون چیه ؟ که نسخه قبلی لزوما مثل نسخه جدیدش نیست اونوقت سیستم های که با نسخه قبلی طراحی شده به مشکل نمی خورن ؟
چرا به مشکل نمی‌خورن؟ برای همینه که توسعه‌دهنده باید نرم‌افزارش رو به صورت مداوم نگه‌داری کنه.
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن

آفلاین Mt

  • Hero Member
  • *
  • ارسال: 745
  • Manjaro + Gnome
پس دلیل ورژن بندی پایتون چیه ؟ که نسخه قبلی لزوما مثل نسخه جدیدش نیست اونوقت سیستم های که با نسخه قبلی طراحی شده به مشکل نمی خورن ؟
چرا به مشکل نمی‌خورن؟ برای همینه که توسعه‌دهنده باید نرم‌افزارش رو به صورت مداوم نگه‌داری کنه.

با این حساب اگر بسته هارو بروز نگه داریم سیستم نیازی به آنتی ویروس پیدا نمی کنه؟
« آخرین ویرایش: 07 آذر 1400، 09:05 ب‌ظ توسط .MTSaghafi »

آفلاین Mehr32

  • High Hero Member
  • *
  • ارسال: 2490
  • جنسیت : پسر
خیر
پیامبر اکرم :«هرکس از ما کمکی بخواهد ما به او کمک میکنیم,ولی اگر کسی دست نیاز پیش دیگران دراز نکند, خداوند او را بی نیاز خواهد ساخت»
طراحی سایت با قیمت عالی site.coffee@
 طراحی پوستر  poster_dizign@

آفلاین Dragon-

  • High Hero Member
  • *
  • ارسال: 2611
  • جنسیت : پسر
با این حساب اگر بسته هارو بروز نگه داریم سیستم نیازی به آنتی ویروس پیدا نمی کنه؟
توی گنو/لینوکس، خیلی کم پیش میاد به ضد ویروس لازم داشته باشید. البته باید حواستون باشه که چیز‌های خارج از مخازن رو با احتیاط نصب کنید، در غیر اینصورت، خیلی راحت ممکنه راه نفوذ به سیستم رو باز کنید.
میدونید که زکات علم نشر آن است

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 15563
  • جنسیت : پسر
  • Urahara Kiesuke
    • وبلاگ
با این حساب اگر بسته هارو بروز نگه داریم سیستم نیازی به آنتی ویروس پیدا نمی کنه؟
به‌روز نگهشون ندارین هم نیازی به ضدویروس پیدا نمی‌کنه. ولی ممکنه راه نفوذ بهش باز شه.
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن

آفلاین Mehr32

  • High Hero Member
  • *
  • ارسال: 2490
  • جنسیت : پسر
با این حساب اگر بسته هارو بروز نگه داریم سیستم نیازی به آنتی ویروس پیدا نمی کنه؟
توی گنو/لینوکس، خیلی کم پیش میاد به ضد ویروس لازم داشته باشید. البته باید حواستون باشه که چیز‌های خارج از مخازن رو با احتیاط نصب کنید، در غیر اینصورت، خیلی راحت ممکنه راه نفوذ به سیستم رو باز کنید.
اون اقلیت رو میتونید بفرمایید ؟ که نیاز است ؟
پیامبر اکرم :«هرکس از ما کمکی بخواهد ما به او کمک میکنیم,ولی اگر کسی دست نیاز پیش دیگران دراز نکند, خداوند او را بی نیاز خواهد ساخت»
طراحی سایت با قیمت عالی site.coffee@
 طراحی پوستر  poster_dizign@

آفلاین Dragon-

  • High Hero Member
  • *
  • ارسال: 2611
  • جنسیت : پسر
وقتی که کامپیوتر‌های ویندوزی هم باشه و بخواهید فایل‌های اونها رو بررسی کنید. یا اینکه کامپیوتر rootkit گرفته باشه، در این شرایط باید از یه چیزی مثل rootkithunter استفاده بشه.
من تا حالا ندیدم کسی از آنتی‌ویروس توی گنو/لینوکس استفاده کنه.
میدونید که زکات علم نشر آن است