انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

لطفاً هر چه زودتر، اوبونتوی خود را به نگارش ۲۱٫۱۰ ارتقا دهید

نویسنده موضوع: نویز صدا  (دفعات بازدید: 896 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین Mt

  • Hero Member
  • *
  • ارسال: 704
  • Manjaro + Xfce
نویز صدا
« : 10 آبان 1400، 10:01 ق‌ظ »
سلام من اوبونتو نسخه ۲۱.۱۰ رو دارم اسپیکر من مثل زنبور ززز می کنه ولی وقتی صدایی پخش میشه از سیستم قطع میشه و بعد از چند ثانیه اگر چیزی پخش نشه همین اتفاق میوفته.
من بطور موقت یک روشی برای حل این مشکل پیدا کردم که فقط روی گنوم این روش برای من جواب میده: توی تنظیمات به بخش صدا که میری قطع میشه نویز من هر سری سیستم رو روشن می کنم تنظیمات رو باز می کنم بعد میرم تو بخش صدا و بعد مینیمایز می کنم راهی نیست که این نویز بصورت دائمی حل بشه توی ویندوز همچین مشکلی وجود نداشت.

درایور کارت گرافیک هم روی xorg هست درایور انحصاری انویدیا هم وجود داره ولی وقتی فعالش می کنم موقع بالا اومدن سیستم صفحه سیاه نشون میده و مجبورم از طریق ترمینال درایور رو پاک کنم.
« آخرین ویرایش: 15 آبان 1400، 11:25 ق‌ظ توسط Mtsaghafi »

آفلاین mobin1387

  • Sr. Member
  • *
  • ارسال: 360
  • جنسیت : پسر
  • I like void Linux
    • وب سایت شخصی خودم (نگرد توش هیچی نیست)
پاسخ : نویز صدا
« پاسخ #1 : 10 آبان 1400، 10:52 ق‌ظ »
سلام من اوبونتو نسخه ۲۱.۱۰ رو دارم اسپیکر من مثل زنبور ززز می کنه ولی وقتی صدایی پخش میشه از سیستم قطع میشه و بعد از چند ثانیه اگر چیزی پخش نشه همین اتفاق میوفته.
من بطور موقت یک روشی برای حل این مشکل پیدا کردم که فقط روی گنوم این روش برای من جواب میده: توی تنظیمات به بخش صدا که میری قطع میشه نویز من هر سری سیستم رو روشن می کنم تنظیمات رو باز می کنم بعد میرم تو بخش صدا و بعد مینیمایز می کنم راهی نیست که این نویز بصورت دائمی حل بشه توی ویندوز همچین مشکلی وجود نداشت.

درایور کارت گرافیک هم روی xorg هست درایور انحصاری انویدیا هم وجود داره ولی وقتی فعالش می کنم موقع بالا اومدن سیستم صفحه سیاه نشون میده و مجبورم از طریق ترمینال درایور رو پاک کنم.

ممنون میشم مدل سخت افزار رو اعلام کنید
کاری ندارم که سیستم عامل گنو درسته یا لینوکس یا گنو/لینوکس ولی خداوکیلی تمام مشکلات نرم افزار های آزاد الآن فقط اسم گذاریه؟ :/

آفلاین Mt

  • Hero Member
  • *
  • ارسال: 704
  • Manjaro + Xfce
پاسخ : نویز صدا
« پاسخ #2 : 10 آبان 1400، 11:48 ق‌ظ »
کارت گرافیک nvidia GForce 210

آفلاین amir28.ns

  • Newbie
  • *
  • ارسال: 4
  • جنسیت : پسر
    • لینوکسی ها
پاسخ : نویز صدا
« پاسخ #3 : 11 آبان 1400، 06:23 ب‌ظ »
مشکل صدا از درایور کارت‌گرافیک نیست از درایور کارت صداست. البته یه تست بکن ببین وقتی موقع لاگین gnome on wayland رو انتخاب میکنی باز این مشکل وجود داره یا نه.البته فکر نمی‌کنم تاثیر داشته باشه(برای این اینو گفتم که دقیق یادم نیست pipewire که به جای pulseaudio توی گنوم استفاده میشه فقط توی wayland کار میکنه یا نه)

آفلاین Dragon-

  • High Hero Member
  • *
  • ارسال: 2563
  • جنسیت : پسر
پاسخ : نویز صدا
« پاسخ #4 : 11 آبان 1400، 06:29 ب‌ظ »
pipewire روی x11 هم کار میده. برای من روی دبیان نصب شده بود ولی چون بهش نیاز نداشتم، حذفش کردم. :D
میدونید که زکات علم نشر آن است

آفلاین Mt

  • Hero Member
  • *
  • ارسال: 704
  • Manjaro + Xfce
پاسخ : نویز صدا
« پاسخ #5 : 12 آبان 1400، 01:59 ق‌ظ »
pipewire روی x11 هم کار میده. برای من روی دبیان نصب شده بود ولی چون بهش نیاز نداشتم، حذفش کردم. :D

سلام ببخشید من چند هفته ای بیشتر نیست اوبونتو نصب کردم میشه بیشتر توضیح بدید. البته من پکیج pulseaudio رو نصب کردم.

مال من ۲ تا گزینه بیشتر نداره
Ubuntu

Ubuntu on xorg

چه فرقی دارن در ظاهر که یکی بودن.

آفلاین Aminavy

  • Sr. Member
  • *
  • ارسال: 255
  • جنسیت : پسر
پاسخ : نویز صدا
« پاسخ #6 : 12 آبان 1400، 01:27 ب‌ظ »
فکر کنم توی ubuntu on xorg درایور انحصاری انویدیا نباشه باید به درد فیلم برداری از صفحه بخوره
« آخرین ویرایش: 12 آبان 1400، 05:16 ب‌ظ توسط Aminavy »

آفلاین Mt

  • Hero Member
  • *
  • ارسال: 704
  • Manjaro + Xfce
پاسخ : نویز صدا
« پاسخ #7 : 12 آبان 1400، 02:28 ب‌ظ »
تو تنظیمات درایور های اوبونتو من روی xorg تنظیم کردم روی انویدیا بزنم سیستم دیگه بالا نمیاد همیشه هم مال من روی Ubuntu‌ معمولی بود.
البته من نسخه 20.04 LTS Focal Fossa نصب بود به جای Ubuntu on xorg نوشته بود Ubuntu on wayland.
« آخرین ویرایش: 18 آبان 1400، 02:43 ب‌ظ توسط Mtsaghafi »

آفلاین Aminavy

  • Sr. Member
  • *
  • ارسال: 255
  • جنسیت : پسر
پاسخ : نویز صدا
« پاسخ #8 : 12 آبان 1400، 05:14 ب‌ظ »
تو تنظیمات درایور های اوبونتو من روی xorg تنظیم کردم روی انویدیا بزنم سیستم دیگه بالا نمیاد همیشه هم مال من روی Ubuntu‌ معمولی بود.قج
البته من نسخه 20.04 LTS Focal Fossa نصب بود به جای Ubuntu on xorg نوشته بود Ubuntu on wayland.
چون اون وقت درایور انویدیا رو نصب نکرده بودی وقتی روی انویدیا تنظیم می کنی باید به اینترنت هم متصل باشی تا اون رو بارگیری کنه بعد باید سیستم رو دوباره راه اندازی کنی
« آخرین ویرایش: 12 آبان 1400، 05:16 ب‌ظ توسط Aminavy »

آفلاین Mt

  • Hero Member
  • *
  • ارسال: 704
  • Manjaro + Xfce
پاسخ : نویز صدا
« پاسخ #9 : 12 آبان 1400، 05:39 ب‌ظ »
تو تنظیمات درایور های اوبونتو من روی xorg تنظیم کردم روی انویدیا بزنم سیستم دیگه بالا نمیاد همیشه هم مال من روی Ubuntu‌ معمولی بود.قج
البته من نسخه 20.04 LTS Focal Fossa نصب بود به جای Ubuntu on xorg نوشته بود Ubuntu on wayland.
چون اون وقت درایور انویدیا رو نصب نکرده بودی وقتی روی انویدیا تنظیم می کنی باید به اینترنت هم متصل باشی تا اون رو بارگیری کنه بعد باید سیستم رو دوباره راه اندازی کنی

به اینترنت متصل بودم اگر نبودم حتی لیست درایور هارو هم نشون نمی داد!

جالبه جلوی درایور انویدیا نوشته Tested پس اگر تست شده چرا نمیاره.

من ۲ بار انویدیا رو نصب کردم سیستم دیگه بالا نیومد با CTRL+AlT+F4 رفتم تو خط فرمان لاگین کردم دستور
sudo apt purge nvidia* --autoremove
رو زدم انویدیا پاک شد بعد سیستم بالا اومد

آفلاین Dragon-

  • High Hero Member
  • *
  • ارسال: 2563
  • جنسیت : پسر
پاسخ : نویز صدا
« پاسخ #10 : 12 آبان 1400، 06:39 ب‌ظ »
سلام ببخشید من چند هفته ای بیشتر نیست اوبونتو نصب کردم میشه بیشتر توضیح بدید. البته من پکیج pulseaudio رو نصب کردم.

مال من ۲ تا گزینه بیشتر نداره
Ubuntu

Ubuntu on xorg

چه فرقی دارن در ظاهر که یکی بودن.
ظاهرشون که باید یکی باشه.
ubuntu خالی، از wayland استفاده می‌کنه. چون wayland از x11 یا همون xorg جدیدتره، خیلی از برنامه‌ها درست روی اون کار نمی‌کنند و ممکنه مشکلاتی داشته باشن.
ubuntu on xorg، از xorg استفاده می‌کنه. برنامه‌ها روی xorg درست کار می‌کنند چون خیلی وقته که هست. ببینید توی xorg هم صدا همینجوریه یا نه. (البته فکر نکنم فرقی کنه)
گرافیک شما یکم قدیمیه. همون درایور‌های nouveau بهتر برای اون جواب میدن.

می‌دونید مدل کارت صدا چیه؟ یا اینکه از کارت صدا داخل مادربورد استفاده میشه.
خروجی دستورات زیر رو بذارید
lspci | grep -i audio
ls /proc/asound/card*
میدونید که زکات علم نشر آن است

آفلاین mobin1387

  • Sr. Member
  • *
  • ارسال: 360
  • جنسیت : پسر
  • I like void Linux
    • وب سایت شخصی خودم (نگرد توش هیچی نیست)
پاسخ : نویز صدا (مشکل حل نشده)
« پاسخ #11 : 12 آبان 1400، 08:08 ب‌ظ »
سلام من اوبونتو نسخه ۲۱.۱۰ رو دارم اسپیکر من مثل زنبور ززز می کنه ولی وقتی صدایی پخش میشه از سیستم قطع میشه و بعد از چند ثانیه اگر چیزی پخش نشه همین اتفاق میوفته.
من بطور موقت یک روشی برای حل این مشکل پیدا کردم که فقط روی گنوم این روش برای من جواب میده: توی تنظیمات به بخش صدا که میری قطع میشه نویز من هر سری سیستم رو روشن می کنم تنظیمات رو باز می کنم بعد میرم تو بخش صدا و بعد مینیمایز می کنم راهی نیست که این نویز بصورت دائمی حل بشه توی ویندوز همچین مشکلی وجود نداشت.

درایور کارت گرافیک هم روی xorg هست درایور انحصاری انویدیا هم وجود داره ولی وقتی فعالش می کنم موقع بالا اومدن سیستم صفحه سیاه نشون میده و مجبورم از طریق ترمینال درایور رو پاک کنم.
ممنون میشم مدل کارت گرافیک تون رو به طور دقیق بگید (و همچنین کارت صدا)
و اینکه آیا از HDMI برای انتقال صدا استفاده میکنید یا نه؟

برای سوال اول خروجی دستور زیرو بزارید:
lspci -v | nc -N paste.ubuntu.ir 1337

کاری ندارم که سیستم عامل گنو درسته یا لینوکس یا گنو/لینوکس ولی خداوکیلی تمام مشکلات نرم افزار های آزاد الآن فقط اسم گذاریه؟ :/

آفلاین Mt

  • Hero Member
  • *
  • ارسال: 704
  • Manjaro + Xfce
پاسخ : نویز صدا (مشکل حل نشده)
« پاسخ #12 : 13 آبان 1400، 01:06 ق‌ظ »
سلام من اوبونتو نسخه ۲۱.۱۰ رو دارم اسپیکر من مثل زنبور ززز می کنه ولی وقتی صدایی پخش میشه از سیستم قطع میشه و بعد از چند ثانیه اگر چیزی پخش نشه همین اتفاق میوفته.
من بطور موقت یک روشی برای حل این مشکل پیدا کردم که فقط روی گنوم این روش برای من جواب میده: توی تنظیمات به بخش صدا که میری قطع میشه نویز من هر سری سیستم رو روشن می کنم تنظیمات رو باز می کنم بعد میرم تو بخش صدا و بعد مینیمایز می کنم راهی نیست که این نویز بصورت دائمی حل بشه توی ویندوز همچین مشکلی وجود نداشت.

درایور کارت گرافیک هم روی xorg هست درایور انحصاری انویدیا هم وجود داره ولی وقتی فعالش می کنم موقع بالا اومدن سیستم صفحه سیاه نشون میده و مجبورم از طریق ترمینال درایور رو پاک کنم.
ممنون میشم مدل کارت گرافیک تون رو به طور دقیق بگید (و همچنین کارت صدا)
و اینکه آیا از HDMI برای انتقال صدا استفاده میکنید یا نه؟

برای سوال اول خروجی دستور زیرو بزارید:
lspci -v | nc -N paste.ubuntu.ir 1337

کارت گرافیک مدلش همینه.
منظورتون از مدل کارت صدا چیه؟
اسپیکر بنده مال سال ۲۰۰۰ هست یک سیم قرمز رنگی هست که به سوکت زرد رنگی پشت کیس می خوره

از ویندوز ۷ به بعد من چنین مشکلی نداشتم و در ویندوز ایکس پی هم با نصب درایور ها این مشکل حل می شد
« آخرین ویرایش: 13 آبان 1400، 01:10 ق‌ظ توسط Mtsaghafi »

آفلاین Mt

  • Hero Member
  • *
  • ارسال: 704
  • Manjaro + Xfce
پاسخ : نویز صدا (مشکل حل نشده)
« پاسخ #13 : 13 آبان 1400، 01:08 ق‌ظ »
 چیزی مثل Realtek برای لینوکس وجود نداره؟

درایور nouveau چجوری نصب کنم؟
« آخرین ویرایش: 13 آبان 1400، 01:12 ق‌ظ توسط Mtsaghafi »

آفلاین Mt

  • Hero Member
  • *
  • ارسال: 704
  • Manjaro + Xfce
پاسخ : نویز صدا
« پاسخ #14 : 13 آبان 1400، 11:58 ق‌ظ »
lspci | grep -i audio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller (rev 01)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)

ls /proc/asound/card*

/proc/asound/cards

/proc/asound/card0:
codec#3  id  pcm0c  pcm0p  pcm1p  pcm2c

/proc/asound/card1:
codec#0  codec#2  eld#0.0  eld#2.0  id     pcm7p  pcm9p
codec#1  codec#3  eld#1.0  eld#3.0  pcm3p  pcm8p

lspci -v | nc -N paste.ubuntu.ir 1337

https://paste.ubuntu.ir/qmwi