انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

لطفاً هر چه زودتر، اوبونتوی خود را به نگارش ۲۱٫۱۰ ارتقا دهید

نویسنده موضوع: Text Editor سبک و مناسب برای لینوکس  (دفعات بازدید: 1316 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین هومان

  • High Hero Member
  • *
  • ارسال: 1475
  • جنسیت : پسر
  • آرچ + گنوم
پاسخ : Text Editor سبک و مناسب برای لینوکس
« پاسخ #30 : 30 آبان 1400، 10:33 ب‌ظ »
هرچیزی جز ای‌مکس جلوی ویم و امکاناتش، یه اسباب‌بازی درجه پنج چینیه!
+++
Kakoune هم خیلی جالبه ولی خیلی شبیه ویمه

آفلاین .MTSaghafi

  • Sr. Member
  • *
  • ارسال: 373
  • کاربر دبیان
پاسخ : Text Editor سبک و مناسب برای لینوکس
« پاسخ #31 : 01 آذر 1400، 01:26 ب‌ظ »
ویم !!!!!!
تمام اگه میخوای یک ادیتور کامل تیدیلش کنی بگو تا تنظیمات مال خودم رو بدم تا حال کنی

سلام. برای طراحی سایت شما تنظیمات دارید؟ html css js jquery bootstrap
اگه دارید ممنون میشم بدید.
من که دوره آقای امیرصمیمی رو دیدم ولی ویم خیلی سخته
امام حسین (ع): «اگر دین ندارید لااقل آزاده باشید!»

آفلاین هومان

  • High Hero Member
  • *
  • ارسال: 1475
  • جنسیت : پسر
  • آرچ + گنوم
پاسخ : Text Editor سبک و مناسب برای لینوکس
« پاسخ #32 : 01 آذر 1400، 03:47 ب‌ظ »
تنظیمات خودش بساز که مناسب نیاز های خودت باشه مال بقیه بدردت نمیخوره

آفلاین .MTSaghafi

  • Sr. Member
  • *
  • ارسال: 373
  • کاربر دبیان
پاسخ : Text Editor سبک و مناسب برای لینوکس
« پاسخ #33 : 01 آذر 1400، 03:53 ب‌ظ »
ویم !!!!!!
تمام اگه میخوای یک ادیتور کامل تیدیلش کنی بگو تا تنظیمات مال خودم رو بدم تا حال کنی

سلام. برای طراحی سایت شما تنظیمات دارید؟ html css js jquery bootstrap
اگه دارید ممنون میشم بدید.
من که دوره آقای امیرصمیمی رو دیدم ولی ویم خیلی سخته

تنظیمات خودش بساز که مناسب نیاز های خودت باشه مال بقیه بدردت نمیخوره

خودم حوصله ور رفتن با کانفیگ هارو ندارم زمان یادگیری ادیتور ندارم بخاطر همین می خوام کانفیگ یک نفر برای طراحی سایت رو بگیرم کار خودم رو شروع کنم.
امام حسین (ع): «اگر دین ندارید لااقل آزاده باشید!»

آفلاین هومان

  • High Hero Member
  • *
  • ارسال: 1475
  • جنسیت : پسر
  • آرچ + گنوم

آفلاین sajadspeed

  • Jr. Member
  • *
  • ارسال: 79
  • جنسیت : پسر
پاسخ : Text Editor سبک و مناسب برای لینوکس
« پاسخ #35 : 01 آذر 1400، 04:38 ب‌ظ »
https://github.com/NvChad/NvChad
سلام ببخشید این الان کانفیگ nvim هست؟ یعنی میتونم پلاگین های vim را روش نصب کنم؟

آفلاین .MTSaghafi

  • Sr. Member
  • *
  • ارسال: 373
  • کاربر دبیان
امام حسین (ع): «اگر دین ندارید لااقل آزاده باشید!»

آفلاین هومان

  • High Hero Member
  • *
  • ارسال: 1475
  • جنسیت : پسر
  • آرچ + گنوم
پاسخ : Text Editor سبک و مناسب برای لینوکس
« پاسخ #37 : 01 آذر 1400، 08:18 ب‌ظ »
https://github.com/NvChad/NvChad
سلام ببخشید این الان کانفیگ nvim هست؟ یعنی میتونم پلاگین های vim را روش نصب کنم؟

نئوویم چون همون ویمه با قابلیت بیشتر از همه ی چیزای ویم ساپورت میکنه

https://github.com/NvChad/NvChad

این چیه؟
کانفیگ ویم

آفلاین .MTSaghafi

  • Sr. Member
  • *
  • ارسال: 373
  • کاربر دبیان
پاسخ : Text Editor سبک و مناسب برای لینوکس
« پاسخ #38 : 01 آذر 1400، 09:21 ب‌ظ »
https://github.com/NvChad/NvChad
سلام ببخشید این الان کانفیگ nvim هست؟ یعنی میتونم پلاگین های vim را روش نصب کنم؟

نئوویم چون همون ویمه با قابلیت بیشتر از همه ی چیزای ویم ساپورت میکنه

https://github.com/NvChad/NvChad

این چیه؟
کانفیگ ویم

چجوری فعال میشه؟
برای طراحی جواب میده؟
امام حسین (ع): «اگر دین ندارید لااقل آزاده باشید!»

آفلاین Dragon-

  • High Hero Member
  • *
  • ارسال: 2184
  • جنسیت : پسر
پاسخ : Text Editor سبک و مناسب برای لینوکس
« پاسخ #39 : 01 آذر 1400، 10:36 ب‌ظ »
سلام ببخشید این الان کانفیگ nvim هست؟ یعنی میتونم پلاگین های vim را روش نصب کنم؟
می‌تونید چیز‌های ویم رو روی این نصب کنید. اما نمی‌تونید nvchad رو روی ویم نصب کنید چون با lua نوشته شده و lua توی نئویم0.5.1 با بالا پشتیبانی میشه. نمی‌تونید تنظیمات ویم رو با lua بنویسید.

چجوری فعال میشه؟
برای طراحی جواب میده؟
ببینید ویم اینجوری نیست که نصب کنید و همه چی آماده باشه، خودتون باید برای کاری که می‌خواهید، تنظیمش کنید. می‌تونید spacevim یا nvcahd رو نصب کنید (در اصل تنظیم ویم هستند) که خیلی از کار‌ها رو کردند و شما لازمه چیز‌های کوچیک رو تغییر بدید تا چیزی بشه که شما می‌خواهید.
برای نصب اونها، معمولا یه راهنما توی صفحه پروژه وجود داره که چیکار کنید.

برای نصب nvchad باید نئوویم 0.5.1 یا به بالا داشته باشید. با این دستور ببینید نسخه نئوویم چنده.
nvim --version
میدونید که زکات علم نشر آن است