انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۰٫۱۰ منتشر شد.
انتظار می‌ره همهٔ اعضا هرچه زودتر به این نگارش ارتقا پیدا کنند. همهٔ پاسخ‌ها از این به بعد، بر پایهٔ اوبونتو ۲۰٫۱۰ خواهد بود.

نویسنده موضوع: unable بودن کتابخانه نصب شده در پایتون (حل شد)  (دفعات بازدید: 445 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین Reza Hosseinzadeh

  • Jr. Member
  • *
  • ارسال: 41
  • کنجکاو
چند روزی هست که وقتی کتابخانه ای رو نصب می کنم، پیام موفقیت نمایش داده می شه و کتابخانه نصب می شه. ولی وقتی می خوام استفاده کنم ارور میده و میگه این کتابخونه پیدا نشد:
Traceback (most recent call last):
  File "/home/ubuntu/Dropbox/Python/All_Python/x.py", line 1, in <module>
    import pyttsx3
ModuleNotFoundError: No module named 'pyttsx3'
کتابخونه ها در دستگاه من در .local/lib/python3.8/site-packages ذخیره شدن و کتابخونه هایی رو که دانلود می کنم به این دایرکتوی میرن ولی قابل نیستن.
مشکل رو پیدا کردم: پایتون رو به ۳.۹ ارتقا دادم ولی pip کتابخونه ها رو در محل قبلی (۳.۸) ذخیره می کنه. چطور باید محل ذخیره رو تغییر بدم؟
« آخرین ویرایش: 22 دی 1399، 08:07 ب‌ظ توسط Reza Hosseinzadeh »
جست و جو کنید و چیز های جدید بیابید

آفلاین مرتضی . م

  • Sr. Member
  • *
  • ارسال: 479
پاسخ : unable بودن کتابخانه نصب شده در پایتون
« پاسخ #1 : 16 دی 1399، 12:29 ب‌ظ »
با pip نصب میکنی؟
اگه آره خروجی این دستور
pip freeze

آفلاین Reza Hosseinzadeh

  • Jr. Member
  • *
  • ارسال: 41
  • کنجکاو
پاسخ : unable بودن کتابخانه نصب شده در پایتون
« پاسخ #2 : 16 دی 1399، 12:47 ب‌ظ »
با pip نصب میکنی؟
اگه آره خروجی این دستور
pip freeze
بله با pip کار می کنم. مشکل رو پیدا کردم. پایتون رو به ۳.۹ ارتقا دادم ولی pip کتابخونه ها رو در محل قبلی (۳.۸) ذخیره می کنه. محل نصب پکیج ها رو عوض کردم هنگام نصب این پیام رو میده (خط اول) و باز هم در دایرکتوری مخصوص ۳.۸ نصب می کنه:
Defaulting to user installation because normal site-packages is not writeable
Collecting pyttsx3
  Using cached pyttsx3-2.90-py3-none-any.whl (39 kB)
Installing collected packages: pyttsx3
Successfully installed pyttsx3-2.90
« آخرین ویرایش: 16 دی 1399، 08:02 ب‌ظ توسط Reza Hosseinzadeh »
جست و جو کنید و چیز های جدید بیابید

آفلاین مرتضی . م

  • Sr. Member
  • *
  • ارسال: 479

آفلاین nixoeen

  • ناظر انجمن
  • *
  • ارسال: 4209
  • جنسیت : پسر
  • masoft قدیم
پاسخ : unable بودن کتابخانه نصب شده در پایتون
« پاسخ #4 : 16 دی 1399، 03:11 ب‌ظ »
بهترین کار اینه که کتابخونه‌ها رو تا جای ممکن از مخازن توزیع نصب کنید. اینطوری نسخه‌ای از پایتون هم که استفاده میشه ثابت می‌مونه و این مشکلات هم نخواهید داشت.

آفلاین Reza Hosseinzadeh

  • Jr. Member
  • *
  • ارسال: 41
  • کنجکاو
پاسخ : unable بودن کتابخانه نصب شده در پایتون
« پاسخ #5 : 16 دی 1399، 07:56 ب‌ظ »
بهترین کار اینه که کتابخونه‌ها رو تا جای ممکن از مخازن توزیع نصب کنید.
روش این کار چیه؟ با چه دستوری باید این کار رو بکنم؟
جست و جو کنید و چیز های جدید بیابید

آفلاین M!lad

  • عضو کاربران ایرانی اوبونتو
  • *
  • ارسال: 1529
پاسخ : unable بودن کتابخانه نصب شده در پایتون
« پاسخ #6 : 16 دی 1399، 11:25 ب‌ظ »
پیشنهاد من این هست که pip رو نصب و بعد به روز کنید. به وسیله اون virtualenv یا گزینه‌ای دیگه‌ای مثل pipenv نصب کنید. و بسته‌ها رو به شکل ایزوله شده نصب کنید.
..I feel no fault for the fault I feel..

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 13587
  • جنسیت : پسر
  • Urahara Kiesuke
    • وبلاگ
پاسخ : unable بودن کتابخانه نصب شده در پایتون
« پاسخ #7 : 19 دی 1399، 01:28 ق‌ظ »
خب نیابد این‌جوری از pip استفاده کرد! اگه قراره برنامه رو روی سیستم اجرا کنید، باید پیش‌نیازهای ویندوزیش رو هم از مخازن خود توزیع نصب کنید و نه از pip. pip فقط برای استفاده داخل محیط‌های مجازیه.
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن

آفلاین nixoeen

  • ناظر انجمن
  • *
  • ارسال: 4209
  • جنسیت : پسر
  • masoft قدیم
پاسخ : unable بودن کتابخانه نصب شده در پایتون
« پاسخ #8 : 19 دی 1399، 07:26 ق‌ظ »
روش این کار چیه؟ با چه دستوری باید این کار رو بکنم؟
با دستور apt می‌تونید این کار رو انجام بدید.

آفلاین Reza Hosseinzadeh

  • Jr. Member
  • *
  • ارسال: 41
  • کنجکاو
پاسخ : unable بودن کتابخانه نصب شده در پایتون
« پاسخ #9 : 19 دی 1399، 07:36 ب‌ظ »
روش این کار چیه؟ با چه دستوری باید این کار رو بکنم؟
با دستور apt می‌تونید این کار رو انجام بدید.
میشه یه مثال کامل تر بزنید؟
جست و جو کنید و چیز های جدید بیابید

آفلاین Reza Hosseinzadeh

  • Jr. Member
  • *
  • ارسال: 41
  • کنجکاو
پاسخ : unable بودن کتابخانه نصب شده در پایتون
« پاسخ #10 : 19 دی 1399، 07:37 ب‌ظ »
خب نیابد این‌جوری از pip استفاده کرد! اگه قراره برنامه رو روی سیستم اجرا کنید، باید پیش‌نیازهای ویندوزیش رو هم از مخازن خود توزیع نصب کنید و نه از pip. pip فقط برای استفاده داخل محیط‌های مجازیه.
همیشه تا بحال از pip استفاده می کردم. منظور شما اینه که از apt استفاده کنم؟
جست و جو کنید و چیز های جدید بیابید

آفلاین nixoeen

  • ناظر انجمن
  • *
  • ارسال: 4209
  • جنسیت : پسر
  • masoft قدیم
پاسخ : unable بودن کتابخانه نصب شده در پایتون
« پاسخ #11 : 19 دی 1399، 07:38 ب‌ظ »
میشه یه مثال کامل تر بزنید؟
برای مثال با دستور sudo apt install python3-pycurl می‌تونید PycURL رو نصب کنید.

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 13587
  • جنسیت : پسر
  • Urahara Kiesuke
    • وبلاگ
همیشه تا بحال از pip استفاده می کردم. منظور شما اینه که از apt استفاده کنم؟
خارج از محیط مجاری، قطعاً! استفاده از پیپ به صورت مستقیم روی سامانهٔ اصلی، می‌تونه صدمات جبران‌ناپذیری وارد کنه.
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن

آفلاین Reza Hosseinzadeh

  • Jr. Member
  • *
  • ارسال: 41
  • کنجکاو
همیشه تا بحال از pip استفاده می کردم. منظور شما اینه که از apt استفاده کنم؟
خارج از محیط مجاری، قطعاً! استفاده از پیپ به صورت مستقیم روی سامانهٔ اصلی، می‌تونه صدمات جبران‌ناپذیری وارد کنه.
نمی دونستم. مثلا چه مشکلاتی به بار میاره؟
جست و جو کنید و چیز های جدید بیابید

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 13587
  • جنسیت : پسر
  • Urahara Kiesuke
    • وبلاگ
تداخل پایگاه دادهٔ پرونده‌های سیستم‌عامل که apt نگهشون می‌داره۷ با چیزهایی که pip نصب کرده که ممکنه کار apt رو مختل کنه.
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن