انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۰٫۱۰ منتشر شد.
انتظار می‌ره همهٔ اعضا هرچه زودتر به این نگارش ارتقا پیدا کنند. همهٔ پاسخ‌ها از این به بعد، بر پایهٔ اوبونتو ۲۰٫۱۰ خواهد بود.

نویسنده موضوع: مشکل با gns3 هنگام اجرا به صورت روت  (دفعات بازدید: 207 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین SpyaM

  • Full Member
  • *
  • ارسال: 121
  • جنسیت : پسر
  • L!nux
مشکل با gns3 هنگام اجرا به صورت روت
« : 19 خرداد 1399، 01:58 ب‌ظ »
سلام
خسته نباشید
با تشکر از دوست خوبمون که دیشب کمک کردن و در مانجارو نصب کردم
ولی من برای اینکه بتونم روتر باز کنم و ران کنم یا .. باید اونو به صورت sudo gns3 بالا بیارم
در حالت عادی هیچ ارور و مشکلی نداره ..
ولی وقتی با دستور روت باز میکنم این ارور ها هست
=> Running GNS3 as root is not recommended and could be dangerous
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Cannot connect to http://localhost:3080. Please check if GNS3 is allowed in your antivirus and firewall. And that server version is 2.2.9.
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Cannot load the GNS3 VM settings in the preferences dialog: not connected to the controller
Cannot load the IOU license in the preferences dialog: not connected to the controller
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Cannot connect to http://127.0.0.1:3080. Please check if GNS3 is allowed in your antivirus and firewall. And that server version is 2.2.9.
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Cannot connect to http://127.0.0.1:3080. Please check if GNS3 is allowed in your antivirus and firewall. And that server version is 2.2.9.
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
لطفا کمک کنید چون این ابزار اصلی منه اینو حل کنم ..
البته من فایروال رو یکبار فعال کردم قبلا ولی اینو دیدم غیرفعال کردم باز درست نشد
بَرای مُوفقیت رویا پَردازی نکنیم ، #تلاش کُنیم

آفلاین SpyaM

  • Full Member
  • *
  • ارسال: 121
  • جنسیت : پسر
  • L!nux
پاسخ : مشکل با gns3 هنگام اجرا به صورت روت
« پاسخ #1 : 19 خرداد 1399، 02:25 ب‌ظ »
سلام
خسته نباشید
با تشکر از دوست خوبمون که دیشب کمک کردن و در مانجارو نصب کردم
ولی من برای اینکه بتونم روتر باز کنم و ران کنم یا .. باید اونو به صورت sudo gns3 بالا بیارم
در حالت عادی هیچ ارور و مشکلی نداره ..
ولی وقتی با دستور روت باز میکنم این ارور ها هست
=> Running GNS3 as root is not recommended and could be dangerous
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Cannot connect to http://localhost:3080. Please check if GNS3 is allowed in your antivirus and firewall. And that server version is 2.2.9.
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Cannot load the GNS3 VM settings in the preferences dialog: not connected to the controller
Cannot load the IOU license in the preferences dialog: not connected to the controller
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Cannot connect to http://127.0.0.1:3080. Please check if GNS3 is allowed in your antivirus and firewall. And that server version is 2.2.9.
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Cannot connect to http://127.0.0.1:3080. Please check if GNS3 is allowed in your antivirus and firewall. And that server version is 2.2.9.
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
لطفا کمک کنید چون این ابزار اصلی منه اینو حل کنم ..
البته من فایروال رو یکبار فعال کردم قبلا ولی اینو دیدم غیرفعال کردم باز درست نشد
حل کردم دوستان هر کی این مشکل رو داشت
وارد تنظیمات برنامه بشه و پورت gns3 server رو عوض کنه
البته فعلا مشکل دیگ هم داره باید بررسی کنم نشد اینجا میپرسم
بَرای مُوفقیت رویا پَردازی نکنیم ، #تلاش کُنیم

آفلاین mrostd

  • Sr. Member
  • *
  • ارسال: 408
  • جنسیت : پسر
  • کاربر openSUSE
    • وبسایت پرسش و پاسخ پرشکا
پاسخ : مشکل با gns3 هنگام اجرا به صورت روت
« پاسخ #2 : 19 خرداد 1399، 02:32 ب‌ظ »
سلام
خسته نباشید
با تشکر از دوست خوبمون که دیشب کمک کردن و در مانجارو نصب کردم
ولی من برای اینکه بتونم روتر باز کنم و ران کنم یا .. باید اونو به صورت sudo gns3 بالا بیارم
در حالت عادی هیچ ارور و مشکلی نداره ..
ولی وقتی با دستور روت باز میکنم این ارور ها هست
=> Running GNS3 as root is not recommended and could be dangerous
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Cannot connect to http://localhost:3080. Please check if GNS3 is allowed in your antivirus and firewall. And that server version is 2.2.9.
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Cannot load the GNS3 VM settings in the preferences dialog: not connected to the controller
Cannot load the IOU license in the preferences dialog: not connected to the controller
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (localhost:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Cannot connect to http://127.0.0.1:3080. Please check if GNS3 is allowed in your antivirus and firewall. And that server version is 2.2.9.
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Cannot connect to http://127.0.0.1:3080. Please check if GNS3 is allowed in your antivirus and firewall. And that server version is 2.2.9.
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
Host requires authentication (127.0.0.1:3080)
لطفا کمک کنید چون این ابزار اصلی منه اینو حل کنم ..
البته من فایروال رو یکبار فعال کردم قبلا ولی اینو دیدم غیرفعال کردم باز درست نشد
هرگز نرم افزار های گرافیکی (دارای gui) رو با sudo اجرا نکن، همونطور که خط اول هم نوشته میتونه منجر به آسیب بشه.

آفلاین SpyaM

  • Full Member
  • *
  • ارسال: 121
  • جنسیت : پسر
  • L!nux
پاسخ : مشکل با gns3 هنگام اجرا به صورت روت
« پاسخ #3 : 19 خرداد 1399، 02:56 ب‌ظ »
متاسفانه یه مشکلو حل میکنم یه مشکل دیه میاد سراغم
اینبار برای اینکه پی سی بتونم بیارم رو نرم افزار باید اینو نصب کنم که نمیشه
[spyam@linux ~]$ yay -S vpcs --noconfirm
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur: 1]  vpcs-0.8-4

  1 vpcs                                     (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: PKGBUILD up to date, Skipping (1/1): vpcs
  1 vpcs                                     (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: Parsing SRCINFO (1/1): vpcs
==> Making package: vpcs 0.8-4 (Mon 08 Jun 2020 02:54:54 PM +0430)
==> Retrieving sources...
  -> Found v0.8beta1.tar.gz
==> Validating source files with md5sums...
    v0.8beta1.tar.gz ... Passed
==> Making package: vpcs 0.8-4 (Mon 08 Jun 2020 02:54:55 PM +0430)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found v0.8beta1.tar.gz
==> Validating source files with md5sums...
    v0.8beta1.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting v0.8beta1.tar.gz with bsdtar
==> Starting prepare()...
patching file src/getopt.h
/*****************************************************************************
* getopt.h - competent and free getopt library.
* $Header: /home/ubuntu/cvs/cvsroot/vpcs/getopt.h,v 1.1 2007-06-12 13:17:40 admin Exp $
*
* Copyright (c)2002-2003 Mark K. Kim
* All rights reserved.
*
* Redistribution and use in source and binary forms, with or without
* modification, are permitted provided that the following conditions
* are met:
*
*   * Redistributions of source code must retain the above copyright
*     notice, this list of conditions and the following disclaimer.
*
*   * Redistributions in binary form must reproduce the above copyright
*     notice, this list of conditions and the following disclaimer in
*     the documentation and/or other materials provided with the
*     distribution.
*
*   * Neither the original author of this software nor the names of its
*     contributors may be used to endorse or promote products derived
*     from this software without specific prior written permission.
*
* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
* OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
* AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
* OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF
* THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
* DAMAGE.
*/

#ifndef _GETOPT_H_
#define _GETOPT_H_


#ifdef __cplusplus
extern "C" {
#endif


extern char* optarg;
extern int optind;
extern int opterr;
extern int optopt;

#ifndef FreeBSD
int getopt(int argc, char *const *argv, const char *optstr);
#endif
int arg_to_int(const char* arg, int min, int max, int defalt);

#ifdef __cplusplus
}
#endif


#endif /* GETOPT_H_ */


/* vim:ts=3
*/
==> Sources are ready.
==> Making package: vpcs 0.8-4 (Mon 08 Jun 2020 02:54:58 PM +0430)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Removing existing $pkgdir/ directory...
==> Starting build()...
Makefile.linux:38: warning: ignoring prerequisites on suffix rule definition
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c vpcs.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c daemon.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c readline.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c packets.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c utils.c
utils.c: In function ‘getkv’:
utils.c:45:3: warning: ‘strncpy’ output truncated before terminating nul copying as many bytes from a string as its length [-Wstringop-truncation]
   45 |   strncpy(buf, str, strlen(str));
      |   ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c queue.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c command.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c dev.c
dev.c: In function ‘open_tap’:
dev.c:173:2: warning: this ‘else’ clause does not guard... [-Wmisleading-indentation]
  173 |  else
      |  ^~~~
dev.c:176:3: note: ...this statement, but the latter is misleadingly indented as if it were guarded by the ‘else’
  176 |   sprintf(dev, "%s", tapname);
      |   ^~~~~~~
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c dhcp.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c command6.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c packets6.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c ip.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c tcp.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c inet6.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c dns.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c remote.c
dns.c: In function ‘hostresolv’:
dns.c:54:8: warning: variable ‘pdn’ set but not used [-Wunused-but-set-variable]
   54 |  char *pdn = NULL;
      |        ^~~
dns.c: In function ‘appenddomain’:
dns.c:141:25: warning: argument to ‘sizeof’ in ‘snprintf’ call is the same expression as the destination; did you mean to provide an explicit length? [-Wsizeof-pointer-memaccess]
  141 |   snprintf(dname, sizeof(dname), "%s", name);
      |                         ^
dns.c:145:24: warning: argument to ‘sizeof’ in ‘snprintf’ call is the same expression as the destination; did you mean to provide an explicit length? [-Wsizeof-pointer-memaccess]
  145 |  snprintf(dname, sizeof(dname), "%s.%s", name, dn);
      |                        ^
dns.c: In function ‘dns4’:
dns.c:151:17: warning: variable ‘in’ set but not used [-Wunused-but-set-variable]
  151 |  struct in_addr in;
      |                 ^~
dns.c: In function ‘hostresolv’:
dns.c:145:37: warning: ‘%s’ directive output may be truncated writing up to 63 bytes into a region of size 7 [-Wformat-truncation=]
  145 |  snprintf(dname, sizeof(dname), "%s.%s", name, dn);
      |                                     ^~
dns.c:145:2: note: ‘snprintf’ output 2 or more bytes (assuming 65) into a destination of size 8
  145 |  snprintf(dname, sizeof(dname), "%s.%s", name, dn);
      |  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
dns.c:159:16: warning: ‘cb.dip’ may be used uninitialized in this function [-Wmaybe-uninitialized]
  159 |  if (sameNet(cb.dip, pc->ip4.ip, pc->ip4.cidr))
      |              ~~^~~~
command6.c: In function ‘ip6Info’:
command6.c:898:20: warning: ‘%s’ directive writing up to 46 bytes into a region of size 44 [-Wformat-overflow=]
  898 |   sprintf(buf, "ip %s/%d", tmp, vpc[id].ip6.cidr);
      |                    ^~      ~~~
command6.c:898:3: note: ‘sprintf’ output between 6 and 62 bytes into a destination of size 47
  898 |   sprintf(buf, "ip %s/%d", tmp, vpc[id].ip6.cidr);
      |   ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c help.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c dump.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c relay.c
relay.c: In function ‘run_relay’:
relay.c:92:3: warning: this ‘if’ clause does not guard... [-Wmisleading-indentation]
   92 |   if (port > 1024 && port < 65534)
      |   ^~
relay.c:94:4: note: ...this statement, but the latter is misleadingly indented as if it were guarded by the ‘if’
   94 |    if (relay_fd) {
      |    ^~
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c hv.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c frag.c
gcc -O2 -m64  -DLinux -Di386 -DHV -Wall -I. -DTAP -c frag6.c
gcc -O2 -m64 vpcs.o daemon.o readline.o packets.o utils.o queue.o command.o dev.o dhcp.o command6.o packets6.o ip.o tcp.o inet6.o dns.o remote.o help.o dump.o relay.o hv.o frag.o frag6.o -o vpcs -lpthread -lutil -s -static
/usr/bin/ld: packets.o:(.bss+0x0): multiple definition of `vpc'; vpcs.o:(.bss+0x60): first defined here
/usr/bin/ld: command.o:(.bss+0x0): multiple definition of `vpc'; vpcs.o:(.bss+0x60): first defined here
/usr/bin/ld: dev.o:(.bss+0x0): multiple definition of `vpc'; vpcs.o:(.bss+0x60): first defined here
/usr/bin/ld: dhcp.o:(.bss+0x0): multiple definition of `vpc'; vpcs.o:(.bss+0x60): first defined here
/usr/bin/ld: command6.o:(.bss+0x0): multiple definition of `vpc'; vpcs.o:(.bss+0x60): first defined here
/usr/bin/ld: packets6.o:(.bss+0x0): multiple definition of `vpc'; vpcs.o:(.bss+0x60): first defined here
/usr/bin/ld: tcp.o:(.bss+0x0): multiple definition of `vpc'; vpcs.o:(.bss+0x60): first defined here
/usr/bin/ld: dns.o:(.bss+0x0): multiple definition of `vpc'; vpcs.o:(.bss+0x60): first defined here
/usr/bin/ld: dump.o:(.bss+0x0): multiple definition of `vpc'; vpcs.o:(.bss+0x60): first defined here
/usr/bin/ld: relay.o:(.bss+0x0): multiple definition of `vpc'; vpcs.o:(.bss+0x60): first defined here
/usr/bin/ld: frag6.o:(.bss+0x0): multiple definition of `vpc'; vpcs.o:(.bss+0x60): first defined here
collect2: error: ld returned 1 exit status
make: *** [Makefile.linux:35: vpcs] Error 1
==> ERROR: A failure occurred in build().
    Aborting...
Error making: vpcs
[spyam@linux ~]$
متاسفانه iou هم برای سوپیچ های من نصب نمیشه :
[spyam@linux ~]$ yay -S iouyap --noconfirm
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur: 1]  iouyap-0.97-2

:: Downloaded PKGBUILD (1/1): iouyap
  1 iouyap                                   (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: Parsing SRCINFO (1/1): iouyap
==> Making package: iouyap 0.97-2 (Mon 08 Jun 2020 02:57:51 PM +0430)
==> Retrieving sources...
  -> Downloading iouyap-0.97.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   118  100   118    0     0    140      0 --:--:-- --:--:-- --:--:--   139
100 75392    0 75392    0     0  29473      0 --:--:--  0:00:02 --:--:-- 68851
==> Validating source files with md5sums...
    iouyap-0.97.tar.gz ... Passed
==> Making package: iouyap 0.97-2 (Mon 08 Jun 2020 02:57:55 PM +0430)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found iouyap-0.97.tar.gz
==> Validating source files with md5sums...
    iouyap-0.97.tar.gz ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting iouyap-0.97.tar.gz with bsdtar
==> Sources are ready.
==> Making package: iouyap 0.97-2 (Mon 08 Jun 2020 02:57:58 PM +0430)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Starting build()...
gcc  -Wall -D_FORTIFY_SOURCE=2  -c -o iouyap.o iouyap.c
bison -y -d netmap_parse.y
In file included from /usr/include/bits/libc-header-start.h:33,
                 from /usr/include/stdio.h:27,
                 from iouyap.c:21:
/usr/include/features.h:397:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
  397 | #  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
      |    ^~~~~~~
gcc  -Wall -D_FORTIFY_SOURCE=2  -c -o netmap.o netmap.c
gcc  -Wall -D_FORTIFY_SOURCE=2  -c -o config.o config.c
flex  -t netmap_scan.l > netmap_scan.c
In file included from /usr/include/bits/libc-header-start.h:33,
                 from /usr/include/stdlib.h:25,
                 from netmap.c:26:
/usr/include/features.h:397:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
  397 | #  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
      |    ^~~~~~~
In file included from /usr/include/bits/libc-header-start.h:33,
                 from /usr/include/stdio.h:27,
                 from iniparser/iniparser.h:17,
                 from config.c:21:
/usr/include/features.h:397:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
  397 | #  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
      |    ^~~~~~~
gcc  -Wall -D_FORTIFY_SOURCE=2  -c -o iniparser/iniparser.o iniparser/iniparser.c
gcc  -Wall -D_FORTIFY_SOURCE=2  -c -o iniparser/dictionary.o iniparser/dictionary.c
In file included from /usr/include/ctype.h:25,
                 from iniparser/iniparser.c:10:
/usr/include/features.h:397:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
  397 | #  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
      |    ^~~~~~~
In file included from /usr/include/bits/libc-header-start.h:33,
                 from /usr/include/stdio.h:27,
                 from iniparser/dictionary.h:21,
                 from iniparser/dictionary.c:16:
/usr/include/features.h:397:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
  397 | #  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
      |    ^~~~~~~
gcc  -Wall -D_FORTIFY_SOURCE=2  -c -o netmap_scan.o netmap_scan.c
In file included from /usr/include/bits/libc-header-start.h:33,
                 from /usr/include/stdio.h:27,
                 from <stdout>:18:
/usr/include/features.h:397:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
  397 | #  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
      |    ^~~~~~~
netmap_parse.y:68.1-11: warning: POSIX Yacc does not support %destructor [-Wyacc]
   68 | %destructor { free($$); } <sval>
      | ^~~~~~~~~~~
mv -f y.tab.c netmap_parse.c
gcc  -Wall -D_FORTIFY_SOURCE=2  -c -o netmap_parse.o netmap_parse.c
In file included from /usr/include/bits/libc-header-start.h:33,
                 from /usr/include/stdlib.h:25,
                 from netmap_parse.y:22:
/usr/include/features.h:397:4: warning: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Wcpp]
  397 | #  warning _FORTIFY_SOURCE requires compiling with optimization (-O)
      |    ^~~~~~~
gcc  -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now  iouyap.o netmap_parse.o netmap_scan.o netmap.o config.o iniparser/iniparser.o iniparser/dictionary.o  -lpthread -o iouyap
/usr/bin/ld: netmap_parse.o:(.bss+0x0): multiple definition of `sizecheck'; iouyap.o:(.bss+0x0): first defined here
/usr/bin/ld: netmap_scan.o:(.bss+0x40): multiple definition of `sizecheck'; iouyap.o:(.bss+0x0): first defined here
/usr/bin/ld: netmap.o:(.bss+0x0): multiple definition of `sizecheck'; iouyap.o:(.bss+0x0): first defined here
collect2: error: ld returned 1 exit status
make: *** [<builtin>: iouyap] Error 1
rm netmap_scan.c netmap_parse.c
==> ERROR: A failure occurred in build().
    Aborting...
Error making: iouyap
[spyam@linux ~]$

« آخرین ویرایش: 19 خرداد 1399، 02:58 ب‌ظ توسط SpyaM »
بَرای مُوفقیت رویا پَردازی نکنیم ، #تلاش کُنیم

آنلاین nixoeen

  • ناظر انجمن
  • *
  • ارسال: 4147
  • جنسیت : پسر
  • masoft قدیم
پاسخ : مشکل با gns3 هنگام اجرا به صورت روت
« پاسخ #4 : 19 خرداد 1399، 07:50 ب‌ظ »
باید اونو به صورت sudo gns3 بالا بیارم
خودش خط اول خروجی گفته که با root اجراش نکنید.