انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۰٫۱۰ منتشر شد.
انتظار می‌ره همهٔ اعضا هرچه زودتر به این نگارش ارتقا پیدا کنند. همهٔ پاسخ‌ها از این به بعد، بر پایهٔ اوبونتو ۲۰٫۱۰ خواهد بود.

نویسنده موضوع: مشکل در نصب yay (حل شد)  (دفعات بازدید: 353 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین AH999

  • Newbie
  • *
  • ارسال: 24
  • جنسیت : پسر
مشکل در نصب yay (حل شد)
« : 08 اسفند 1398، 05:22 ب‌ظ »
سلام به همگی دوستان
می خواستم یکسری پکیج ها رو از  aur آرچ دانلود و نصب کنم که نیاز به یک aur helper پیدا کردم و الان که طبق توضیحات توسعه دهندش میرم جلو ، باز به مشکل می خورم و نمیدونم مشکل از چی هستش * ممنون میشم راهنمایی کنید ...

ٰgit clone https://aur.archlinux.org/yay.git
cd yay
makepkg -si

وقتی آخرین دستور رو میزنم ،‌این ارور رو میده
==> ERROR: Cannot find the fakeroot binary.
==> ERROR: Cannot find the strip binary required for object file stripping.
« آخرین ویرایش: 09 اسفند 1398، 05:15 ب‌ظ توسط AHosseini »

آفلاین SLACKER

  • High Sr. Member
  • *
  • ارسال: 699
  • جنسیت : پسر
پاسخ : مشکل در نصب Yay
« پاسخ #1 : 08 اسفند 1398، 05:50 ب‌ظ »
سلام به همگی دوستان
می خواستم یکسری پکیج ها رو از  aur آرچ دانلود و نصب کنم که نیاز به یک aur helper پیدا کردم و الان که طبق توضیحات توسعه دهندش میرم جلو ، باز به مشکل می خورم و نمیدونم مشکل از چی هستش * ممنون میشم راهنمایی کنید ...

ٰgit clone https://aur.archlinux.org/yay.git
cd yay
makepkg -si

وقتی آخرین دستور رو میزنم ،‌این ارور رو میده
==> ERROR: Cannot find the fakeroot binary.
==> ERROR: Cannot find the strip binary required for object file stripping.
*
« آخرین ویرایش: 08 اسفند 1398، 06:16 ب‌ظ توسط SLACKER »
اسلکور به روزترین توزیع پایدار!
وقتی که شما اسلکور رو یاد میگیرد در حقیقت لینوکس رو یاد گرفتید نه توزیع رو!

آفلاین هومان

  • High Hero Member
  • *
  • ارسال: 1379
  • جنسیت : پسر
پاسخ : مشکل در نصب Yay
« پاسخ #2 : 08 اسفند 1398، 05:54 ب‌ظ »
yay تو مخازن مانجاروه نه مخازن ارچ

آفلاین SLACKER

  • High Sr. Member
  • *
  • ارسال: 699
  • جنسیت : پسر
پاسخ : مشکل در نصب Yay
« پاسخ #3 : 08 اسفند 1398، 06:07 ب‌ظ »
yay تو مخازن مانجاروه نه مخازن ارچ

نمیدونستم. این رو نصب کنه فکر کنم مشکلش حل میشه:

  sudo pacman -S base-devel
« آخرین ویرایش: 08 اسفند 1398، 06:15 ب‌ظ توسط SLACKER »
اسلکور به روزترین توزیع پایدار!
وقتی که شما اسلکور رو یاد میگیرد در حقیقت لینوکس رو یاد گرفتید نه توزیع رو!

آفلاین AH999

  • Newbie
  • *
  • ارسال: 24
  • جنسیت : پسر
پاسخ : مشکل در نصب Yay
« پاسخ #4 : 08 اسفند 1398، 06:29 ب‌ظ »

آفلاین AH999

  • Newbie
  • *
  • ارسال: 24
  • جنسیت : پسر
پاسخ : مشکل در نصب Yay
« پاسخ #5 : 08 اسفند 1398، 06:31 ب‌ظ »
yay تو مخازن مانجاروه نه مخازن ارچ

نمیدونستم. این رو نصب کنه فکر کنم مشکلش حل میشه:

  sudo pacman -S base-devel

نیستش داخل مخزن رسمی آرچ

آفلاین هومان

  • High Hero Member
  • *
  • ارسال: 1379
  • جنسیت : پسر

آفلاین Sun-PDA

  • Hero Member
  • *
  • ارسال: 841
پاسخ : مشکل در نصب Yay
« پاسخ #7 : 08 اسفند 1398، 07:23 ب‌ظ »
سلام به همگی دوستان
می خواستم یکسری پکیج ها رو از  aur آرچ دانلود و نصب کنم که نیاز به یک aur helper پیدا کردم و الان که طبق توضیحات توسعه دهندش میرم جلو ، باز به مشکل می خورم و نمیدونم مشکل از چی هستش * ممنون میشم راهنمایی کنید ...

ٰgit clone https://aur.archlinux.org/yay.git
cd yay
makepkg -si

وقتی آخرین دستور رو میزنم ،‌این ارور رو میده
==> ERROR: Cannot find the fakeroot binary.
==> ERROR: Cannot find the strip binary required for object file stripping.

همونطور که یکی از دوستان هم اشاره کرد باید قبلش بسته base-devel رو با دستور زیر نصب کنی

sudo pacman -S base-devel
البته میتونی بجاش بسته های binutils make gcc fakeroot رو با دستور زیر نصب کنی، فرقی نمی کنه

sudo pacman -S binutils make gcc fakeroot
البته بجای این کارها میتونی مخزن چین رو به مخازن آرچ اضافه کنی ، یعنی فایل etc/pacman.conf رو ویرایش کنی ، مثلا اگر بخواهی با نانو ویرایش کنی دستورش میشه:

sudo nano /etc/pacman.conf

و بعد خطوط زیر رو به انتهاش اضافه کنی

[archlinuxcn]
SigLevel = Never
Server = http://repo.archlinuxcn.org/$arch

بعد با دستور زیر براحتی yay رو نصب کنی

sudo pacman -Sy yay