انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۰.۰۴ منتشر شد.
انتظار می‌ره همهٔ اعضا هرچه زودتر به این نگارش ارتقا پیدا کنند. همهٔ پاسخ‌ها از این به بعد، بر پایهٔ اوبونتو ۲۰.۰۴ خواهد بود.

نویسنده موضوع: مشکل با apt [حل شد]  (دفعات بازدید: 786 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین ###darklinux$$$

  • Sr. Member
  • *
  • ارسال: 416
  • جنسیت : پسر
  • ارزان زیستن به معنی حکم شما بر پول است نه تنگدستی
پاسخ : مشکل با apt
« پاسخ #15 : 24 دی 1398، 01:46 ب‌ظ »
اون برنامه ای که توی ارور هست با این دستور کارشو تموم کن
sudo apt purge --force appname
فکر کنم مشکلت با steam هست
سلام ممنون از توجهتون اما
sudo apt purge --force steam
که این ارور رو میده
E: Command line option --force is not understood in combination with the other options
و اگه از --remove  یا apt purge خالی یا ... استفاده کنم
 دقیقا همون ارور قبلی رو میده
یعنی این
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 linux-headers-5.3.0-26-generic : Depends: linux-headers-5.3.0-26 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

ببخشید میتونید جای --force رو با steam عوض کنید
sudo apt purge steam --force
اینو یادم رفته بود که --force آخر میاد نگا کن bash نوشته نفهمیدم
بعد از اینا میتونی دستورات آپدیت رو اجرا کنی ببینی بازم چه خبره
sudo apt update && sudo apt upgrade -y && sudo apt autoclean -y
یا همین دستور رو کامل کپی کن
سلام  اما هنگام پاک کردن هم دقیقا همین ارور رو میده ](*,) ](*,) ](*,) در ضمن steam ندارم اما هر چی رو میخوام پاک کنم همین ارور میده
apt update و apt autoclean کار کرد (که از اول هم میکرد اما متاسفانه هر استفاده دیگه ای که بخوام از apt بکنم همون ارور رو میده
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 linux-headers-5.3.0-26-generic : Depends: linux-headers-5.3.0-26 but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

هر چی میخوای پاک کنی آخرش یه --force بزار مثلا
sudo apt purge firefox --force
force یعنی زور به زور پاک کردن
sudo apt purge linux-headers-5.3.0-26 --force
ببخشید الآن linux-headers رو پاک کنم مشکلی نداره از اسمش که مهم به نظر میاد
متعلق به یه برنامه به نظر میاد نه
بعد از این کار تموم ppa برنامه هایی که به نظرت مشکل دارن رو پاک کن بعدش
sudo apt update && sudo apt upgrade -y && sudo apt autoclean -y
اگر هم فکر میکنی مشکلی به وجود میاد همین الانم برنامه ناقصه تو به جز مشکل مخازن چیز دیگه ای نمیبینی پس متعلق به یه برنامس
« آخرین ویرایش: 24 دی 1398، 01:54 ب‌ظ توسط ###darklinux$$$ »

آفلاین ###darklinux$$$

  • Sr. Member
  • *
  • ارسال: 416
  • جنسیت : پسر
  • ارزان زیستن به معنی حکم شما بر پول است نه تنگدستی
پاسخ : مشکل با apt
« پاسخ #16 : 24 دی 1398، 01:58 ب‌ظ »
اگر مشکلت حل شد اطلاع رسانی کن :popcorn:

آفلاین SLACKER

  • High Sr. Member
  • *
  • ارسال: 680
  • جنسیت : پسر
پاسخ : مشکل با apt
« پاسخ #17 : 24 دی 1398، 02:05 ب‌ظ »
این رو امتحان کن شاید مشکلت حل بشه. گفتی ۳ تا از بسته ها مشکل دارن
sudo dpkg -i --force-overwrite
جلوی این دستور ادرس اون 3 تا بسته که مشکل دارن رو بده. اینم مثال:
sudo dpkg -i --force-overwrite /var/cache/apt/archives/udev_237-3ubuntu10.9_amd64.deb
بعد بسته ها رو پاک کن و اپدیت و اپگریت
sudo apt purge udev
sudo apt-get update
sudo apt-get upgrade
بسته dev مثاله
اگه کار کرد خبر بده
اسلکور به روزترین توزیع پایدار!
وقتی که شما اسلکور رو یاد میگیرد در حقیقت لینوکس رو یاد گرفتید نه توزیع رو!

آفلاین ali7rangoo

  • Full Member
  • *
  • ارسال: 182
  • جنسیت : پسر
پاسخ : مشکل با apt
« پاسخ #18 : 24 دی 1398، 02:10 ب‌ظ »
اگر مشکلت حل شد اطلاع رسانی کن :popcorn:
نشد
خداوند دنیا رو open source قرار داده .
پس باید سورسشو تغییر بدیم و اون رو به  سوی مثبت ببریم.
nano world

آفلاین ali7rangoo

  • Full Member
  • *
  • ارسال: 182
  • جنسیت : پسر
پاسخ : مشکل با apt
« پاسخ #19 : 24 دی 1398، 02:14 ب‌ظ »
این رو امتحان کن شاید مشکلت حل بشه. گفتی ۳ تا از بسته ها مشکل دارن
sudo dpkg -i --force-overwrite
جلوی این دستور ادرس اون 3 تا بسته که مشکل دارن رو بده. اینم مثال:
sudo dpkg -i --force-overwrite /var/cache/apt/archives/udev_237-3ubuntu10.9_amd64.deb
بعد بسته ها رو پاک کن و اپدیت و اپگریت
sudo apt purge udev
sudo apt-get update
sudo apt-get upgrade
بسته dev مثاله
اگه کار کرد خبر بده
سلام الآن لیست آپگریدم طولانی تر شد الآن اینه
inutils-common/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
binutils-x86-64-linux-gnu/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
binutils/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
fwupd-signed/eoan-updates 1.10.1+1.2.10-1ubuntu3 amd64 [upgradable from: 1.10+1.2.10-1ubuntu2]
fwupd/eoan-updates 1.2.10-1ubuntu3 amd64 [upgradable from: 1.2.10-1ubuntu2]
gnome-desktop3-data/eoan-updates,eoan-updates 3.34.2-2ubuntu1~19.10.1 all [upgradable from: 3.34.1-1ubuntu1]
libbinutils/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
libfwupd2/eoan-updates 1.2.10-1ubuntu3 amd64 [upgradable from: 1.2.10-1ubuntu2]
libgcrypt20/eoan-updates,eoan-security,eoan-security 1.8.4-5ubuntu2.1 amd64 [upgradable from: 1.8.4-5ubuntu2]
libgnome-desktop-3-18/eoan-updates 3.34.2-2ubuntu1~19.10.1 amd64 [upgradable from: 3.34.1-1ubuntu1]
linux-firmware/eoan-updates,eoan-updates 1.183.3 all [upgradable from: 1.183]
linux-headers-5.3.0-26-generic/eoan-updates,eoan-security,eoan-security 5.3.0-26.28 amd64 [upgradable from: 5.3.0-26.28~18.04.1]
thunderbird/eoan-updates,eoan-security,eoan-security 1:68.2.2+build1-0ubuntu0.19.10.1 amd64 [upgradable from: 1:68.1.2+build1-0ubuntu1]

نفهمیدم الآن باید چجوری دستورتون رو تو اینجا وارد کنم البته خودم فکر میکنم فقط این مشکل داره

linux-headers-5.3.0-26-generic/eoan-updates,eoan-security,eoan-security 5.3.0-26.28 amd64 [upgradable from: 5.3.0-26.28~18.04.1]
خداوند دنیا رو open source قرار داده .
پس باید سورسشو تغییر بدیم و اون رو به  سوی مثبت ببریم.
nano world

آفلاین SLACKER

  • High Sr. Member
  • *
  • ارسال: 680
  • جنسیت : پسر
پاسخ : مشکل با apt
« پاسخ #20 : 24 دی 1398، 02:26 ب‌ظ »
این رو امتحان کن شاید مشکلت حل بشه. گفتی ۳ تا از بسته ها مشکل دارن
sudo dpkg -i --force-overwrite
جلوی این دستور ادرس اون 3 تا بسته که مشکل دارن رو بده. اینم مثال:
sudo dpkg -i --force-overwrite /var/cache/apt/archives/udev_237-3ubuntu10.9_amd64.deb
بعد بسته ها رو پاک کن و اپدیت و اپگریت
sudo apt purge udev
sudo apt-get update
sudo apt-get upgrade
بسته dev مثاله
اگه کار کرد خبر بده
سلام الآن لیست آپگریدم طولانی تر شد الآن اینه
inutils-common/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
binutils-x86-64-linux-gnu/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
binutils/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
fwupd-signed/eoan-updates 1.10.1+1.2.10-1ubuntu3 amd64 [upgradable from: 1.10+1.2.10-1ubuntu2]
fwupd/eoan-updates 1.2.10-1ubuntu3 amd64 [upgradable from: 1.2.10-1ubuntu2]
gnome-desktop3-data/eoan-updates,eoan-updates 3.34.2-2ubuntu1~19.10.1 all [upgradable from: 3.34.1-1ubuntu1]
libbinutils/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
libfwupd2/eoan-updates 1.2.10-1ubuntu3 amd64 [upgradable from: 1.2.10-1ubuntu2]
libgcrypt20/eoan-updates,eoan-security,eoan-security 1.8.4-5ubuntu2.1 amd64 [upgradable from: 1.8.4-5ubuntu2]
libgnome-desktop-3-18/eoan-updates 3.34.2-2ubuntu1~19.10.1 amd64 [upgradable from: 3.34.1-1ubuntu1]
linux-firmware/eoan-updates,eoan-updates 1.183.3 all [upgradable from: 1.183]
linux-headers-5.3.0-26-generic/eoan-updates,eoan-security,eoan-security 5.3.0-26.28 amd64 [upgradable from: 5.3.0-26.28~18.04.1]
thunderbird/eoan-updates,eoan-security,eoan-security 1:68.2.2+build1-0ubuntu0.19.10.1 amd64 [upgradable from: 1:68.1.2+build1-0ubuntu1]

نفهمیدم الآن باید چجوری دستورتون رو تو اینجا وارد کنم البته خودم فکر میکنم فقط این مشکل داره

linux-headers-5.3.0-26-generic/eoan-updates,eoan-security,eoan-security 5.3.0-26.28 amd64 [upgradable from: 5.3.0-26.28~18.04.1]
یعنی الان اون ۳ بسته که مشکل داشتن رو حذف کردی؟
اپگرید کردی ببینی درست شده یا نه؟
اسلکور به روزترین توزیع پایدار!
وقتی که شما اسلکور رو یاد میگیرد در حقیقت لینوکس رو یاد گرفتید نه توزیع رو!

آفلاین ali7rangoo

  • Full Member
  • *
  • ارسال: 182
  • جنسیت : پسر
پاسخ : مشکل با apt
« پاسخ #21 : 24 دی 1398، 02:38 ب‌ظ »
این رو امتحان کن شاید مشکلت حل بشه. گفتی ۳ تا از بسته ها مشکل دارن
sudo dpkg -i --force-overwrite
جلوی این دستور ادرس اون 3 تا بسته که مشکل دارن رو بده. اینم مثال:
sudo dpkg -i --force-overwrite /var/cache/apt/archives/udev_237-3ubuntu10.9_amd64.deb
بعد بسته ها رو پاک کن و اپدیت و اپگریت
sudo apt purge udev
sudo apt-get update
sudo apt-get upgrade
بسته dev مثاله
اگه کار کرد خبر بده
سلام الآن لیست آپگریدم طولانی تر شد الآن اینه
inutils-common/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
binutils-x86-64-linux-gnu/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
binutils/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
fwupd-signed/eoan-updates 1.10.1+1.2.10-1ubuntu3 amd64 [upgradable from: 1.10+1.2.10-1ubuntu2]
fwupd/eoan-updates 1.2.10-1ubuntu3 amd64 [upgradable from: 1.2.10-1ubuntu2]
gnome-desktop3-data/eoan-updates,eoan-updates 3.34.2-2ubuntu1~19.10.1 all [upgradable from: 3.34.1-1ubuntu1]
libbinutils/eoan-updates,eoan-security,eoan-security 2.33-2ubuntu1.2 amd64 [upgradable from: 2.33-2ubuntu1]
libfwupd2/eoan-updates 1.2.10-1ubuntu3 amd64 [upgradable from: 1.2.10-1ubuntu2]
libgcrypt20/eoan-updates,eoan-security,eoan-security 1.8.4-5ubuntu2.1 amd64 [upgradable from: 1.8.4-5ubuntu2]
libgnome-desktop-3-18/eoan-updates 3.34.2-2ubuntu1~19.10.1 amd64 [upgradable from: 3.34.1-1ubuntu1]
linux-firmware/eoan-updates,eoan-updates 1.183.3 all [upgradable from: 1.183]
linux-headers-5.3.0-26-generic/eoan-updates,eoan-security,eoan-security 5.3.0-26.28 amd64 [upgradable from: 5.3.0-26.28~18.04.1]
thunderbird/eoan-updates,eoan-security,eoan-security 1:68.2.2+build1-0ubuntu0.19.10.1 amd64 [upgradable from: 1:68.1.2+build1-0ubuntu1]

نفهمیدم الآن باید چجوری دستورتون رو تو اینجا وارد کنم البته خودم فکر میکنم فقط این مشکل داره

linux-headers-5.3.0-26-generic/eoan-updates,eoan-security,eoan-security 5.3.0-26.28 amd64 [upgradable from: 5.3.0-26.28~18.04.1]
یعنی الان اون ۳ بسته که مشکل داشتن رو حذف کردی؟
اپگرید کردی ببینی درست شده یا نه؟
نه نه نفهمیم چجوری حذف کنم
شما بگید چجوری کلک این
linux-headers-5.3.0-26-generic/eoan-updates,eoan-security,eoan-security 5.3.0-26.28
رو با روش اصلاح کنم یا حذف کنم فکر کنم مشکل اصلی اینه.
خداوند دنیا رو open source قرار داده .
پس باید سورسشو تغییر بدیم و اون رو به  سوی مثبت ببریم.
nano world

آفلاین ali7rangoo

  • Full Member
  • *
  • ارسال: 182
  • جنسیت : پسر
پاسخ : مشکل با apt
« پاسخ #22 : 24 دی 1398، 02:46 ب‌ظ »
راستی یه مساله یادم اومد قبل از اینکه زوبونتو رو نصب کنم چون با کارت گرافیک من مشکل داره ppa کارت گرافیک رو با استفاده از cubic builder اضافه کردم
و الآنم رفتم ppa شو حذف کردم اما بازم حل نشد به نظرتون مشکل بخاطر این بوده بنظرتون اگه نسخه بدون دستکاریشو بنصبم با آپگرید دوباره این مشکل پیش نمیاد



خیلی خیلی ببخشید دارم وقتتونو میگیرم
خداوند دنیا رو open source قرار داده .
پس باید سورسشو تغییر بدیم و اون رو به  سوی مثبت ببریم.
nano world

آفلاین SLACKER

  • High Sr. Member
  • *
  • ارسال: 680
  • جنسیت : پسر
پاسخ : مشکل با apt
« پاسخ #23 : 24 دی 1398، 02:52 ب‌ظ »
راستی یه مساله یادم اومد قبل از اینکه زوبونتو رو نصب کنم چون با کارت گرافیک من مشکل داره ppa کارت گرافیک رو با استفاده از cubic builder اضافه کردم
و الآنم رفتم ppa شو حذف کردم اما بازم حل نشد به نظرتون مشکل بخاطر این بوده بنظرتون اگه نسخه بدون دستکاریشو بنصبم با آپگرید دوباره این مشکل پیش نمیاد



خیلی خیلی ببخشید دارم وقتتونو میگیرم
احتمالا بخاطر همین بوده
حالا باید ببینی چی از ppa نصب شده و احتمالا پاکش کنی
______________________________
ولی بهترین کار اینه دوباره زوبونتو رو از اول نصب کنی
اول اپدیت و اپگرید انجام بده بعد برد سراغ کارت گرافیک
——————————————————-
اینم امتحان کن ببین چی میشه
sudo apt install linux-headers-$(uname -r)
اسلکور به روزترین توزیع پایدار!
وقتی که شما اسلکور رو یاد میگیرد در حقیقت لینوکس رو یاد گرفتید نه توزیع رو!

آفلاین ali7rangoo

  • Full Member
  • *
  • ارسال: 182
  • جنسیت : پسر
پاسخ : مشکل با apt
« پاسخ #24 : 24 دی 1398، 02:56 ب‌ظ »
ای بابا یه چیز دیگه یه دوستی گفته بودن شاید فضای کافی نداری فکر کنم همونه من اینبار برای usr boot و فلان پارتیشن جداگانه در نظر گرفتم و وقتی میرم آپدیت از طریق گرافیکی انجام بدم این ارور رو بهم میده

الآن باید با چه ابزاری درستش کنم با gparted یا چیز دیگه اگه میشه بگشد
خداوند دنیا رو open source قرار داده .
پس باید سورسشو تغییر بدیم و اون رو به  سوی مثبت ببریم.
nano world

آفلاین هومان

  • High Hero Member
  • *
  • ارسال: 1314
  • جنسیت : پسر
  • bedrock user
پاسخ : مشکل با apt
« پاسخ #25 : 24 دی 1398، 02:59 ب‌ظ »
با gparted می تونید حجمرو تغییر بدید البته باید فضای پارتیشن نشدع داشته باشید
musl is god

آفلاین ali7rangoo

  • Full Member
  • *
  • ارسال: 182
  • جنسیت : پسر
پاسخ : مشکل با apt
« پاسخ #26 : 24 دی 1398، 05:19 ب‌ظ »
با gparted می تونید حجمرو تغییر بدید البته باید فضای پارتیشن نشدع داشته باشید
مشکل اصلی اینجاست که اونم نمیشه نصب کرد ](*,)
خداوند دنیا رو open source قرار داده .
پس باید سورسشو تغییر بدیم و اون رو به  سوی مثبت ببریم.
nano world

آفلاین هومان

  • High Hero Member
  • *
  • ارسال: 1314
  • جنسیت : پسر
  • bedrock user
پاسخ : مشکل با apt
« پاسخ #27 : 24 دی 1398، 05:27 ب‌ظ »
ایزوی زنده رو دانلود کنید بعد بوتیبل کنید با dd
musl is god

آفلاین ###darklinux$$$

  • Sr. Member
  • *
  • ارسال: 416
  • جنسیت : پسر
  • ارزان زیستن به معنی حکم شما بر پول است نه تنگدستی
پاسخ : مشکل با apt
« پاسخ #28 : 25 دی 1398، 10:33 ق‌ظ »
با gparted می تونید حجمرو تغییر بدید البته باید فضای پارتیشن نشدع داشته باشید
مشکل اصلی اینجاست که اونم نمیشه نصب کرد ](*,)
]چه کاریه همون زوبونتو رو لایو بوت کنید خودش gparted داره

آفلاین ali7rangoo

  • Full Member
  • *
  • ارسال: 182
  • جنسیت : پسر
پاسخ : مشکل با apt
« پاسخ #29 : 25 دی 1398، 11:22 ق‌ظ »
با gparted می تونید حجمرو تغییر بدید البته باید فضای پارتیشن نشدع داشته باشید
مشکل اصلی اینجاست که اونم نمیشه نصب کرد ](*,)
]چه کاریه همون زوبونتو رو لایو بوت کنید خودش gparted داره
سلام
راست میگی من خبر نداشتم زوبونتو پیشفرض Gparted رو داره به هر حال دوباهر نصبیدمش و در پارتیشن بندی دو تا پارتیشن بیشتر نساختم(روت و هوم) یه ده گیگی هم برا swap و فضای خالی نگه داشتم الآن دارم آپگرید میکنم انشاالله که جواب میده و در آخر محضر همه کسانی که در این مشکل به من کمک کردن نهایت تشکر و عذرخواهی  ;D رو دارم.
خداوند دنیا رو open source قرار داده .
پس باید سورسشو تغییر بدیم و اون رو به  سوی مثبت ببریم.
nano world