انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۰٫۱۰ منتشر شد.
انتظار می‌ره همهٔ اعضا هرچه زودتر به این نگارش ارتقا پیدا کنند. همهٔ پاسخ‌ها از این به بعد، بر پایهٔ اوبونتو ۲۰٫۱۰ خواهد بود.

نویسنده موضوع: راهنمایی برای نصب ویجت (حل شد)  (دفعات بازدید: 618 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین vmxcodex

  • Sr. Member
  • *
  • ارسال: 451
  • جنسیت : پسر
راهنمایی برای نصب ویجت (حل شد)
« : 01 بهمن 1397، 01:39 ب‌ظ »
سلام
میخوام این رو نصب کنم :
https://github.com/psifidotos/applet-window-buttons

خطا دارم :
encoder@Office:~/Desktop/C$ sudo sh install.sh
install.sh: 1: [: -a: unexpected operator
-- The C compiler identification is GNU 7.3.0
-- The CXX compiler identification is GNU 7.3.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found KF5CoreAddons: /usr/lib/x86_64-linux-gnu/cmake/KF5CoreAddons/KF5CoreAddonsConfig.cmake (found version "5.54.0")
-- Could NOT find KF5Declarative (missing: KF5Declarative_DIR)
-- Could NOT find KF5Declarative: found neither KF5DeclarativeConfig.cmake nor kf5declarative-config.cmake
-- Installing in the same prefix as Qt, adopting their path scheme.
-- Found KF5Plasma: /usr/lib/x86_64-linux-gnu/cmake/KF5Plasma/KF5PlasmaConfig.cmake (found version "5.54.0")
-- Found KF5PlasmaQuick: /usr/lib/x86_64-linux-gnu/cmake/KF5PlasmaQuick/KF5PlasmaQuickConfig.cmake (found version "5.54.0")
CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
  Could NOT find KF5 (missing: Declarative) (found suitable version "5.54.0",
  minimum required is "5.38.0")
Call Stack (most recent call first):
  /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
  /usr/local/share/ECM/find-modules/FindKF5.cmake:110 (find_package_handle_standard_args)
  CMakeLists.txt:18 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/encoder/Desktop/C/build/CMakeFiles/CMakeOutput.log".
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.


فایل لاگ رو هم پیوست کردم ٬
 بسته های زیر رو هم نصب کردم :
libkf5declarative5*
libkf5plasma-dev
extra-cmake-modules(from source)
qtdeclarative5-dev
libkdecorations2-dev

این هم مشخصات سیستم :
« آخرین ویرایش: 01 بهمن 1397، 02:12 ب‌ظ توسط enCODEr »

آفلاین vmxcodex

  • Sr. Member
  • *
  • ارسال: 451
  • جنسیت : پسر
پاسخ : راهنمایی برای نصب ویجت (حل شد)
« پاسخ #1 : 01 بهمن 1397، 02:13 ب‌ظ »
این بسته ها رو کم داشت :
libkdeclarative5_4.14.22-0ubuntu2.2~ubuntu16.04~ppa1_amd64.deb
libkf5declarative-dev_5.36.0-0ubuntu1~ubuntu16.04~ppa1_amd64.deb
« آخرین ویرایش: 01 بهمن 1397، 02:15 ب‌ظ توسط enCODEr »