انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید


 خبرها، اتفاقات و تصاویر مربوط به مربوط به جشن انتشار را با هشتگ ufest1804 در شبکه‌های اجتماعی دنبال کنید

نویسنده موضوع: مشکل در نصب کارخواه اف‌دروید روی اوبونتو  (دفعات بازدید: 155 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین ahangarha

  • Newbie
  • *
  • ارسال: 16
  • جنسیت : پسر
سلام

برای افزودن کاره‌های آزاد روی مخازن اف‌دروید، طبق آموزش آقای بهزادی پیش رفته‌ام. (https://archive.org/details/add-app-fdroid-danialbehzadi-tehlug247)

اما زمانی که دستور gradle AssembleRelease را وارد می‌کنم، خطای زیر را می‌گیرم:

➜  fdroidclient git:(master) gradle AssembleRelease

FAILURE: Build failed with an exception.

* What went wrong:
Could not determine java version from '10.0.2'.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


➜  fdroidclient git:(master) gradle --stacktrace AssembleRelease

FAILURE: Build failed with an exception.

* What went wrong:
Could not determine java version from '10.0.2'.

* Try:
Run with --info or --debug option to get more log output.

* Exception is:
java.lang.IllegalArgumentException: Could not determine java version from '10.0.2'.
        at org.gradle.api.JavaVersion.toVersion(JavaVersion.java:70)
        at org.gradle.api.JavaVersion.current(JavaVersion.java:80)
        at org.gradle.internal.jvm.UnsupportedJavaRuntimeException.assertUsingVersion(UnsupportedJavaRuntimeException.java:29)
        at org.gradle.launcher.cli.JavaRuntimeValidationAction.execute(JavaRuntimeValidationAction.java:32)
        at org.gradle.launcher.cli.JavaRuntimeValidationAction.execute(JavaRuntimeValidationAction.java:24)
        at org.gradle.launcher.cli.ExceptionReportingAction.execute(ExceptionReportingAction.java:33)
        at org.gradle.launcher.cli.ExceptionReportingAction.execute(ExceptionReportingAction.java:22)
        at org.gradle.launcher.cli.CommandLineActionFactory$WithLogging.execute(CommandLineActionFactory.java:210)
        at org.gradle.launcher.cli.CommandLineActionFactory$WithLogging.execute(CommandLineActionFactory.java:174)
        at org.gradle.launcher.Main.doAction(Main.java:33)
        at org.gradle.launcher.bootstrap.EntryPoint.run(EntryPoint.java:45)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:564)
        at org.gradle.launcher.bootstrap.ProcessBootstrap.runNoExit(ProcessBootstrap.java:60)
        at org.gradle.launcher.bootstrap.ProcessBootstrap.run(ProcessBootstrap.java:37)
        at org.gradle.launcher.GradleMain.main(GradleMain.java:23)

مشکل از کجاست؟

(از اوبونتو ۱۸٫۰۴ دارم استفاده می‌کنم)

آفلاین majid.ee

  • Newbie
  • *
  • ارسال: 20
محتوی فایل gradle-wrapper.properties رو بذارین.

آفلاین ahangarha

  • Newbie
  • *
  • ارسال: 16
  • جنسیت : پسر
$ cat gradle/wrapper/gradle-wrapper.properties
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.4.1-bin.zip
distributionSha256Sum=e7cf7d1853dfc30c1c44f571d3919eeeedef002823b66b6a988d27e919686389


آفلاین علی رزم دیده

  • عضو کاربران ایرانی اوبونتو
  • *
  • ارسال: 1178
  • جنسیت : پسر
  • ali76 سابق
سلام

این مشکل ناشی از این هست که شما نسخه ی قدیمی gradle (نسخه ی 4.4.1) رو استفاده می کنین که از جاوا 10 پشتیبانی نمی کنه. شما باید نسخه ی gradle تون رو به نسخه های بالاتر 4.7 ارتقا بدین.

برای این کار می تونین از فایل gradle-wrapper.properties کمک بگیرین و distribution* رو به صورت زیر تغییر بدین :

برای مثال برای نسخه ی 5:
distributionUrl=https\://services.gradle.org/distributions/gradle-5.0-bin.zip
distributionSha256Sum=6157ac9f3410bc63644625b3b3e9e96c963afd7910ae0697792db57813ee79a6

و یا برای نسخه ی 4.7:
distributionUrl=https\://services.gradle.org/distributions/gradle-4.7-bin.zip
distributionSha256Sum=fca5087dc8b50c64655c000989635664a73b11b9bd3703c7d6cabd31b7dcdb04

این ها هم مشکلاتی مشابه مشکل شما هستند که نگاه کردن به اونا هم خالی از لطف نیست :