انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۰.۰۴ منتشر شد.
انتظار می‌ره همهٔ اعضا هرچه زودتر به این نگارش ارتقا پیدا کنند. همهٔ پاسخ‌ها از این به بعد، بر پایهٔ اوبونتو ۲۰.۰۴ خواهد بود.

نویسنده موضوع: مشکل SHELL پیش فرض  (دفعات بازدید: 323 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین bahram.alef

  • Newbie
  • *
  • ارسال: 7
  • جنسیت : پسر
مشکل SHELL پیش فرض
« : 24 آبان 1397، 03:14 ق‌ظ »
سلام خسته نباشید من zsh نصب کردم رو سیستم اما شل پیش فرض باش هست
chsh -s /usr/bin/zshرو که میزنم دوباره همون میمونه و
 echo $SHELL میزنم خروجیش باش bin/bashآدرس درست است
قبلش این کد رو زدم برا فهمیدنش which zsh

امیدوارم درست گفته باشم
خلاصه کلام اینه با اینکه با chsh -s شل رو تغییر دادم اما بازم هیچ تغییری نمیکنه با روت هم امتحان کردم.
پیشاپیش ممنون

آفلاین yahya.musavi

  • Full Member
  • *
  • ارسال: 219
  • جنسیت : پسر
  • بهترین موسیقی دنیا=شنیدن صوت قرآن
نپرسید کشورتان چه کاری می‌تواند برای شما انجام دهد. بپرسید شما چه کاری می‌توانید برای کشورتان انجام دهید.   جان اف. کندی

آزادی در پرتو قانون. همانند هوایی است که ما تنفس می کنیم. دوایت آیزنهاور


آفلاین M!lad

  • High Hero Member
  • *
  • ارسال: 1181
پاسخ : مشکل SHELL پیش فرض
« پاسخ #3 : 24 آبان 1397، 01:33 ب‌ظ »
یک بار باید logout و مجدد login کنید.

این دستور رو بزنید تا مطمئن بشید شل مورد نظرتون ست شده:

getent passwd $USER | cut -f7 -d:
باید برگردونه

/usr/bin/zsh
..I feel no fault for the fault I feel..

آفلاین bahram.alef

  • Newbie
  • *
  • ارسال: 7
  • جنسیت : پسر
پاسخ : مشکل SHELL پیش فرض
« پاسخ #4 : 24 آبان 1397، 10:07 ب‌ظ »
ممنون رفقا