انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید


 خبرها، اتفاقات و تصاویر مربوط به مربوط به جشن انتشار را با هشتگ ufest1804 در شبکه‌های اجتماعی دنبال کنید

نویسنده موضوع: مشکل در اتصال به دیتابیس(حل شد)  (دفعات بازدید: 205 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین Mr-virus

  • Full Member
  • *
  • ارسال: 107
  • جنسیت : پسر
مشکل در اتصال به دیتابیس(حل شد)
« : 10 مهر 1397، 07:59 ب‌ظ »
سلام دوستان
بنده یک مشکلی دارم وقتی با php میخوام به دیتابیس کانکت بشم هیچ خروجی نداره و یک صفحه سفید هست و در سورس هم چیزی وجود نداره!با وردپرس هم امتحان کردم بعد از وارد کردن مشخصات دیتابیس و یا ساختن فایل کانفیگ جهت اتصال به دیتابیس هیچ خروجی ندارم و صفحه سفیده.
این هارو قرار میدم شاید اطلاعات خاصی وجود داشته باشه فایل لاگ رو پیدا نکردم متاسفانه و لاگ های موجود خالی بودن:
● mariadb.service - MariaDB 10.1.35 database server
   Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2018-09-26 20:23:15 +0330; 17min ago
     Docs: man:mysqld(8)
           https://mariadb.com/kb/en/library/systemd/
  Process: 2009 ExecStartPost=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
  Process: 1926 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ]   && systemctl set-environment _WSREP_START_POSITION=$VAR || exit 1 (code=exited, status=0/SUCCESS)
  Process: 1925 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
 Main PID: 1981 (mysqld)
   Status: "Taking your SQL requests now..."
    Tasks: 27 (limit: 4915)
   Memory: 63.5M
   CGroup: /system.slice/mariadb.service
           └─1981 /usr/bin/mysqld

Sep 26 20:23:15 archlinux mysqld[1981]: 2018-09-26 20:23:15 139717078753216 [Note] InnoDB: Highest supported file format is Barracuda.
Sep 26 20:23:15 archlinux mysqld[1981]: 2018-09-26 20:23:15 139717078753216 [Note] InnoDB: 128 rollback segment(s) are active.
Sep 26 20:23:15 archlinux mysqld[1981]: 2018-09-26 20:23:15 139717078753216 [Note] InnoDB: Waiting for purge to start
Sep 26 20:23:15 archlinux mysqld[1981]: 2018-09-26 20:23:15 139717078753216 [Note] InnoDB:  Percona XtraDB (http://www.percona.com) 5.6.39-83.1 started; log sequence number 1642925
Sep 26 20:23:15 archlinux mysqld[1981]: 2018-09-26 20:23:15 139717078753216 [Note] Plugin 'FEEDBACK' is disabled.
Sep 26 20:23:15 archlinux mysqld[1981]: 2018-09-26 20:23:15 139716500387584 [Note] InnoDB: Dumping buffer pool(s) not yet started
Sep 26 20:23:15 archlinux mysqld[1981]: 2018-09-26 20:23:15 139717078753216 [Note] Server socket created on IP: '127.0.0.1'.
Sep 26 20:23:15 archlinux mysqld[1981]: 2018-09-26 20:23:15 139717078753216 [Note] /usr/bin/mysqld: ready for connections.
Sep 26 20:23:15 archlinux mysqld[1981]: Version: '10.1.35-MariaDB'  socket: '/run/mysqld/mysqld.sock'  port: 3306  MariaDB Server
Sep 26 20:23:15 archlinux systemd[1]: Started MariaDB 10.1.35 database server.
« آخرین ویرایش: 24 آبان 1397، 06:01 ب‌ظ توسط Mr-virus »

آفلاین Mr-virus

  • Full Member
  • *
  • ارسال: 107
  • جنسیت : پسر
پاسخ : مشکل در اتصال به دیتابیس
« پاسخ #1 : 03 آبان 1397، 03:30 ب‌ظ »
دوستان کسی پیشنهادی نداره؟مشکلم هنوز حل نشده متاسفانه

آنلاین lingirl

  • Jr. Member
  • *
  • ارسال: 42
پاسخ : مشکل در اتصال به دیتابیس
« پاسخ #2 : 05 آبان 1397، 02:32 ب‌ظ »
یک یوزر بساز داخل دیبی و بعدش اونو grant کن و پرمیژن های همه چیزو بهش بده. توی وردپرست این یوزر و مشخصاتش رو وارد کن

آفلاین Mr-virus

  • Full Member
  • *
  • ارسال: 107
  • جنسیت : پسر
پاسخ : مشکل در اتصال به دیتابیس
« پاسخ #3 : 24 آبان 1397، 05:58 ب‌ظ »
دوستان حل شد.متوجه شدم باید از php.ini دیتابیس mysql رو فعال کنم و با فعال سازی مشکل حل شد.