انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

نویسنده موضوع: بروز خطا بعد از آپگرید دبیان 8 به 9.4 وگرفتاری شدید  (دفعات بازدید: 491 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین tahamtan

  • Newbie
  • *
  • ارسال: 4
  • جنسیت : پسر
سلام

خسته نباشید
دبیان 8 رو به 9.4 آپگرید کردیم

روی دبیان 8 مجازی ساز proxmox استفاده می کردیم که 4 تا سرور مجازی ویندوز داره ، به علت بالا بودن حجم سرور های مجازی فایل های بکاپ بجز یکی همه ناقص و غیر قابل استفاده هستند .
الان سیستم بدرستی کار نمی کنه و به مجازی ساز proxmox هم دسترسی نداریم  :(

دبیان ناقص آپدیت شده و این خطا ها رو می دهد



zfs-initramfs این نصب شده ولی اجرا نمیشود که مربوط به فایل‌ سیستمی استفاده شده برای هارد سرور های مجازی است

depends

zfsutils-linux

but it is not going to be installed

متاسفانه هر کاری که می تونستم انجام دادم ولی رفع نشد .



دوباره هم تلاش کردم آپدیت کنم که این پیام رو میده

you might want to run apt --fix-broken install

و اینکار رو هم انجام میدم دوباره سه تا سرویس بالا رو ایراد می گیره


لطفا راهنمایی کنید ، الان دو روزه همه سرور ها و سایت ها دان هستند ، متاسفانه بکاپ هم نداریم

با تشکر

آفلاین فرهاد محمدی مجد

  • Sr. Member
  • *
  • ارسال: 487
  • جنسیت : پسر
  • Debian + GNOME + XFCE
    • debian.org
این جور مشکلات حاد، حیاتی و پیچیده را بهتره در لیست پستی دبیان مطرح کنید، بهترین و سریع ترین جواب ها توسط لیست پستی داده میشوند.
نام کاربری اصلی و نخستم Fedora-Red Hat بود ولی دیدم بهتره با نام حقیقیم فعالیت کنم.

آفلاین tahamtan

  • Newbie
  • *
  • ارسال: 4
  • جنسیت : پسر
سلام
ممنون راهنمایی کردید .
من تازه عضو شدم
لطفا لینک مربوزه رو بفرستید
با تشکر

آفلاین nixoeen

  • ناظر انجمن
  • *
  • ارسال: 3701
  • جنسیت : پسر
  • masoft قدیم
باید خروجی‌هایی که میگیرید رو به صورت کامل بذارید تا بتونیم بهتون کمک کنیم.

آفلاین سلمان م.

  • ناظر انجمن
  • *
  • ارسال: 3721
  • جنسیت : پسر
  • GNU Operating System - سیستم عامل گنو
درود بر تو،

اول از همه این‌که پیغام‌های خطاها رو کامل بذار تا بهتر بشه نظر داد

و همچنین اینکه دو تا بسته‌ای که گفتی توی مخزن‌های contrib هستن، پس قاعدتا نباید مشکلی وجود داشته باشه، contrib رو توی /etc/apt/sources.list وارد کردی؟

همچنین اینکه محتویات /etc/apt/sources.list رو این‌جا بذار.

همچنین پیغام‌هایی که بعد از زدن دستور زیر می‌ده رو بذار:

$ sudo apt install zfsutils-linux

آفلاین tahamtan

  • Newbie
  • *
  • ارسال: 4
  • جنسیت : پسر
deb  http://deb.debian.org/debian stretch main
deb-src  http://deb.debian.org/debian stretch main
 
deb  http://deb.debian.org/debian stretch-updates main
deb-src  http://deb.debian.org/debian stretch-updates main
 
deb http://security.debian.org/ stretch/updates main
deb-src http://security.debian.org/ stretch/updates main
 
 
#If you also want the contrib and non-free components, add contrib non-free after main:
 
 
deb  http://deb.debian.org/debian stretch main contrib non-free
deb-src  http://deb.debian.org/debian stretch main contrib non-free
 
deb  http://deb.debian.org/debian stretch-updates main contrib non-free
deb-src  http://deb.debian.org/debian stretch-updates main contrib non-free
 
deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free



--fix -broken install

(Reading database ... 178290 files and directories currently installed.)
Preparing to unpack .../libuutil1linux_0.7.8-pve1~bpo9_amd64.deb ...
Unpacking libuutil1linux (0.7.8-pve1~bpo9) ...
dpkg: error processing archive /var/cache/apt/archives/libuutil1linux_0.7.8-pve1~bpo9_amd64.deb (--unpack):
 trying to overwrite '/lib/libuutil.so.1.0.1', which is also in package libuutil1 0.6.5-pve9~jessie
Preparing to unpack .../libnvpair1linux_0.7.8-pve1~bpo9_amd64.deb ...
Unpacking libnvpair1linux (0.7.8-pve1~bpo9) ...
dpkg: error processing archive /var/cache/apt/archives/libnvpair1linux_0.7.8-pve1~bpo9_amd64.deb (--unpack):
 trying to overwrite '/lib/libnvpair.so.1.0.1', which is also in package libnvpair1 0.6.5-pve9~jessie
Preparing to unpack .../libzpool2linux_0.7.8-pve1~bpo9_amd64.deb ...
Unpacking libzpool2linux (0.7.8-pve1~bpo9) ...
dpkg: error processing archive /var/cache/apt/archives/libzpool2linux_0.7.8-pve1~bpo9_amd64.deb (--unpack):
 trying to overwrite '/lib/libzpool.so.2.0.0', which is also in package libzpool2 0.6.5-pve9~jessie
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../libzfs2linux_0.7.8-pve1~bpo9_amd64.deb ...
Unpacking libzfs2linux (0.7.8-pve1~bpo9) ...
dpkg: error processing archive /var/cache/apt/archives/libzfs2linux_0.7.8-pve1~bpo9_amd64.deb (--unpack):
 trying to overwrite '/lib/libzfs.so.2.0.0', which is also in package libzfs2 0.6.5-pve9~jessie
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../zfsutils-linux_0.7.8-pve1~bpo9_amd64.deb ...
Unpacking zfsutils-linux (0.7.8-pve1~bpo9) ...
dpkg: error processing archive /var/cache/apt/archives/zfsutils-linux_0.7.8-pve1~bpo9_amd64.deb (--unpack):
 trying to overwrite '/etc/default/zfs', which is also in package zfsutils 0.6.5-pve9~jessie
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libuutil1linux_0.7.8-pve1~bpo9_amd64.deb
 /var/cache/apt/archives/libnvpair1linux_0.7.8-pve1~bpo9_amd64.deb
 /var/cache/apt/archives/libzpool2linux_0.7.8-pve1~bpo9_amd64.deb
 /var/cache/apt/archives/libzfs2linux_0.7.8-pve1~bpo9_amd64.deb
 /var/cache/apt/archives/zfsutils-linux_0.7.8-pve1~bpo9_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

دوستان به سرور دسترسی نداشتم دیر ارسال کردم

آفلاین tahamtan

  • Newbie
  • *
  • ارسال: 4
  • جنسیت : پسر
root@server:~# apt install zfsutils-linux
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 systemd : Depends: libsystemd0 (= 232-25+deb9u2) but 232-25+deb9u3 is to be installed
 zfsutils-linux : Depends: libnvpair1linux (>= 0.7.8) but it is not going to be installed
                  Depends: libuutil1linux (>= 0.7.8) but it is not going to be installed
                  Depends: libzfs2linux (>= 0.7.8) but it is not going to be installed
                  Depends: libzpool2linux (>= 0.7.8) but it is not going to be installed
                  Recommends: zfs-zed but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

پکیج های نصب شده هم این موارد رو نشون میده ، دوباره دبیان رو آپدیت می کنم همین ها تکرار میشه
Try 'apt --fix-broken install' with no packages (or specify a solution

root@server:~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 systemd : Depends: libsystemd0 (= 232-25+deb9u2) but 232-25+deb9u3 is installed
 zfs-initramfs : Depends: zfsutils-linux but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

root@server:~# dpkg -C
The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
 zfs-initramfs        OpenZFS root filesystem capabilities for Linux - initramf

The following packages have been triggered, but the trigger processing
has not yet been done.  Trigger processing can be requested using
dselect or dpkg --configure --pending (or dpkg --triggers-only):
 libc-bin             GNU C Library: Binaries

بعد از دستور  apt --fix-broken install

root@server:~# apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  espeak-data firebird2.5-common firebird2.5-common-doc firebird2.5-server-common firebird3.0-common
  firebird3.0-common-doc gdebi-core gir1.2-clutter-gst-2.0 gir1.2-gkbd-3.0 gir1.2-grilo-0.2 gir1.2-gtop-2.0
  gir1.2-javascriptcoregtk-3.0 gir1.2-mediaart-1.0 gir1.2-webkit-3.0 gir1.2-xkl-1.0 gnome-icon-theme-symbolic
  gstreamer0.10-gconf gstreamer0.10-nice gstreamer0.10-plugins-bad gstreamer0.10-plugins-base gstreamer0.10-pulseaudio
  gstreamer0.10-x gstreamer1.0-clutter hwdata imagemagick-common libamd2.3.1 libavcodec56 libavformat56 libavresample2
  libavutil54 libcamd2.3.1 libcamel-1.2-49 libccolamd2.8.0 libcdaudio1 libcholmod2.1.2 libchromaprint0
  libclutter-gst-2.0-0 libcolamd2.8.0 libcoverart0 libdbus-1-dev libdirac-encoder0 libebackend-1.2-7 libecal-1.2-16
  libedata-cal-1.2-23 libedataserver-1.2-18 libegl1-mesa-drivers libelfg0 libept1.4.12 libespeak1 libexiv2-13
  libfbclient2 libfbembed2.5 libgdata19 libgdict-1.0-6 libgegl-0.2-0 libgif4 libgit2-21 libglew1.10 libgnome2-0
  libgphoto2-port10 libgrilo-0.2-1 libgstreamer-plugins-bad0.10-0 libgstreamer-plugins-base0.10-0 libgstreamer0.10-0
  libgtkglext1 libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0 libgtop2-7 libhunspell-1.3-0 libical1a
  libilmbase6 libimobiledevice4 libinput5 libjim0.75 libjsoncpp0 liblircclient0 libllvm3.5 liblouis2 liblua5.1-0
  libmediaart-1.0-0 libmimic0 libmusicbrainz5-1 libnm-glib-vpn1 libnm-gtk-common libopenexr6 libopenjpeg5 libopenraw1
  libopenvg1-mesa liborcus-0.8-0 libplist2 libpoppler46 libqmi-glib1 libqt4-dbus libqt4-xml libqtcore4 libqtdbus4
  libqtgui4 libquvi-scripts libquvi7 libreoffice-gtk libreoffice-gtk2 libreoffice-sdbc-firebird libreoffice-systray
  librhythmbox-core8 librygel-core-2.4-2 librygel-renderer-2.4-2 librygel-renderer-gst-2.4-2 librygel-server-2.4-2
  libschroedinger-1.0-0 libsctp1 libslv2-9 libsoundtouch0 libspice-client-gtk-3.0-4 libswscale3 libtommath1
  libumfpack5.6.2 libusbmuxd2 libvpx1 libvte-2.90-9 libvte-2.90-common libwebp5 libwebrtc-audio-processing-0
  libwildmidi1 libwps-0.3-3 libx264-142 lksctp-tools mobile-broadband-provider-info perlmagick pkg-config python-cups
  python-dbus-dev python-gobject python-libxml2 python-pyatspi python-smbc qdbus qt-at-spi qtchooser qtcore4-l10n
  system-config-printer xbase-clients
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  libnvpair1linux libpam-systemd libuutil1linux libzfs2linux libzpool2linux systemd zfs-zed zfsutils-linux
Suggested packages:
  systemd-ui systemd-container nfs-kernel-server samba-common-bin
The following NEW packages will be installed:
  libnvpair1linux libuutil1linux libzfs2linux libzpool2linux zfs-zed zfsutils-linux
The following packages will be upgraded:
  libpam-systemd systemd
2 upgraded, 6 newly installed, 0 to remove and 49 not upgraded.
1 not fully installed or removed.
Need to get 2,656 kB/3,868 kB of archives.
After this operation, 4,337 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://deb.debian.org/debian stretch-updates/main amd64 libpam-systemd amd64 232-25+deb9u3 [188 kB]
Get:2 http://deb.debian.org/debian stretch-updates/main amd64 systemd amd64 232-25+deb9u3 [2,468 kB]
Fetched 2,656 kB in 2s (1,212 kB/s)
Reading changelogs... Done
(Reading database ... 178290 files and directories currently installed.)
Preparing to unpack .../0-libuutil1linux_0.7.8-pve1~bpo9_amd64.deb ...
Unpacking libuutil1linux (0.7.8-pve1~bpo9) ...
dpkg: error processing archive /tmp/apt-dpkg-install-dsFNTv/0-libuutil1linux_0.7.8-pve1~bpo9_amd64.deb (--unpack):
 trying to overwrite '/lib/libuutil.so.1.0.1', which is also in package libuutil1 0.6.5-pve9~jessie
Preparing to unpack .../1-libnvpair1linux_0.7.8-pve1~bpo9_amd64.deb ...
Unpacking libnvpair1linux (0.7.8-pve1~bpo9) ...
dpkg: error processing archive /tmp/apt-dpkg-install-dsFNTv/1-libnvpair1linux_0.7.8-pve1~bpo9_amd64.deb (--unpack):
 trying to overwrite '/lib/libnvpair.so.1.0.1', which is also in package libnvpair1 0.6.5-pve9~jessie
Preparing to unpack .../2-libzpool2linux_0.7.8-pve1~bpo9_amd64.deb ...
Unpacking libzpool2linux (0.7.8-pve1~bpo9) ...
dpkg: error processing archive /tmp/apt-dpkg-install-dsFNTv/2-libzpool2linux_0.7.8-pve1~bpo9_amd64.deb (--unpack):
 trying to overwrite '/lib/libzpool.so.2.0.0', which is also in package libzpool2 0.6.5-pve9~jessie
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../3-libzfs2linux_0.7.8-pve1~bpo9_amd64.deb ...
Unpacking libzfs2linux (0.7.8-pve1~bpo9) ...
dpkg: error processing archive /tmp/apt-dpkg-install-dsFNTv/3-libzfs2linux_0.7.8-pve1~bpo9_amd64.deb (--unpack):
 trying to overwrite '/lib/libzfs.so.2.0.0', which is also in package libzfs2 0.6.5-pve9~jessie
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../4-zfsutils-linux_0.7.8-pve1~bpo9_amd64.deb ...
Unpacking zfsutils-linux (0.7.8-pve1~bpo9) ...
dpkg: error processing archive /tmp/apt-dpkg-install-dsFNTv/4-zfsutils-linux_0.7.8-pve1~bpo9_amd64.deb (--unpack):
 trying to overwrite '/etc/default/zfs', which is also in package zfsutils 0.6.5-pve9~jessie
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../5-libpam-systemd_232-25+deb9u3_amd64.deb ...
Unpacking libpam-systemd:amd64 (232-25+deb9u3) over (232-25+deb9u2) ...
Preparing to unpack .../6-systemd_232-25+deb9u3_amd64.deb ...
Unpacking systemd (232-25+deb9u3) over (232-25+deb9u2) ...
Preparing to unpack .../7-zfs-zed_0.7.8-pve1~bpo9_amd64.deb ...
Unpacking zfs-zed (0.7.8-pve1~bpo9) ...
dpkg: error processing archive /tmp/apt-dpkg-install-dsFNTv/7-zfs-zed_0.7.8-pve1~bpo9_amd64.deb (--unpack):
 trying to overwrite '/etc/zfs/zed.d/zed-functions.sh', which is also in package zfsutils 0.6.5-pve9~jessie
Errors were encountered while processing:
 /tmp/apt-dpkg-install-dsFNTv/0-libuutil1linux_0.7.8-pve1~bpo9_amd64.deb
 /tmp/apt-dpkg-install-dsFNTv/1-libnvpair1linux_0.7.8-pve1~bpo9_amd64.deb
 /tmp/apt-dpkg-install-dsFNTv/2-libzpool2linux_0.7.8-pve1~bpo9_amd64.deb
 /tmp/apt-dpkg-install-dsFNTv/3-libzfs2linux_0.7.8-pve1~bpo9_amd64.deb
 /tmp/apt-dpkg-install-dsFNTv/4-zfsutils-linux_0.7.8-pve1~bpo9_amd64.deb
 /tmp/apt-dpkg-install-dsFNTv/7-zfs-zed_0.7.8-pve1~bpo9_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
« آخرین ویرایش: 23 اردیبهشت 1397، 02:34 ب‌ظ توسط tahamtan »