انجمن‌های فارسی اوبونتو

کمک و پشتیبانی => نرم‌افزارهای اینترنتی => نویسنده: nzasali در 15 تیر 1398، 11:50 ق‌ظ

عنوان: مشکل اپاچی وب سرور (برای وردپرس لوکال هاست) بعد از خاموش روشن کردن مجدد لپ تاپ
ارسال شده توسط: nzasali در 15 تیر 1398، 11:50 ق‌ظ
سلام
من اوبوتتو ۱۸.۰۴ روی لپ تاپم دارم و برای وارد شدن به محیط وردپرس به جای نصب برنامه لمپ از دستورات ترمینال برای نصب phpmyadmin, mysql, apache2 استقاده کردم
بار اول بدون مشکل نصب شد و محیط وردپرس اومد بالا ولی دیتابیسی نساختم بار دوم ارور داد
[● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset:
  Drop-In: /lib/systemd/system/apache2.service.d
           └─apache2-systemd.conf
   Active: failed (Result: exit-code) since Sat 2019-07-06 10:49:21 +0430; 47min
  Process: 1065 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILU

Jul 06 10:49:21 nazanin apachectl[1065]: AH00558: apache2: Could not reliably de
Jul 06 10:49:21 nazanin apachectl[1065]: (98)Address already in use: AH00072: ma
Jul 06 10:49:21 nazanin apachectl[1065]: (98)Address already in use: AH00072: ma
Jul 06 10:49:21 nazanin apachectl[1065]: no listening sockets available, shuttin
Jul 06 10:49:21 nazanin apachectl[1065]: AH00015: Unable to open logs
Jul 06 10:49:21 nazanin apachectl[1065]: Action 'start' failed.
Jul 06 10:49:21 nazanin apachectl[1065]: The Apache error log may have more info
Jul 06 10:49:21 nazanin systemd[1]: apache2.service: Control process exited, cod
Jul 06 10:49:21 nazanin systemd[1]: apache2.service: Failed with result 'exit-co
Jul 06 10:49:21 nazanin systemd[1]: Failed to start The Apache HTTP Server.

که درست کردم با سرچ و دوباره محیط وردپرس بالا اومد و دیتابیسی ساختم و پست گذاشتم و ...
دفعه بعد دوباره بالا نیومد و همین ارور در ترمینال برای sudo systemctl status apache2
اومد که با سرچ هم درست نشد و بردم فرد دیگه برام درست کرد و یه دیتابیس جدید ساخت و واردش شد حتی بعد از ری استارت سیستم باز هم بالا اومد ولی بعدا وقتی خودم امتحان کردم دوباره با زدن ادرس localhost/wordpress به صفحه ی
404 not found
nginx/1.14.0(ubuntu)
برخوردم و در ترمینال نیز همین ارور دوباره پیدا شد
عنوان: پاسخ : مشکل اپاچی وب سرور (برای وردپرس لوکال هاست) بعد از خاموش روشن کردن مجدد لپ تاپ
ارسال شده توسط: nixoeen در 15 تیر 1398، 04:32 ب‌ظ
دو تا وب‌سرور نصب کردید. یکی Nginx و یکی Apache. یا باید یکی رو پاک کنید یا اینکه تنظیماتشون رو تغییر بدید که هر کدوم روی پورت‌های متفاوتی اجرا بشن یا اینکه تنظیم کنید که فقط یکی از اون‌ها اجرا باشه و هر دو همزمان اجرا نشن.