انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

اوبونتو ۲۰.۰۴ منتشر شد.
انتظار می‌ره همهٔ اعضا هرچه زودتر به این نگارش ارتقا پیدا کنند. همهٔ پاسخ‌ها از این به بعد، بر پایهٔ اوبونتو ۲۰.۰۴ خواهد بود.

نویسنده موضوع: دیکشنری MDic منتشر شد...  (دفعات بازدید: 38208 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین sun

  • Full Member
  • *
  • ارسال: 124
  • جنسیت : پسر
  • لینوکس یعنی دنیای ندانسته ها
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #45 : 19 دی 1387، 11:17 ب‌ظ »
این   MDicConv نصب نمیشه من اول  زدم  sudo ./configureو این ارور رو داد (این آخرش است)

ppending configuration tag "F77" to libtool
checking for sqlite3_open in -lsqlite3... no
checking sqlite3.h usability... no
checking sqlite3.h presence... no
checking for sqlite3.h... no
configure: error: you need SQlite3 Develoment pakage to use this
حالا باید چی کار کرد
به امید روزی که آزادی را درک کنیم؟

آفلاین سعید رسولی

  • ilius, saeedgnu
  • عضو کاربران ایرانی اوبونتو
  • *
  • ارسال: 1534
  • جنسیت : پسر
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #46 : 20 دی 1387، 12:51 ق‌ظ »
این   MDicConv نصب نمیشه من اول  زدم  sudo ./configureو این ارور رو داد (این آخرش است)

ppending configuration tag "F77" to libtool
checking for sqlite3_open in -lsqlite3... no
checking sqlite3.h usability... no
checking sqlite3.h presence... no
checking for sqlite3.h... no
configure: error: you need SQlite3 Develoment pakage to use this
حالا باید چی کار کرد
از خط آخرش معلومه دیگه:
configure: error: you need SQlite3 Develoment pakage to use this
باید پکیج sqlite3-dev رو نصب کنید.
ولی پیشنهاد می‌کنم PyGlossary رو دانلود کنید، هم دردسر کامپایل نداره(پکیج deb داره و راحت) هم گرافیکی هست. از شانس شما ospdev.net هم نمیاد بالا. براتون آپلود کردم.

آفلاین کنجکاو!

  • High Sr. Member
  • *
  • ارسال: 580
  • جنسیت : پسر
  • الکترونیک + برنامه نویسی + لینوکس
    • یک کنجکاو بلاگ!
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #47 : 20 دی 1387، 11:29 ق‌ظ »
من یادمه که با pyglossary در تبدیل دیشکنری های بابیلون مشکل داشتم!
البته الان یادم نیست!
«پشتکار»«پشتکار»«پشتکار»

آفلاین سعید رسولی

  • ilius, saeedgnu
  • عضو کاربران ایرانی اوبونتو
  • *
  • ارسال: 1534
  • جنسیت : پسر
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #48 : 20 دی 1387، 05:59 ب‌ظ »
من یادمه که با pyglossary در تبدیل دیشکنری های بابیلون مشکل داشتم!
البته الان یادم نیست!
با کدوم ورژنش؟ چه مشکلی داشتید؟
الآن هم با این ورژنش یه تستی بکنید ضرر نداره.

آفلاین sun

  • Full Member
  • *
  • ارسال: 124
  • جنسیت : پسر
  • لینوکس یعنی دنیای ندانسته ها
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #49 : 21 دی 1387، 12:02 ق‌ظ »
این   MDicConv نصب نمیشه من اول  زدم  sudo ./configureو این ارور رو داد (این آخرش است)

ppending configuration tag "F77" to libtool
checking for sqlite3_open in -lsqlite3... no
checking sqlite3.h usability... no
checking sqlite3.h presence... no
checking for sqlite3.h... no
configure: error: you need SQlite3 Develoment pakage to use this
حالا باید چی کار کرد
از خط آخرش معلومه دیگه:
configure: error: you need SQlite3 Develoment pakage to use this
باید پکیج sqlite3-dev رو نصب کنید.
ولی پیشنهاد می‌کنم PyGlossary رو دانلود کنید، هم دردسر کامپایل نداره(پکیج deb داره و راحت) هم گرافیکی هست. از شانس شما ospdev.net هم نمیاد بالا. براتون آپلود کردم.
از لطفتون خیلی ممنون اما نمی تونم با این بابیلون را به mdic تبدیل کنم میشه روش نصب MDicConv رو بنویسین یا بسته کامپایل شدش رو قرار بدین
به امید روزی که آزادی را درک کنیم؟

آفلاین سعید رسولی

  • ilius, saeedgnu
  • عضو کاربران ایرانی اوبونتو
  • *
  • ارسال: 1534
  • جنسیت : پسر
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #50 : 21 دی 1387، 03:00 ق‌ظ »
از لطفتون خیلی ممنون اما نمی تونم با این بابیلون را به mdic تبدیل کنم میشه روش نصب MDicConv رو بنویسین یا بسته کامپایل شدش رو قرار بدین
برای کامپایلش باید پیش‌نیازهاش رو نصب کنید(مثلاً همون sqlite3) البته پکیج dev شون(یعنی سورسشون) بعد کامپایل کنید.
به هر حال کامپایل شده‌ش رو پیوست کردم.
ولی ممنون میشم بگید مشکلتون با pyglossary چیه(با جزئیات و متن ارور یا اسکرین‌شات) تا شاید اصلاحش کنم.
« آخرین ویرایش: 21 دی 1387، 04:49 ق‌ظ توسط ilius »

آفلاین mtux

  • Sr. Member
  • *
  • ارسال: 450
  • جنسیت : پسر
    • Mgroup
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #51 : 21 دی 1387، 11:54 ق‌ظ »
این   MDicConv نصب نمیشه من اول  زدم  sudo ./configureو این ارور رو داد (این آخرش است)

ppending configuration tag "F77" to libtool
checking for sqlite3_open in -lsqlite3... no
checking sqlite3.h usability... no
checking sqlite3.h presence... no
checking for sqlite3.h... no
configure: error: you need SQlite3 Develoment pakage to use this
حالا باید چی کار کرد
از خط آخرش معلومه دیگه:
configure: error: you need SQlite3 Develoment pakage to use this
باید پکیج sqlite3-dev رو نصب کنید.
ولی پیشنهاد می‌کنم PyGlossary رو دانلود کنید، هم دردسر کامپایل نداره(پکیج deb داره و راحت) هم گرافیکی هست. از شانس شما ospdev.net هم نمیاد بالا. براتون آپلود کردم.
از لطفتون خیلی ممنون اما نمی تونم با این بابیلون را به mdic تبدیل کنم میشه روش نصب MDicConv رو بنویسین یا بسته کامپایل شدش رو قرار بدین

منم پیشنهاد میکنم از PyGlossary استفاده کنید.
اما برای کامپایل mdicconv هم:
./configure
make
sudo make install
Free Software Advocate and Developer
http://mtux.wordpress.com
My GNU Affero page: http://rate.affero.net/mtux

آفلاین sun

  • Full Member
  • *
  • ارسال: 124
  • جنسیت : پسر
  • لینوکس یعنی دنیای ندانسته ها
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #52 : 21 دی 1387، 11:51 ب‌ظ »
از لطفتون خیلی ممنون اما نمی تونم با این بابیلون را به mdic تبدیل کنم میشه روش نصب MDicConv رو بنویسین یا بسته کامپایل شدش رو قرار بدین
برای کامپایلش باید پیش‌نیازهاش رو نصب کنید(مثلاً همون sqlite3) البته پکیج dev شون(یعنی سورسشون) بعد کامپایل کنید.
به هر حال کامپایل شده‌ش رو پیوست کردم.
ولی ممنون میشم بگید مشکلتون با pyglossary چیه(با جزئیات و متن ارور یا اسکرین‌شات) تا شاید اصلاحش کنم.
Error console:
Traceback (most recent call last):
  File "/usr/bin/../share/pyglossary/src/interface.py", line 378, in convert_clicked
    self.glos.write(oPath, format=format)
  File "/usr/share/pyglossary/src/glossary.py", line 256, in write
    exec('self.write%s(filename=filename)'%format)
  File "<string>", line 1, in <module>
  File "/usr/share/pyglossary/src/glossary.py", line 1727, in writeMdic
    con.execute(sqlLines[:-1])
sqlite3.OperationalError: unrecognized token: "'Acces Control List(s"

موفق باشید.
به امید روزی که آزادی را درک کنیم؟

آفلاین سعید رسولی

  • ilius, saeedgnu
  • عضو کاربران ایرانی اوبونتو
  • *
  • ارسال: 1534
  • جنسیت : پسر
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #53 : 22 دی 1387، 05:43 ق‌ظ »
Error console:
Traceback (most recent call last):
  File "/usr/bin/../share/pyglossary/src/interface.py", line 378, in convert_clicked
    self.glos.write(oPath, format=format)
  File "/usr/share/pyglossary/src/glossary.py", line 256, in write
    exec('self.write%s(filename=filename)'%format)
  File "<string>", line 1, in <module>
  File "/usr/share/pyglossary/src/glossary.py", line 1727, in writeMdic
    con.execute(sqlLines[i][:-1])
sqlite3.OperationalError: unrecognized token: "'Acces Control List(s"
موفق باشید.
ممنون. اصلاح شد. لطفاً نسخهٔ جدید رو دانلود کنید و دوباره امتحان کنید.

آفلاین پیام ابراهیمی

  • High Hero Member
  • *
  • ارسال: 1123
  • جنسیت : پسر
    • پلت ولگ
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #54 : 24 دی 1387، 01:25 ب‌ظ »
من از pyglossary استفاده کردم و تونستم ۲ glossary رو که از سایت بابیلون دانلود کرده بودم رو تبدیل کنم. مشکل اینه که glossary های تبدیل شده کار نمیکنن.
مثلا برای کلمه ی default مینویسه:

Default:
Default

برای نصب mdicconv هم ارور زیر رو میده:
make: *** No rule to make target `all'.  Stop.
« آخرین ویرایش: 24 دی 1387، 01:50 ب‌ظ توسط پیام »
http://www.palatvalg.com اینم وبلاگ جدید منه...

آفلاین سعید رسولی

  • ilius, saeedgnu
  • عضو کاربران ایرانی اوبونتو
  • *
  • ارسال: 1534
  • جنسیت : پسر
پاسخ به: پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #55 : 24 دی 1387، 03:27 ب‌ظ »
من از pyglossary استفاده کردم و تونستم ۲ glossary رو که از سایت بابیلون دانلود کرده بودم رو تبدیل کنم. مشکل اینه که glossary های تبدیل شده کار نمیکنن.
مثلا برای کلمه ی default مینویسه:

Default:
Default

برای نصب mdicconv هم ارور زیر رو میده:
make: *** No rule to make target `all'.  Stop.
اون دیتابیس bgl رو دوباره با pyglossary تبدیلش کنید به tabfile بعد با یه ادیتور بازش کنید ببینید توش چیه (یا اینکه همون bgl رو توی تب DB Editor باز کنید)
می‌تونید همون فایل m2 رو هم با sqlitebrowser باز کنید ببینید توش چیه. sqlitebrowser برای اوبونتو هاردی:
http://packages.ubuntu.com/hardy/i386/sqlitebrowser/download

آفلاین mtux

  • Sr. Member
  • *
  • ارسال: 450
  • جنسیت : پسر
    • Mgroup
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #56 : 24 دی 1387، 06:46 ب‌ظ »
من از pyglossary استفاده کردم و تونستم ۲ glossary رو که از سایت بابیلون دانلود کرده بودم رو تبدیل کنم. مشکل اینه که glossary های تبدیل شده کار نمیکنن.
مثلا برای کلمه ی default مینویسه:

Default:
Default

برای نصب mdicconv هم ارور زیر رو میده:
make: *** No rule to make target `all'.  Stop.

برای نصب mdicconv هم اول باید ./configure رو اجرا کنید! بعد make رو!
و البته! همه‌ی اینا رو باید داخل پوشه‌ی اصلی سورس اجرا کنید!

توی فایل INSTALL فکر کنم توضیحات کاملتری داشت ;)
Free Software Advocate and Developer
http://mtux.wordpress.com
My GNU Affero page: http://rate.affero.net/mtux

آفلاین پیام ابراهیمی

  • High Hero Member
  • *
  • ارسال: 1123
  • جنسیت : پسر
    • پلت ولگ
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #57 : 24 دی 1387، 07:22 ب‌ظ »
من از pyglossary استفاده کردم و تونستم ۲ glossary رو که از سایت بابیلون دانلود کرده بودم رو تبدیل کنم. مشکل اینه که glossary های تبدیل شده کار نمیکنن.
مثلا برای کلمه ی default مینویسه:

Default:
Default

برای نصب mdicconv هم ارور زیر رو میده:
make: *** No rule to make target `all'.  Stop.

یرای نصب mdicconv هم اول باید ./configure رو اجرا کنید! بعد make رو!
و البته! همه‌ی اینا رو باید داخل پوشه‌ی اصلی سورس اجرا کنید!

توی فایل INSTALL فکر کنم توضیحات کاملتری داشت ;)

خوب منم دقیقا همین کار رو کردم اما همون ارور رو داد! کلا من تو این ۲ ماهی که دارم اوبونتو کار می کنم هیچ وقت نتونستم بعد از configure دستور make رو اجرا کنم. همیشه همین ارور رو میده!
« آخرین ویرایش: 24 دی 1387، 07:36 ب‌ظ توسط پیام »
http://www.palatvalg.com اینم وبلاگ جدید منه...

آفلاین mtux

  • Sr. Member
  • *
  • ارسال: 450
  • جنسیت : پسر
    • Mgroup
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #58 : 24 دی 1387، 07:57 ب‌ظ »
من از pyglossary استفاده کردم و تونستم ۲ glossary رو که از سایت بابیلون دانلود کرده بودم رو تبدیل کنم. مشکل اینه که glossary های تبدیل شده کار نمیکنن.
مثلا برای کلمه ی default مینویسه:

Default:
Default

برای نصب mdicconv هم ارور زیر رو میده:
make: *** No rule to make target `all'.  Stop.

یرای نصب mdicconv هم اول باید ./configure رو اجرا کنید! بعد make رو!
و البته! همه‌ی اینا رو باید داخل پوشه‌ی اصلی سورس اجرا کنید!

توی فایل INSTALL فکر کنم توضیحات کاملتری داشت ;)

خوب منم دقیقا همین کار رو کردم اما همون ارور رو داد! کلا من تو این ۲ ماهی که دارم اوبونتو کار می کنم هیچ وقت نتونستم بعد از configure دستور make رو اجرا کنم. همیشه همین ارور رو میده!

پس مشخص میشه که اجرای configure موفقیت آمیز نبوده!
خروجی رو نگاه کن! ۱۰۰٪ گفته که فلان چیز کمه!

اگر درست باشه، آخرین خروجی‌هاش باید
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating config.h
config.status: executing depfiles commands
یا یه چی تو همین مایه‌ها باشه! که بگه که فایل Makefile رو ایجاد کرده!
چون دستور make نیاز به این فایل داره، برای کامپایل کردن!
Free Software Advocate and Developer
http://mtux.wordpress.com
My GNU Affero page: http://rate.affero.net/mtux

آفلاین بهزادubuntu

  • Sr. Member
  • *
  • ارسال: 471
پاسخ به: دیکشنری MDic منتشر شد...
« پاسخ #59 : 24 دی 1387، 08:42 ب‌ظ »
سلام من خیلی دنبال اینها گشتم ولی پیدا نکردم
عربی به فارسی
روسی به فارسی
فرانسه به فارسی
ممنون از زحمتهاتون  ;)
کتيبه سازمان ملل کوروش کبير
خداوند کشور را از دشمن خشکسالی و دروغ محفوظ دارد

برنامه حسابداری