انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید


 خبرها، اتفاقات و تصاویر مربوط به مربوط به جشن انتشار را با هشتگ ufest1804 در شبکه‌های اجتماعی دنبال کنید

نویسنده موضوع: درخواست راهنمایی در نصب lamp  (دفعات بازدید: 57 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین ali556583.556583

  • Jr. Member
  • *
  • ارسال: 41
  • جنسیت : پسر
درخواست راهنمایی در نصب lamp
« : 19 آبان 1397، 09:51 ب‌ظ »
درود
من ی راهنمایی میخواستم برای این اموزش:

https://gnuland.net/tutorials/lamp.html

موقع اجرای این دستور:

apt-list "php-*"
این رو میده:
apt-list "php-*"
apt-list: command not found

آفلاین Sosha

  • High Sr. Member
  • *
  • ارسال: 681
  • جنسیت : پسر
  • Only Ubuntu <3
    • نوشته های یک دوستدار گنو
پاسخ : درخواست راهنمایی در نصب lamp
« پاسخ #1 : 19 آبان 1397، 10:47 ب‌ظ »
خوشحالم که اون آموزش بکارت اومده اما فکر می‌کنم اون تیکش بد بیان شده

شما توی ترمینالتون apt list php- وارد کنید و ۲تا دکمه tab پشت سر هم بزنید تا لیستی از Extensions ها رو ببینید. بعد هر کدوم رو خواستید اسمش رو کپی کنید و نصب کنید. اگر نمی‌دونید دستور نصب چیه: sudo apt install folanجای folan هر چی نیاز داشتی قرار بده.
« آخرین ویرایش: 19 آبان 1397، 10:49 ب‌ظ توسط Sosha »
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش برو خدا رو شکر کن که با دمپایی نیومدم سراغت!

آفلاین ali556583.556583

  • Jr. Member
  • *
  • ارسال: 41
  • جنسیت : پسر
پاسخ : درخواست راهنمایی در نصب lamp
« پاسخ #2 : 19 آبان 1397، 11:08 ب‌ظ »
این کد حله:

apt list php-
باز اخرش ارور داد:

sudo apt install php-mysql
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  ant ant-optional antlr3 aspectj bnd bubblewrap clang default-jdk
  default-jdk-doc default-jdk-headless devhelp-common elfutils exuberant-ctags
  flatpak flatpak-builder gir1.2-dazzle-1.0 gir1.2-flatpak-1.0 gir1.2-ggit-1.0
  gir1.2-template-1.0 intltool java-wrappers javahelp2 junit junit-doc junit4
  junit4-doc libactivation-java libantlr-java libantlr3-runtime-java
  libaopalliance-java libapache-pom-java libargs4j-java libasm-java libasm1
  libasm4-java libaspectj-java libatinject-jsr330-api-java
  libavalon-framework-java libbcel-java libbeansbinding-java libbindex-java
  libbsh-java libbytelist-java libcdi-api-java libcglib-java libcodemodel-java
  libcodesize-java libcommons-beanutils-java libcommons-cli-java
  libcommons-codec-java libcommons-collections3-java libcommons-compress-java
  libcommons-digester-java libcommons-io-java libcommons-lang-java
  libcommons-lang3-java libcommons-logging-java libcommons-net-java
  libcommons-parent-java libdevhelp-3-5 libdom4j-java libdtd-parser-java
  libeclipselink-java libequinox-osgi-java libexcalibur-logkit-java
  libfastinfoset-java libfelix-framework-java libfelix-gogo-runtime-java
  libfelix-main-java libfelix-osgi-obr-java libfelix-resolver-java libflatpak0
  libfreemarker-java libgeronimo-annotation-1.3-spec-java
  libgeronimo-interceptor-3.0-spec-java
  libgeronimo-j2ee-connector-1.5-spec-java libgeronimo-jms-1.1-spec-java
  libgeronimo-jta-1.1-spec-java libgeronimo-validation-1.1-spec-java
  libgit2-26 libgit2-glib-1.0-0 libglib2.0-dev libglib2.0-dev-bin
  libguava-java libguice-java libhamcrest-java libhamcrest-java-doc
  libhawtjni-runtime-java libhtml5parser-java libhttpclient-java
  libhttpcore-java libice-dev libicu4j-4.4-java libini4j-java libisorelax-java
  libistack-commons-java libjansi-java libjansi-native-java libjavaewah-java
  libjaxb-api-java libjaxb-java libjaxen-java libjaxp1.3-java libjcodings-java
  libjcommander-java libjemmy2-java libjgit-java libjna-java libjna-jni
  libjna-platform-java libjnlp-servlet-java libjoda-time-java
  libjpa-2.1-spec-java libjsch-agent-proxy-java libjsch-java
  libjson-simple-java libjsonp-java libjsonrpc-glib-1.0-1 libjsr305-java
  libjsr311-api-java libjvyamlb-java libjzlib-java libkxml2-java
  liblog4j1.2-java liblucene3-contrib-java liblucene3-java libmail-java
  libmaven-file-management-java libmaven-parent-java libmaven-resolver-java
  libmaven-shared-io-java libmaven-shared-utils-java libmaven3-core-java
  libmsv-java libmysql-java libnb-absolutelayout-java libnb-javaparser-java
  libnb-org-openide-util-java libnb-org-openide-util-lookup-java
  libosgi-annotation-java libosgi-compendium-java libosgi-core-java
  libostree-1-1 libparanamer-java libpcre16-3 libpcre3-dev libpcre32-3
  libpcrecpp0v5 libpicocontainer-java libplexus-archiver-java
  libplexus-cipher-java libplexus-classworlds-java
  libplexus-component-annotations-java libplexus-interpolation-java
  libplexus-io-java libplexus-sec-dispatcher-java libplexus-utils-java
  libplexus-utils2-java libpostgresql-jdbc-java libpthread-stubs0-dev
  libregexp-java librelaxng-datatype-java librngom-java libsdo-api-java
  libsequence-library-java libserf-1-1 libservlet3.1-java
  libsimple-validation-java libsisu-guice-java libsisu-inject-java
  libsisu-ioc-java libsisu-plexus-java libslf4j-java libsm-dev libsnappy-java
  libsnappy-jni libsqljet-java libstax-ex-java libstreambuffer-java
  libstringtemplate-java libstringtemplate4-java libsvn-java libsvn1
  libsvnclientadapter-java libsvnkit-java libswing-layout-java libswingx-java
  libtemplate-glib-1.0-0 libtemplate-glib-common libtrilead-ssh2-java
  libtxw2-java libvala-0.40-0 libvala-0.40-dev libwagon-provider-api-java
  libws-commons-util-java libx11-dev libx11-doc libxalan2-java libxau-dev
  libxcb1-dev libxdmcp-dev libxerces2-java libxml-commons-external-java
  libxml-commons-resolver1.1-java libxsom-java libxt-dev libxz-java
  libyaml-snake-java meson ninja-build openjdk-11-doc openjdk-11-jdk
  openjdk-11-jdk-headless ostree pkg-config python3-bs4 python3-distutils
  python3-html5lib python3-jedi python3-lib2to3 python3-lxml python3-parso
  python3-webencodings sysprof testng valac-0.40-vapi valgrind
  x11proto-core-dev x11proto-dev xdg-desktop-portal xdg-desktop-portal-gtk
  xorg-sgml-doctools xtrans-dev zlib1g-dev
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  php7.2-mysql
The following NEW packages will be installed:
  php-mysql php7.2-mysql
0 upgraded, 2 newly installed, 0 to remove and 31 not upgraded.
2 not fully installed or removed.
Need to get 120 kB of archives.
After this operation, 461 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ir.archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-mysql amd64 7.2.10-0ubuntu0.18.04.1 [118 kB]
Get:2 http://ir.archive.ubuntu.com/ubuntu bionic/main amd64 php-mysql all 1:7.2+60ubuntu1 [2,004 B]
Fetched 120 kB in 1s (117 kB/s)     
Selecting previously unselected package php7.2-mysql.
(Reading database ... 232796 files and directories currently installed.)
Preparing to unpack .../php7.2-mysql_7.2.10-0ubuntu0.18.04.1_amd64.deb ...
Unpacking php7.2-mysql (7.2.10-0ubuntu0.18.04.1) ...
Selecting previously unselected package php-mysql.
Preparing to unpack .../php-mysql_1%3a7.2+60ubuntu1_all.deb ...
Unpacking php-mysql (1:7.2+60ubuntu1) ...
Setting up php7.2-mysql (7.2.10-0ubuntu0.18.04.1) ...

Creating config file /etc/php/7.2/mods-available/mysqlnd.ini with new version

Creating config file /etc/php/7.2/mods-available/mysqli.ini with new version

Creating config file /etc/php/7.2/mods-available/pdo_mysql.ini with new version
Setting up grub-efi-amd64-signed (1.93.8+2.02-2ubuntu8.7) ...
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.
dpkg: error processing package grub-efi-amd64-signed (--configure):
 installed grub-efi-amd64-signed package post-installation script subprocess returned error exit status 1
Setting up php-mysql (1:7.2+60ubuntu1) ...
dpkg: dependency problems prevent configuration of shim-signed:
 shim-signed depends on grub-efi-amd64-signed; however:
  Package grub-efi-amd64-signed is not configured yet.

dpkg: error processing package shim-signed (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 grub-efi-amd64-signed
 shim-signed
E: Sub-process /usr/bin/dpkg returned an error code (1)