انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

نویسنده موضوع: مشکل بعد از نصب کارت گرافیک انویدیا در slackware  (دفعات بازدید: 155 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین patri

  • Jr. Member
  • *
  • ارسال: 53
  • جنسیت : پسر
با سلام
من بعد از نصب کارت گرافیک به صورت قدم به قدم و از روی راهنمای زیر

https://docs.slackware.com/howtos:hardware:proprietary_graphics_drivers

بعد از نصب و اجرای دستور startx نمی تونم وارد محیط گرافیکی بشم و بهم پیام خطایی که در عکس هست رو میده. لطفا اگه کسی تجربه داره کمکم کنه! خیلی توی اینترنت سرچ کردم اما جوابی پیدا نکردم و اگه لطفا با جزئیات راهنماییم کنید(دقیقا دستوراتی که باید بزنم یا هر اطلاعاتی که بتونه کمکم کنه) ممنون میشم .
پیام خطا در عکس زیر
http://www.pic98.ir/upload/7czd_photo_2017-03-29_03-34-30.jpg
این جهان زندان و ما زندانیان * بر شکن زندان و خود را وارهان

آنلاین M!lad

  • Hero Member
  • *
  • ارسال: 958
  • YPSD
پاسخ : مشکل بعد از نصب کارت گرافیک انویدیا در slackware
« پاسخ #1 : 09 فروردین 1396، 04:29 ق‌ظ »
محتویات فایل لاگی که گفته رو چک کن شاید متوجه بشی مشکل چیه نشد بزار اینجا ببینیم چی میگه...
/var/log/Xorg.0.log
تا جایی که یادمه درایور آزاد اتومات نصب میشه بدون درایور انحصاری چک کردی ببینی مشکلی داره یا نه؟
...

آفلاین patri

  • Jr. Member
  • *
  • ارسال: 53
  • جنسیت : پسر
پاسخ : مشکل بعد از نصب کارت گرافیک انویدیا در slackware
« پاسخ #2 : 09 فروردین 1396، 01:22 ب‌ظ »
میشه بگین خط اول خطا معنیش چیه ؟!
xauth: file /root/.serverauth.1711 does not existدرایور آزاد نصب میشه اما متاسفانه با لپ تاپ من سازگار نیست و فن لپ تاپم روشن میمونه دائم!
اینم محتویات فایل var/log/Xorg.0.log
[  6066.678]
X.Org X Server 1.18.3
Release Date: 2016-04-04
[  6066.678] X Protocol Version 11, Revision 0
[  6066.678] Build Operating System: Slackware 14.2 Slackware Linux Project
[  6066.678] Current Operating System: Linux lifetype 4.4.14 #2 SMP Fri Jun 24 13:38:27 CDT 2016 x86_64
[  6066.678] Kernel command line: BOOT_IMAGE=Linux ro root=807 vt.default_utf8=0
[  6066.678] Build Date: 15 April 2016  11:05:21AM
[  6066.678] 
[  6066.679] Current version of pixman: 0.34.0
[  6066.679] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[  6066.679] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  6066.679] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 29 02:06:57 2017
[  6066.680] (==) Using config file: "/etc/X11/xorg.conf"
[  6066.680] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  6066.680] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  6066.680] (==) ServerLayout "Layout0"
[  6066.680] (**) |-->Screen "Screen0" (0)
[  6066.680] (**) |   |-->Monitor "Monitor0"
[  6066.681] (**) |   |-->Device "Device0"
[  6066.681] (**) |-->Screen "Screen0 (1)" (1)
[  6066.681] (**) |   |-->Monitor "Monitor0"
[  6066.681] (**) |   |-->Device "Device0 (1)"
[  6066.681] (**) |-->Input Device "Keyboard0"
[  6066.681] (**) |-->Input Device "Mouse0"
[  6066.681] (==) Automatically adding devices
[  6066.681] (==) Automatically enabling devices
[  6066.681] (==) Automatically adding GPU devices
[  6066.681] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  6066.681] (WW) The directory "/usr/share/fonts/local" does not exist.
[  6066.681] Entry deleted from font path.
[  6066.681] (WW) The directory "/usr/share/fonts/CID" does not exist.
[  6066.681] Entry deleted from font path.
[  6066.681] (**) FontPath set to:
/usr/lib64/X11/fonts/misc/:unscaled,
/usr/lib64/X11/fonts/100dpi/:unscaled,
/usr/lib64/X11/fonts/75dpi/:unscaled,
/usr/lib64/X11/fonts/misc/,
/usr/lib64/X11/fonts/Type1/,
/usr/lib64/X11/fonts/Speedo/,
/usr/lib64/X11/fonts/100dpi/,
/usr/lib64/X11/fonts/75dpi/,
/usr/lib64/X11/fonts/cyrillic/,
/usr/lib64/X11/fonts/TTF/,
/usr/share/fonts/TTF,
/usr/share/fonts/OTF,
/usr/share/fonts/Type1,
/usr/share/fonts/misc,
/usr/share/fonts/75dpi/:unscaled,
/usr/share/fonts/100dpi/:unscaled,
/usr/share/fonts/75dpi,
/usr/share/fonts/100dpi,
/usr/share/fonts/cyrillic
[  6066.681] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  6066.681] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  6066.681] (WW) Disabling Keyboard0
[  6066.681] (WW) Disabling Mouse0
[  6066.681] (II) Loader magic: 0x808c00
[  6066.681] (II) Module ABI versions:
[  6066.681] X.Org ANSI C Emulation: 0.4
[  6066.681] X.Org Video Driver: 20.0
[  6066.681] X.Org XInput driver : 22.1
[  6066.681] X.Org Server Extension : 9.0
[  6066.682] (II) xfree86: Adding drm device (/dev/dri/card1)
[  6066.682] (II) xfree86: Adding drm device (/dev/dri/card0)
[  6066.685] (--) PCI:*(0:0:2:0) 8086:0116:1028:050e rev 9, Mem @ 0xf1400000/4194304, 0xe0000000/268435456, I/O @ 0x00004000/64
[  6066.685] (--) PCI: (0:1:0:0) 10de:0df4:1028:050e rev 161, Mem @ 0xf0000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00003000/128, BIOS @ 0x????????/524288
[  6066.685] (II) Open ACPI successful (/var/run/acpid.socket)
[  6066.685] (II) LoadModule: "glx"
[  6066.685] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  6066.692] (II) Module glx: vendor="NVIDIA Corporation"
[  6066.692] compiled for 4.0.2, module version = 1.0.0
[  6066.692] Module class: X.Org Server Extension
[  6066.692] (II) NVIDIA GLX Module  375.39  Tue Jan 31 19:37:12 PST 2017
[  6066.692] (II) LoadModule: "nvidia"
[  6066.692] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[  6066.693] (II) Module nvidia: vendor="NVIDIA Corporation"
[  6066.693] compiled for 4.0.2, module version = 1.0.0
[  6066.693] Module class: X.Org Video Driver
[  6066.693] (II) NVIDIA dlloader X Driver  375.39  Tue Jan 31 19:13:22 PST 2017
[  6066.693] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  6066.693] (--) using VT number 7

[  6066.700] (II) Loading sub module "fb"
[  6066.700] (II) LoadModule: "fb"
[  6066.700] (II) Loading /usr/lib64/xorg/modules/libfb.so
[  6066.701] (II) Module fb: vendor="X.Org Foundation"
[  6066.701] compiled for 1.18.3, module version = 1.0.0
[  6066.701] ABI class: X.Org ANSI C Emulation, version 0.4
[  6066.701] (II) Loading sub module "wfb"
[  6066.701] (II) LoadModule: "wfb"
[  6066.702] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[  6066.703] (II) Module wfb: vendor="X.Org Foundation"
[  6066.703] compiled for 1.18.3, module version = 1.0.0
[  6066.703] ABI class: X.Org ANSI C Emulation, version 0.4
[  6066.703] (II) Loading sub module "ramdac"
[  6066.703] (II) LoadModule: "ramdac"
[  6066.703] (II) Module "ramdac" already built-in
[  6066.704] (EE) Screen 0 deleted because of no matching config section.
[  6066.704] (II) UnloadModule: "nvidia"
[  6066.704] (II) UnloadSubModule: "wfb"
[  6066.704] (II) UnloadSubModule: "fb"
[  6066.704] (EE) Device(s) detected, but none match those in the config file.
[  6066.704] (EE)
Fatal server error:
[  6066.704] (EE) no screens found(EE)
[  6066.704] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
 for help.
[  6066.704] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  6066.704] (EE)
[  6066.717] (EE) Server terminated with error (1). Closing log file.

اینم فایل xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 375.39  (buildmeister@swio-display-x86-rhel47-09)  Tue Jan 31 20:47:44 PST 2017


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    Screen      1  "Screen0 (1)" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/lib64/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/misc/"
    FontPath        "/usr/lib64/X11/fonts/Type1/"
    FontPath        "/usr/lib64/X11/fonts/Speedo/"
    FontPath        "/usr/lib64/X11/fonts/100dpi/"
    FontPath        "/usr/lib64/X11/fonts/75dpi/"
    FontPath        "/usr/lib64/X11/fonts/cyrillic/"
    FontPath        "/usr/lib64/X11/fonts/TTF/"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 540M"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device0 (1)"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 540M"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen0 (1)"
    Device         "Device0 (1)"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

« آخرین ویرایش: 09 فروردین 1396، 01:34 ب‌ظ توسط patri »
این جهان زندان و ما زندانیان * بر شکن زندان و خود را وارهان

آنلاین M!lad

  • Hero Member
  • *
  • ارسال: 958
  • YPSD
پاسخ : مشکل بعد از نصب کارت گرافیک انویدیا در slackware
« پاسخ #3 : 09 فروردین 1396، 05:12 ب‌ظ »
در ابتدا که یک یوز معمولی بساز با اون startx بزن.
توی لاگ به خطوطی که EE دارند توجه کن...

فایل xorg.conf رو که خودکار توسط Nvidia تولید شده رو حذف و تست کن ببین نتیجه چی میشه.

درباره خط اول اینجا رو بخون:

https://unix.stackexchange.com/questions/199160/what-are-serverauth-files-in-my-home-directory
...