انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

نویسنده موضوع: مشکل در اجرای دیکشنری longman  (دفعات بازدید: 431 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین Danial_Atash

  • Newbie
  • *
  • ارسال: 5
  • جنسیت : پسر
مشکل در اجرای دیکشنری longman
« : 17 شهریور 1395، 12:41 ب‌ظ »
دوستان من دیکشنری لانگمن رو روی اوبونتوی خودم نصب کردم اما موقعی که می‌خوام اجراش کنم هیچی وا نمی‌شه وقتی می‌رم تو پوشه‌ی محل نصب و دستور زیر رو تو ترمینال اجرا می‌کنم:
./run-ldoce5.sh
ارور زیر میاد:
./ldoce5-bin: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
که هر چی می‌خوام با apt بسته‌ی libgtk-x11 رو نصب کنم نمی‌شه.
کسی می‌تونه راهنماییم کنه؟

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 12158
  • جنسیت : پسر
  • Urahara Kiesuke
    • صفحهٔ ویکی
پاسخ : مشکل در اجرای دیکشنری longman
« پاسخ #1 : 18 شهریور 1395، 03:48 ب‌ظ »
باید بستهٔlibgtk2.0-0 رو نصب کنی.
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن

آفلاین K-FIVE

  • Jr. Member
  • *
  • ارسال: 92
  • جنسیت : پسر
پاسخ : مشکل در اجرای دیکشنری longman
« پاسخ #2 : 18 شهریور 1395، 10:46 ب‌ظ »
درود
داخل فایل img که داری خودش بسته مربوط به نصب در اوبونتو رو داره | همون رو اجرا کنی | اتومات خودش همه رو درست میکنه
البته صدا نداره و درست کردن صداش هم دردسر داشت ک م انجام ندادم

پیوست: تصویر اجرایی برنامه

آفلاین Danial_Atash

  • Newbie
  • *
  • ارسال: 5
  • جنسیت : پسر
پاسخ : مشکل در اجرای دیکشنری longman
« پاسخ #3 : 19 شهریور 1395، 12:44 ق‌ظ »
می‌خوام نصب کنم نمیشه یه عالمه dependency داره. چیکارشون کنم؟؟؟
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgtk2.0-dev : Depends: libglib2.0-dev (>= 2.27.3) but it is not installable
                 Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
                 Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
                 Depends: libatk1.0-dev (>= 1.29.2) but it is not installable
                 Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not installable
                 Depends: libxcursor-dev but it is not installable
                 Depends: libxcomposite-dev (>= 1:0.2.0-3) but it is not installable
E: Unable to correct problems, you have held broken packages.
[/pre]