انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

نویسنده موضوع: مشکل با نصب virtual box در اوبونتو 16.04  (دفعات بازدید: 1398 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین ha88an

  • Newbie
  • *
  • ارسال: 7
مشکل با نصب virtual box در اوبونتو 16.04
« : 21 خرداد 1395، 09:56 ب‌ظ »
سلام دوستان
من Virtual Box رو از سایت سازندش دانلود کردم از اونجایی ک نسخه اوبونتو من 16.04 هس و 64 بیتیه این نسخه رو دانلود کردم:
http://download.virtualbox.org/virtualbox/5.0.20/virtualbox-5.0_5.0.20-106931~Ubuntu~xenial_i386.deb
متاسفانه بعد از نصب کردن از طریق ترمینال اخطار میده بهم: ](*,)


تازه کار هستم دوستان  :P

آفلاین M!lad

  • Hero Member
  • *
  • ارسال: 957
  • YPSD
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #1 : 21 خرداد 1395، 10:15 ب‌ظ »
VirtualBox رو از مخازن خود اوبونتو نصب کنید: (نسخه 5.0.18‌ تو مخازن موجوده)
sudo apt install virtualbox
ضمن اینکه نسخه‌ای که دانلود کردید 32 بیتی هست، برنامه های 32بیتی رو سیستم‌عامل‌های 64بیتی قابل اجرا هستند ولی اگر اشتباه نکنم برخی از اونها یه Library خاص میخوان.
« آخرین ویرایش: 21 خرداد 1395، 10:18 ب‌ظ توسط M!lad »
...

آفلاین ha88an

  • Newbie
  • *
  • ارسال: 7
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #2 : 22 خرداد 1395، 12:27 ق‌ظ »
VirtualBox رو از مخازن خود اوبونتو نصب کنید: (نسخه 5.0.18‌ تو مخازن موجوده)
sudo apt install virtualbox
ضمن اینکه نسخه‌ای که دانلود کردید 32 بیتی هست، برنامه های 32بیتی رو سیستم‌عامل‌های 64بیتی قابل اجرا هستند ولی اگر اشتباه نکنم برخی از اونها یه Library خاص میخوان.

ممنون دوست عزیز ولی حالا با ارور زیر مواجه شدم

sudo apt install virtualbox
[sudo] password for hassan:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'virtualbox-5.0:i386' instead of 'virtualbox:i386'
virtualbox-5.0:i386 is already the newest version (5.0.20-106931~Ubuntu~xenial).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 teamviewer:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
                   Depends: libgcc1:i386 but it is not installable
                   Depends: libasound2:i386 but it is not installable
                   Depends: libexpat1:i386 but it is not installable
                   Depends: libfontconfig1:i386 but it is not installable
                   Depends: libfreetype6:i386 but it is not installable
                   Depends: libjpeg62:i386 but it is not installable
                   Depends: libpng12-0:i386 but it is not installable
                   Depends: libsm6:i386 but it is not installable
                   Depends: libxdamage1:i386 but it is not installable
                   Depends: libxext6:i386 but it is not installable
                   Depends: libxfixes3:i386 but it is not installable
                   Depends: libxinerama1:i386 but it is not installable
                   Depends: libxrandr2:i386 but it is not installable
                   Depends: libxrender1:i386 but it is not installable
                   Depends: libxtst6:i386 but it is not installable
                   Depends: zlib1g:i386 but it is not installable
 virtualbox-5.0:i386 : Depends: libc6:i386 (>= 2.15) but it is not installable
                       Depends: libcurl3:i386 (>= 7.16.2) but it is not installable
                       Depends: libdevmapper1.02.1:i386 (>= 2:1.02.97) but it is not installable
                       Depends: libgcc1:i386 (>= 1:4.2) but it is not installable
                       Depends: libgl1-mesa-glx:i386 but it is not installable or
                                libgl1:i386 but it is not installable
                       Depends: libpng12-0:i386 (>= 1.2.13-4) but it is not installable
                       Depends: libpython2.7:i386 (>= 2.7) but it is not installable
                       Depends: libqt4-opengl:i386 (>= 4:4.7.2) but it is not installable
                       Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not installable
                       Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not installable
                       Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not installable
                       Depends: libssl1.0.0:i386 (>= 1.0.0) but it is not installable
                       Depends: libstdc++6:i386 (>= 5.2) but it is not installable
                       Depends: libvpx3:i386 (>= 1.5.0) but it is not installable
                       Depends: libx11-6:i386 but it is not installable
                       Depends: libxcursor1:i386 (> 1.1.2) but it is not installable
                       Depends: libxext6:i386 but it is not installable
                       Depends: libxinerama1:i386 but it is not installable
                       Depends: libxml2:i386 (>= 2.7.4) but it is not installable
                       Depends: libxmu6:i386 but it is not installable
                       Depends: libxt6:i386 but it is not installable
                       Depends: zlib1g:i386 (>= 1:1.1.4) but it is not installable
                       Recommends: libasound2:i386 but it is not installable
                       Recommends: libpulse0:i386 but it is not installable
                       Recommends: libsdl-ttf2.0-0:i386 but it is not installable
                       Recommends: dkms:i386 but it is not installable
                       Recommends: linux-headers:i386 but it is not installable
                       Recommends: gcc:i386 but it is not installable
                       Recommends: make:i386 but it is not installable
                       Recommends: binutils:i386 but it is not installable
                       Recommends: pdf-viewer:i386 but it is not installable
                       Recommends: libgl1:i386 but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

آفلاین M!lad

  • Hero Member
  • *
  • ارسال: 957
  • YPSD
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #3 : 22 خرداد 1395، 09:47 ق‌ظ »
بزنید:

sudo apt-get autoremove --purge virtualbox
sudo apt-get install virtualbox

چون احتمالا برنامه‌هایی رو از خارج مخازن اصلی نصب کردید اینطور شده، دستورات بالا رو چک کنید ببینید حل میشه؟
...

آفلاین ha88an

  • Newbie
  • *
  • ارسال: 7
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #4 : 22 خرداد 1395، 01:23 ب‌ظ »
بزنید:

sudo apt-get autoremove --purge virtualbox
sudo apt-get install virtualbox

چون احتمالا برنامه‌هایی رو از خارج مخازن اصلی نصب کردید اینطور شده، دستورات بالا رو چک کنید ببینید حل میشه؟

اره خارج از مخزن خواستم نصب کنم ولی کامل پاکشون کردم قبلش
این دستورات جدید رو هم ک گفتید زدم ولی همچنان همون خطای دفعه قبل رو میده
sudo apt-get autoremove --purge virtualbox
[sudo] password for hassan:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'virtualbox-5.0:i386' instead of 'virtualbox:i386'
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 teamviewer:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
                   Depends: libgcc1:i386 but it is not installable
                   Depends: libasound2:i386 but it is not installable
                   Depends: libexpat1:i386 but it is not installable
                   Depends: libfontconfig1:i386 but it is not installable
                   Depends: libfreetype6:i386 but it is not installable
                   Depends: libjpeg62:i386 but it is not installable
                   Depends: libpng12-0:i386 but it is not installable
                   Depends: libsm6:i386 but it is not installable
                   Depends: libxdamage1:i386 but it is not installable
                   Depends: libxext6:i386 but it is not installable
                   Depends: libxfixes3:i386 but it is not installable
                   Depends: libxinerama1:i386 but it is not installable
                   Depends: libxrandr2:i386 but it is not installable
                   Depends: libxrender1:i386 but it is not installable
                   Depends: libxtst6:i386 but it is not installable
                   Depends: zlib1g:i386 but it is not installable
 virtualbox-5.0:i386 : Depends: libc6:i386 (>= 2.15) but it is not installable
                       Depends: libcurl3:i386 (>= 7.16.2) but it is not installable
                       Depends: libdevmapper1.02.1:i386 (>= 2:1.02.97) but it is not installable
                       Depends: libgcc1:i386 (>= 1:4.2) but it is not installable
                       Depends: libgl1-mesa-glx:i386 but it is not installable or
                                libgl1:i386 but it is not installable
                       Depends: libpng12-0:i386 (>= 1.2.13-4) but it is not installable
                       Depends: libpython2.7:i386 (>= 2.7) but it is not installable
                       Depends: libqt4-opengl:i386 (>= 4:4.7.2) but it is not installable
                       Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not installable
                       Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not installable
                       Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not installable
                       Depends: libssl1.0.0:i386 (>= 1.0.0) but it is not installable
                       Depends: libstdc++6:i386 (>= 5.2) but it is not installable
                       Depends: libvpx3:i386 (>= 1.5.0) but it is not installable
                       Depends: libx11-6:i386 but it is not installable
                       Depends: libxcursor1:i386 (> 1.1.2) but it is not installable
                       Depends: libxext6:i386 but it is not installable
                       Depends: libxinerama1:i386 but it is not installable
                       Depends: libxml2:i386 (>= 2.7.4) but it is not installable
                       Depends: libxmu6:i386 but it is not installable
                       Depends: libxt6:i386 but it is not installable
                       Depends: zlib1g:i386 (>= 1:1.1.4) but it is not installable
                       Recommends: libasound2:i386 but it is not installable
                       Recommends: libpulse0:i386 but it is not installable
                       Recommends: libsdl-ttf2.0-0:i386 but it is not installable
                       Recommends: dkms:i386 but it is not installable
                       Recommends: linux-headers:i386 but it is not installable
                       Recommends: gcc:i386 but it is not installable
                       Recommends: make:i386 but it is not installable
                       Recommends: binutils:i386 but it is not installable
                       Recommends: pdf-viewer:i386 but it is not installable
                       Recommends: libgl1:i386 but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
hassan@hassan-System-Product-Name:~$ sudo apt-get install virtualbox
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'virtualbox-5.0:i386' instead of 'virtualbox:i386'
virtualbox-5.0:i386 is already the newest version (5.0.20-106931~Ubuntu~xenial).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 teamviewer:i386 : Depends: libc6:i386 (>= 2.4) but it is not installable
                   Depends: libgcc1:i386 but it is not installable
                   Depends: libasound2:i386 but it is not installable
                   Depends: libexpat1:i386 but it is not installable
                   Depends: libfontconfig1:i386 but it is not installable
                   Depends: libfreetype6:i386 but it is not installable
                   Depends: libjpeg62:i386 but it is not installable
                   Depends: libpng12-0:i386 but it is not installable
                   Depends: libsm6:i386 but it is not installable
                   Depends: libxdamage1:i386 but it is not installable
                   Depends: libxext6:i386 but it is not installable
                   Depends: libxfixes3:i386 but it is not installable
                   Depends: libxinerama1:i386 but it is not installable
                   Depends: libxrandr2:i386 but it is not installable
                   Depends: libxrender1:i386 but it is not installable
                   Depends: libxtst6:i386 but it is not installable
                   Depends: zlib1g:i386 but it is not installable
 virtualbox-5.0:i386 : Depends: libc6:i386 (>= 2.15) but it is not installable
                       Depends: libcurl3:i386 (>= 7.16.2) but it is not installable
                       Depends: libdevmapper1.02.1:i386 (>= 2:1.02.97) but it is not installable
                       Depends: libgcc1:i386 (>= 1:4.2) but it is not installable
                       Depends: libgl1-mesa-glx:i386 but it is not installable or
                                libgl1:i386 but it is not installable
                       Depends: libpng12-0:i386 (>= 1.2.13-4) but it is not installable
                       Depends: libpython2.7:i386 (>= 2.7) but it is not installable
                       Depends: libqt4-opengl:i386 (>= 4:4.7.2) but it is not installable
                       Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not installable
                       Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not installable
                       Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not installable
                       Depends: libssl1.0.0:i386 (>= 1.0.0) but it is not installable
                       Depends: libstdc++6:i386 (>= 5.2) but it is not installable
                       Depends: libvpx3:i386 (>= 1.5.0) but it is not installable
                       Depends: libx11-6:i386 but it is not installable
                       Depends: libxcursor1:i386 (> 1.1.2) but it is not installable
                       Depends: libxext6:i386 but it is not installable
                       Depends: libxinerama1:i386 but it is not installable
                       Depends: libxml2:i386 (>= 2.7.4) but it is not installable
                       Depends: libxmu6:i386 but it is not installable
                       Depends: libxt6:i386 but it is not installable
                       Depends: zlib1g:i386 (>= 1:1.1.4) but it is not installable
                       Recommends: libasound2:i386 but it is not installable
                       Recommends: libpulse0:i386 but it is not installable
                       Recommends: libsdl-ttf2.0-0:i386 but it is not installable
                       Recommends: dkms:i386 but it is not installable
                       Recommends: linux-headers:i386 but it is not installable
                       Recommends: gcc:i386 but it is not installable
                       Recommends: make:i386 but it is not installable
                       Recommends: binutils:i386 but it is not installable
                       Recommends: pdf-viewer:i386 but it is not installable
                       Recommends: libgl1:i386 but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

دیگه کم کم دارم از خودم و اوبونتو ناامید میشم  ](*,) ](*,) ](*,)

آفلاین M!lad

  • Hero Member
  • *
  • ارسال: 957
  • YPSD
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #5 : 22 خرداد 1395، 03:14 ب‌ظ »
این راهنما رو مطالعه کنید:

https://askubuntu.com/questions/140246/how-do-i-resolve-unmet-dependencies-after-adding-a-ppa
...

آفلاین دانیال بهزادی

  • ناظر انجمن
  • *
  • ارسال: 12218
  • جنسیت : پسر
  • Urahara Kiesuke
    • صفحهٔ ویکی
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #6 : 23 خرداد 1395، 08:10 ق‌ظ »
می‌دونم جوابم پاک کردن صورت مسئله است. ولی چرا از gnome-boxes استفاده نمی‌کنی؟ خیلی بی‌دردسرتره!
اگه این ارسال بهت کمک کرد، دنبال دکمهٔ تشکر نگرد. به جاش تو هم به جامعهٔ آزادت کمک کن

آفلاین ha88an

  • Newbie
  • *
  • ارسال: 7
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #7 : 30 خرداد 1395، 06:50 ب‌ظ »
می‌دونم جوابم پاک کردن صورت مسئله است. ولی چرا از gnome-boxes استفاده نمی‌کنی؟ خیلی بی‌دردسرتره!

برای اندروید استادیو و جنی موشن نیاز دارم بهش

آفلاین K-FIVE

  • Jr. Member
  • *
  • ارسال: 92
  • جنسیت : پسر
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #8 : 18 شهریور 1395، 11:04 ب‌ظ »
5.0.20
رو در
16.04 LTS
نصب کردم البته 32 بیت مشکلی نداشت | نسخه تو عوض کن
مثلا دقیق همین نسخه رو | ویندزی ش | تو ویندوز نصب نشد


آفلاین AlirezaieS

  • Jr. Member
  • *
  • ارسال: 80
  • جنسیت : پسر
  • Pythonista
    • WebGo!
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #9 : 19 شهریور 1395، 09:19 ق‌ظ »
اول اینکه این نسخه از VirtualBox که شما سعی در نصبش داری،نسخه ۳۲ بیتی هست :)
پس اگر سیستم عاملت 64 بیتی هست یا نسخه 64 بیتی VirtualBox رو نصب کن یا با کد زیر امکان اجرای نرم افزار ها 32 بیتی رو فعال کن:
$ sudo dpkg --add-architecture i386
$ sudo apt update
دوم اینکه Dependencie ها نصب نیستن :(
پیشنهاد میکنم به جای دانلود پکیج،از توی مخازن نصب کنی \\:D/
$ sudo apt install virtualbox virtualbox-ext-pack
اگر به خاطر تحریم ها با نصبش مشکل داری از تور استفاده کن:
http://forum.ubuntu.ir/index.php/topic,86172.0.html
http://forum.ubuntu.ir/index.php?topic=111452.0
http://forum.ubuntu.ir/index.php?topic=96172.15

اگر خیلی اصرار داری که همون پکیج دانلودی رو نصب کنی دستور زیر رو بزن ببین مشکلت حل میشه؟
$ sudo apt purge virtualbox*
$ sudo apt autoremove
$ sudo apt install -f
« آخرین ویرایش: 19 شهریور 1395، 09:27 ق‌ظ توسط AlirezaieS »
01010011 01100001 01100100 01100101 01100111 01101000

آفلاین computer_soft

  • Newbie
  • *
  • ارسال: 9
  • جنسیت : دختر
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #10 : 20 شهریور 1395، 03:37 ق‌ظ »
VirtualBox رو از مخازن خود اوبونتو نصب کنید: (نسخه 5.0.18‌ تو مخازن موجوده)
sudo apt install virtualbox
ضمن اینکه نسخه‌ای که دانلود کردید 32 بیتی هست، برنامه های 32بیتی رو سیستم‌عامل‌های 64بیتی قابل اجرا هستند ولی اگر اشتباه نکنم برخی از اونها یه Library خاص میخوان.


درود بر شماُ این مخزن که میگین چیه؟؟ من تازه اوبونتو نصب کردم میخوام virtual box نصب کنم روش مشکل برخوردم.

آفلاین AlirezaieS

  • Jr. Member
  • *
  • ارسال: 80
  • جنسیت : پسر
  • Pythonista
    • WebGo!
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #11 : 20 شهریور 1395، 02:52 ب‌ظ »
مخازن یا Repository ها مخازنی هستن که نرم افزار های تست شده و مطمئن رو شامل میشن.
هر توزیع گنو/لینوکسی مخارن خودش رو داره که نرم افزار ها رو در داخل اون میذاره و شما از اون دانلود میکنید
مثلا" برای اوبونتو بعد از آپدیت کردن لیست مخازن با دستور زیر میتونید  virtualbox رو نصب کنید:
$ sudo apt update
$ sudo apt install virtualbox
01010011 01100001 01100100 01100101 01100111 01101000

آفلاین M!lad

  • Hero Member
  • *
  • ارسال: 957
  • YPSD
پاسخ : مشکل با نصب virtual box در اوبونتو 16.04
« پاسخ #12 : 04 مهر 1395، 10:11 ق‌ظ »
VirtualBox رو از مخازن خود اوبونتو نصب کنید: (نسخه 5.0.18‌ تو مخازن موجوده)
sudo apt install virtualbox
ضمن اینکه نسخه‌ای که دانلود کردید 32 بیتی هست، برنامه های 32بیتی رو سیستم‌عامل‌های 64بیتی قابل اجرا هستند ولی اگر اشتباه نکنم برخی از اونها یه Library خاص میخوان.


درود بر شماُ این مخزن که میگین چیه؟؟ من تازه اوبونتو نصب کردم میخوام virtual box نصب کنم روش مشکل برخوردم.

ویکی رو مطالعه کنید:
https://wiki.ubuntu.ir/wiki/مخزن

برای اطلاعات بیشتر:

https://help.ubuntu.com/community/Repositories/Ubuntu
...