انجمن‌های فارسی اوبونتو

لطفاً به انجمن‌ها وارد شده و یا جهت ورود ثبت‌نام نمائید

لطفاً جهت ورود نام کاربری و رمز عبورتان را وارد نمائید

نویسنده موضوع: مشکل در نصب skype [حل شد]  (دفعات بازدید: 1808 بار)

0 کاربر و 1 مهمان درحال مشاهده موضوع.

آفلاین javad-b

  • Jr. Member
  • *
  • ارسال: 81
  • جنسیت : پسر
مشکل در نصب skype [حل شد]
« : 25 اسفند 1391، 05:46 ب‌ظ »
سلام.
امروز مجبور شدم ابونتو رو دوباره نصب کنم، چون صبح به خاطر یه اشتباه به طور کامل پاک شد.
یکی از نیاز های اساسی من نرم افزاره skype ـه. روی ابونتو قبلیم بدون مشکل نصب شده بود اما روی این ابونتو جدید به هیچ وجه نصب نمیشه! نه از مخازن و نه از فایل .deb .
ابونتو ۱۲.۱۰ دارم و البته ۶۴ بیت.
وقتی دستور apt-get skype رو اجرا میکنم با این ارور مواجه میشم:
javad@HP-620:~$ sudo apt-get install skype
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.
و وقتی که میخوام پیش نیازی رو که گفته نصب کنم با این ارورها:
javad@HP-620:~$ sudo apt-get install skype-bin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype-bin:i386 : Depends: libasound2:i386 (>= 1.0.23) but it is not going to be installed
                  Depends: libc6:i386 (>= 2.7) but it is not going to be installed
                  Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
                  Depends: libqt4-dbus:i386 (>= 4:4.5.3) but it is not going to be installed
                  Depends: libqt4-network:i386 (>= 4:4.8.0) but it is not going to be installed
                  Depends: libqt4-xml:i386 (>= 4:4.5.3) but it is not going to be installed
                  Depends: libqtcore4:i386 (>= 4:4.7.0~beta1) but it is not going to be installed
                  Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
                  Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed
                  Depends: libstdc++6:i386 (>= 4.6) but it is not going to be installed
                  Depends: libx11-6:i386 but it is not going to be installed
                  Depends: libxext6:i386 but it is not going to be installed
                  Depends: libxss1:i386 but it is not going to be installed
                  Depends: libxv1:i386 but it is not going to be installed
                  Depends: libssl1.0.0:i386 but it is not going to be installed
                  Recommends: sni-qt:i386 but it is not going to be installed
                  Recommends: libasound2-plugins:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

و به دلایل نا معلوم خودش پیش نیاز ها رو نصب نمیکنه!
وقتی هم میخوام با فایل .deb نصب کنم:
javad@HP-620:~$ sudo dpkg -i skype_Ubuntu-current_amd64.deb
Selecting previously unselected package skype.
(Reading database ... 272068 files and directories currently installed.)
Unpacking skype (from skype_Ubuntu-current_amd64.deb) ...
dpkg: dependency problems prevent configuration of skype:
 skype depends on libasound2 (>= 1.0.23).
 skype depends on libc6 (>= 2.3.6-6~); however:
  Package libc6:i386 is not installed.
 skype depends on libc6 (>= 2.7); however:
  Package libc6:i386 is not installed.
 skype depends on libgcc1 (>= 1:4.1.1); however:
 skype depends on libqt4-dbus (>= 4:4.5.3); however:
  Package libqt4-dbus:i386 is not installed.
 skype depends on libqt4-network (>= 4:4.8.0); however:
  Package libqt4-network:i386 is not installed.
 skype depends on libqt4-xml (>= 4:4.5.3); however:
  Package libqt4-xml:i386 is not installed.
 skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
  Package libqtcore4:i386 is not installed.
 skype depends on libqtgui4 (>= 4:4.8.0); however:
  Package libqtgui4:i386 is not installed.
 skype depends on libqtwebkit4 (>= 2.2~2011week36); however:
 skype depends on libstdc++6 (>= 4.6); however:
 skype depends on libx11-6; however:
 skype depends on libxext6; however:
 skype depends on libxss1; however
dpkg: error processing skype (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 skype
چند ساعتی هم میشه که دارم جستجو میکنم ارور ها رو توی گوگل، ولی هنوز نتیجه ای نگرفتم. به شدت هم به این نرم افزار نیاز دارم! ممنون میشم اگه کمک کنید.
« آخرین ویرایش: 26 اسفند 1391، 07:35 ب‌ظ توسط JBonline »
Free software is not software, Free software is the culture and thinking, not only about the copyright.

آفلاین سلمان م.

  • ناظر انجمن
  • *
  • ارسال: 2565
  • جنسیت : پسر
  • GNU Operating System - سیستم عامل گنو
پاسخ : مشکل در نصب skype
« پاسخ #1 : 25 اسفند 1391، 07:57 ب‌ظ »
سلام. میگه یک سری از پیش‌نیازها رو که برای اسکایپ نیاز هست، نمی‌تونه توی مخازن پیدا کنه، (skype-bin)
سیستم رو یک بار به روز کن ببین درست نمی‌شه.
$ sudo apt-get update

آفلاین امید توانا

  • Hero Member
  • *
  • ارسال: 965
  • جنسیت : پسر
پاسخ : مشکل در نصب skype
« پاسخ #2 : 25 اسفند 1391، 08:14 ب‌ظ »
یه راهنمایی کلی: هرگاه توی نصب نرم‌افزار xxx گیر کردی این جمله جادویی رو گوگل کن:
how to install xxx ubuntu
در این صورت [ur=https://help.ubuntu.com/community/Skypel] این برگه[/url] نخستین پیشنهاد گوگل به شماست. اسکایپ تنها به صورت ۳۲ بیت ارائه می‌شه که برای نصب روی ۶۴ بیت باید یه مرحله اضافه انجام بدی
sudo dpkg --add-architecture i386
sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install skype

آفلاین javad-b

  • Jr. Member
  • *
  • ارسال: 81
  • جنسیت : پسر
پاسخ : مشکل در نصب skype
« پاسخ #3 : 25 اسفند 1391، 08:43 ب‌ظ »
سلام. میگه یک سری از پیش‌نیازها رو که برای اسکایپ نیاز هست، نمی‌تونه توی مخازن پیدا کنه، (skype-bin)
سیستم رو یک بار به روز کن ببین درست نمی‌شه.
$ sudo apt-get update
لیست مخازن به روز بودن، ولی برای احتیاط دوباره بروز کردم. تغییری نکرد اوضاع.
یه راهنمایی کلی: هرگاه توی نصب نرم‌افزار xxx گیر کردی این جمله جادویی رو گوگل کن:
how to install xxx ubuntu
در این صورت [ur=https://help.ubuntu.com/community/Skypel] این برگه[/url] نخستین پیشنهاد گوگل به شماست. اسکایپ تنها به صورت ۳۲ بیت ارائه می‌شه که برای نصب روی ۶۴ بیت باید یه مرحله اضافه انجام بدی
sudo dpkg --add-architecture i386
sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install skype
بالا هم گفتم، قبل از زدن تاپیک حسابی جستجو کردم توی اینترنت! این کار رو انجام داده بودم، ریپوز پارتنر رو هم از قبل داشتم. الان هم برای احتیاط دوباره این مراحل رو انجام دادم. تفاوتی نکرد متاسفانه.
جالب اینجاست که رو ابونتو قبلی بدون هیچ مشکل خاصی نصب شد.تمام ارتباطات من از طریق اسکایپه، یعنی هیچ راهی نیست که درستش کنم؟ :(
« آخرین ویرایش: 23 امرداد 1392، 12:03 ب‌ظ توسط JBonline »
Free software is not software, Free software is the culture and thinking, not only about the copyright.

آفلاین MHA152

  • High Hero Member
  • *
  • ارسال: 2740
  • جنسیت : پسر
  • من عاشق یونیکسی ها هستم
پاسخ : مشکل در نصب skype
« پاسخ #4 : 25 اسفند 1391، 08:47 ب‌ظ »
اگه مشکل اینترنت ندارید با دسترسی ریشه فایل های مربوط به اسکایپ را از آرشیو پاک کن وبزن دوباره دانلود کنه
« آخرین ویرایش: 25 اسفند 1391، 10:51 ب‌ظ توسط MHA152 »
بهتون پیشنهاد می کنم به دنیای بزرگ شبه−یونیکس وارد بشید و از پیشرفت لذت ببرید
جیمیلم

آفلاین javad-b

  • Jr. Member
  • *
  • ارسال: 81
  • جنسیت : پسر
پاسخ : مشکل در نصب skype
« پاسخ #5 : 25 اسفند 1391، 10:36 ب‌ظ »
اگه مشکل اینترنت ندارید با دسترسی ریشه فایل های مربوط به اسکایئ را از آرشیو ئاک کن وبزن دوباره دانلود کنه
چی میگی آقا؟ :-/ ربطی نداره.
Free software is not software, Free software is the culture and thinking, not only about the copyright.

آفلاین سلمان م.

  • ناظر انجمن
  • *
  • ارسال: 2565
  • جنسیت : پسر
  • GNU Operating System - سیستم عامل گنو
پاسخ : مشکل در نصب skype
« پاسخ #6 : 25 اسفند 1391، 10:53 ب‌ظ »
خب حالا لازم شد که یک خورده بیشتر وارد جزییات بشیم.
یه فایل هست به اسم sources.list که توی دیرکتوری زیر هست،
/etc/apt/توی این فایل، آدرس مخازن رسمی اوبونتو (چه فعال شده، چه فعال نشده) وجود داره. اگه فعال نشده باشه، جلوش # هست ولی اگه فعال شده باشه، دیگه اون علامت نیست. شما نگاه کن ببین که جلوی آدرس مربوط به partner (پاراتنر) علامت # هست یا نه. مثلن مال من (اوبونتو ۱۲٫۱۰) قسمت مربوط به پارتنر اینجوری هست.

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu quantal partner
deb-src http://archive.canonical.com/ubuntu quantal partner

اگه مخزنی که گفتم فعال شده باشه، سه تا فایل به آدرس زیر اضافه می‌شه:
/var/lib/apt/lists/به اسم‌های (برای اوبونتو ۱۲٫۱۰):
archive.canonical.com_ubuntu_dists_quantal_partner_binary-amd64_Packagesarchive.canonical.com_ubuntu_dists_quantal_partner_binary-i386_Packagesarchive.canonical.com_ubuntu_dists_quantal_partner_source_Sourcesخب، این سه تا فایل چی هستن؟ توی هر کدوم از فایل‌های بالا که گفتم، اسم، مشخصات، وابستگی‌ها و ... بسته‌های تو مخازن و همچنین آدرسی که مثلن apt-get باید بره و بسته‌های موجود  رو دانلود کنه، نوشته شده. توی فایل دومی که گفتم شما باز کن و ببین که بسته‌ی skype-bin موجود هست یا نه.

به جز روش‌های بالا، با استفاده از ترمینال هم می‌شه کار کرد، که سریع‌تر میشه. ولی اگه همین‌جوری کار کنی، بنظر من دید بهتری پیدا می‌کنی.

آفلاین امید توانا

  • Hero Member
  • *
  • ارسال: 965
  • جنسیت : پسر
پاسخ : مشکل در نصب skype
« پاسخ #7 : 25 اسفند 1391، 10:53 ب‌ظ »
من یه کم جستجو کردم و گویا مشکل کلی هست که برای خیلی‌ها پیش اومده. دلیلش هم در تنظیمات کتابخانه‌های ۳۲ بیت برای ۶۴ بیت هست. عده‌ای تونستن مشکل رو از روش این برگه حل کنن. شما هم یه آزمایشی کن.

آفلاین javad-b

  • Jr. Member
  • *
  • ارسال: 81
  • جنسیت : پسر
پاسخ : مشکل در نصب skype [حل شد]
« پاسخ #8 : 26 اسفند 1391، 07:34 ب‌ظ »
خب حالا لازم شد که یک خورده بیشتر وارد جزییات بشیم.
یه فایل هست به اسم sources.list که توی دیرکتوری زیر هست،
/etc/apt/توی این فایل، آدرس مخازن رسمی اوبونتو (چه فعال شده، چه فعال نشده) وجود داره. اگه فعال نشده باشه، جلوش # هست ولی اگه فعال شده باشه، دیگه اون علامت نیست. شما نگاه کن ببین که جلوی آدرس مربوط به partner (پاراتنر) علامت # هست یا نه. مثلن مال من (اوبونتو ۱۲٫۱۰) قسمت مربوط به پارتنر اینجوری هست.

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu quantal partner
deb-src http://archive.canonical.com/ubuntu quantal partner

اگه مخزنی که گفتم فعال شده باشه، سه تا فایل به آدرس زیر اضافه می‌شه:
/var/lib/apt/lists/به اسم‌های (برای اوبونتو ۱۲٫۱۰):
archive.canonical.com_ubuntu_dists_quantal_partner_binary-amd64_Packagesarchive.canonical.com_ubuntu_dists_quantal_partner_binary-i386_Packagesarchive.canonical.com_ubuntu_dists_quantal_partner_source_Sourcesخب، این سه تا فایل چی هستن؟ توی هر کدوم از فایل‌های بالا که گفتم، اسم، مشخصات، وابستگی‌ها و ... بسته‌های تو مخازن و همچنین آدرسی که مثلن apt-get باید بره و بسته‌های موجود  رو دانلود کنه، نوشته شده. توی فایل دومی که گفتم شما باز کن و ببین که بسته‌ی skype-bin موجود هست یا نه.

به جز روش‌های بالا، با استفاده از ترمینال هم می‌شه کار کرد، که سریع‌تر میشه. ولی اگه همین‌جوری کار کنی، بنظر من دید بهتری پیدا می‌کنی.
مشکل از ریپوز ها نیست اصلا، میدونم خودم :-"
من یه کم جستجو کردم و گویا مشکل کلی هست که برای خیلی‌ها پیش اومده. دلیلش هم در تنظیمات کتابخانه‌های ۳۲ بیت برای ۶۴ بیت هست. عده‌ای تونستن مشکل رو از روش این برگه حل کنن. شما هم یه آزمایشی کن.
خب با این روش حل شد :د مثل این که یه داون گرید لازم بود برای بعضی از پکیج ها! روش کار رو توضیح میدم تا اگه کس دیگه ای هم در آینده به این مشکل خورد بتونه استفاده کنه:
یه فایل به اسم preferences توی مسیر زیر ساختم و با نانو بازش کردم
sudo nano /etc/apt/preferencesاین ها رو توی این فایل نوشتم:
Package: *       
Pin: release a=quantal*
Pin-Priority: 2012
و سیو کردم. حالا این دستور:
sudo apt-get dist-upgrade
حدود ۵۰۰ مگ دانلود شد! و بعد نصب اسکایپ، البته من از روی پیکجی که دانلود کردم نصب میکنم: ( آخرین نسخه ای یه که توی سایت اسکابپ قابل دانلود هست و اونی هم که توی مخازن پارتنره همینه )
sudo dpkg -i skype-ubuntu-precise_4.1.0.20-1_i386.deb
نصب شد، البته نه به طور کامل. حالا برای کامل شدن پروسه نصب:
sudo apt-get -f installاینجا لایبرری ها مورد نیاز برای اجرای اسکایپ دانلود و نصب میشه. + skype-bin
اسکایپ اجرا شد :D
در پایان اون فایلی که اول ساختیم رو پاک کنید، چون باعث میشه apt-get آپدیت های جدید رو پیدا نکنه.
sudo rm /etc/apt/preferences
ممنون  از همگی، به خصوص جناب omidtavana.

ظاهرا یه باگه این قضیه، واقعا چرا باید نرم افزاری که توی مخازن رسمی هست روی یه ابونتو ۱۲.۱۰ خالص نصب نشه؟! من که نمیدونم.
« آخرین ویرایش: 26 اسفند 1391، 07:42 ب‌ظ توسط JBonline »
Free software is not software, Free software is the culture and thinking, not only about the copyright.

آفلاین Emadsmart

  • Jr. Member
  • *
  • ارسال: 51
  • جنسیت : پسر
پاسخ : مشکل در نصب skype [حل شد]
« پاسخ #9 : 20 اردیبهشت 1392، 10:06 ب‌ظ »
آقایون سلام...واقعا من دارم با این سیستم عامل حال میکنم چون توش همه دست به دست هم میدن تا مشکل ی نفر رو حل کنن و اصلا هم کار به این ندارن که طرف مبتدیه یا حرفیه...
آقا ببینید من اوبونتوی 13.04 دارم 64 بیتی از تو سایت خودذش من چون واسه 13.04 چیزی ندیدم واسه 12.04 اگه اشتباه نکنم دانلود کردم...بعدش اینکه خب با اینکه یا 30 مگابایتی رو دان کردهربود بعد از اجرا کردن فایل .deb باز هم تو softwarecenter شروع کرد به دانلود کردن و اصلا اون صفحه نصبی که همیشه میاورد و تو ویندوز هم میاره رو نیاورد بعد از دانلود کردن من هرچی زدم باز نشد بعدش خواستم برم پاکش کنم چون مال 12.04 بوده دیدم هیچ جایی واسهhttp://www.webupd8.org/2013/04/fix-skype-not-working-in-ubuntu-1304.html پاک کردنش تو softwarecenter نیستش (مثل بقیه  ی برنامه هایی که میریزیم) بعدش رفتم گوگل کردم...
http://www.webupd8.org/2013/04/fix-skype-not-working-in-ubuntu-1304.html
به این رسیدم اینایی که این گفت رو انجام دادم اومد و همه چیزشم در ظاهر درست شده فقط اینکه کلا کانتکت هامو اصلا نمیاره و نشون نمیده ینی انگار خالیه خالیه حتی جایی هم  واسه ریستور کردن نداره چون من بکاپ گرفتم حالا شما میگید چی کنم؟؟؟؟؟؟
من بسی نیاز دارم به اسکایپ آیا با دستوری که این بنده خدا داده هرکاری کردم رو پاک کنم؟و اینکه چجوری اینی که ریختم رو /اک کنم و اینکه چجوری نصبش کنم؟خیلی زیاد شد ولی دقیقه و مطمءنن مشکل خیلی هاست...

آفلاین علیرضاامیرصمیمی

  • High Hero Member
  • *
  • ارسال: 1404
  • جنسیت : پسر
  • ubuntu studio 14.04
    • وبلاگ من درباره لینوکس و میزکار XFCE
پاسخ : مشکل در نصب skype [حل شد]
« پاسخ #10 : 20 اردیبهشت 1392، 10:32 ب‌ظ »
آقایون سلام...واقعا من دارم با این سیستم عامل حال میکنم چون توش همه دست به دست هم میدن تا مشکل ی نفر رو حل کنن و اصلا هم کار به این ندارن که طرف مبتدیه یا حرفیه...
آقا ببینید من اوبونتوی 13.04 دارم 64 بیتی از تو سایت خودذش من چون واسه 13.04 چیزی ندیدم واسه 12.04 اگه اشتباه نکنم دانلود کردم...بعدش اینکه خب با اینکه یا 30 مگابایتی رو دان کردهربود بعد از اجرا کردن فایل .deb باز هم تو softwarecenter شروع کرد به دانلود کردن و اصلا اون صفحه نصبی که همیشه میاورد و تو ویندوز هم میاره رو نیاورد بعد از دانلود کردن من هرچی زدم باز نشد بعدش خواستم برم پاکش کنم چون مال 12.04 بوده دیدم هیچ جایی واسهhttp://www.webupd8.org/2013/04/fix-skype-not-working-in-ubuntu-1304.html پاک کردنش تو softwarecenter نیستش (مثل بقیه  ی برنامه هایی که میریزیم) بعدش رفتم گوگل کردم...
http://www.webupd8.org/2013/04/fix-skype-not-working-in-ubuntu-1304.html
به این رسیدم اینایی که این گفت رو انجام دادم اومد و همه چیزشم در ظاهر درست شده فقط اینکه کلا کانتکت هامو اصلا نمیاره و نشون نمیده ینی انگار خالیه خالیه حتی جایی هم  واسه ریستور کردن نداره چون من بکاپ گرفتم حالا شما میگید چی کنم؟؟؟؟؟؟
من بسی نیاز دارم به اسکایپ آیا با دستوری که این بنده خدا داده هرکاری کردم رو پاک کنم؟و اینکه چجوری اینی که ریختم رو /اک کنم و اینکه چجوری نصبش کنم؟خیلی زیاد شد ولی دقیقه و مطمءنن مشکل خیلی هاست...
ببخش منو که دخالت میکنم ولی چون بالای تاپیک زده حل شد،اگه میخوای جواب سوالت رو بگیری تاپیک جدا بزن،چون در غیر اینصورت دوستان فکر میکنن مشکل تاپیک حل شده و شاید واردش نشن و نتونی پاسخ مناسب بگیری